summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-10-01 21:20:21 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-10-01 21:20:21 +0000
commit51c45ba642fe1b449b01c4162fba78d4af968a64 (patch)
treeebea17067c6da9d513c43d8614294f14893b9ad0 /games-emulation
parentversion bump (diff)
downloadgentoo-2-51c45ba642fe1b449b01c4162fba78d4af968a64.tar.gz
gentoo-2-51c45ba642fe1b449b01c4162fba78d4af968a64.tar.bz2
gentoo-2-51c45ba642fe1b449b01c4162fba78d4af968a64.zip
version bump (bug #149757)
(Portage version: 2.1.2_pre1-r4)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/hatari/ChangeLog7
-rw-r--r--games-emulation/hatari/files/digest-hatari-0.903
-rw-r--r--games-emulation/hatari/hatari-0.90.ebuild61
3 files changed, 70 insertions, 1 deletions
diff --git a/games-emulation/hatari/ChangeLog b/games-emulation/hatari/ChangeLog
index a91e227f1713..610ee8ac5bc1 100644
--- a/games-emulation/hatari/ChangeLog
+++ b/games-emulation/hatari/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/hatari
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/ChangeLog,v 1.11 2006/03/24 21:36:14 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/ChangeLog,v 1.12 2006/10/01 21:20:21 mr_bones_ Exp $
+
+*hatari-0.90 (01 Oct 2006)
+
+ 01 Oct 2006; Michael Sterrett <mr_bones_@gentoo.org> +hatari-0.90.ebuild:
+ version bump (bug #149757)
24 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org> hatari-0.45.ebuild:
Removed sed-4 from DEPEND.
diff --git a/games-emulation/hatari/files/digest-hatari-0.90 b/games-emulation/hatari/files/digest-hatari-0.90
new file mode 100644
index 000000000000..787a612ab7b3
--- /dev/null
+++ b/games-emulation/hatari/files/digest-hatari-0.90
@@ -0,0 +1,3 @@
+MD5 2e5d1e329ebbf6c75ccab8c4f9a78f11 hatari-0.90.tar.gz 687029
+RMD160 914b97dd914329af858c6c0630671399b5231d78 hatari-0.90.tar.gz 687029
+SHA256 1dc883e06af223944c8bb5394134aa6f539623f5a31a505404e893c39e6cafda hatari-0.90.tar.gz 687029
diff --git a/games-emulation/hatari/hatari-0.90.ebuild b/games-emulation/hatari/hatari-0.90.ebuild
new file mode 100644
index 000000000000..e8fcbab07a13
--- /dev/null
+++ b/games-emulation/hatari/hatari-0.90.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/hatari-0.90.ebuild,v 1.1 2006/10/01 21:20:21 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Atari ST emulator"
+HOMEPAGE="http://hatari.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hatari/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ games-emulation/emutos"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e '/^CC/d' \
+ -e "/^CFLAGS/ s:=.*:=${CFLAGS}:" \
+ -e "/^DATADIR/ s:=.*:= ${GAMES_DATADIR}/${PN}:" Makefile.cnf \
+ || die "sed Makefile.cnf failed"
+}
+
+src_compile() {
+ # broken deps in the makefiles
+ emake -C src/uae-cpu gencpu || die "emake failed"
+ emake -C src || die "emake failed"
+}
+
+src_install() {
+ dogamesbin "${S}/src/hatari" || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins src/gui-sdl/font5x8.bmp src/gui-sdl/font10x16.bmp \
+ || die "doins failed"
+ dodoc readme.txt doc/*.txt
+ dohtml -r doc/
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "You need a TOS ROM to run hatari. EmuTOS, a free TOS implementation,"
+ einfo "has been installed in /usr/games/lib/ with a .img extension (there"
+ einfo "are several from which to choose)."
+ echo
+ einfo "Another option is to go to http://www.atari.st/ and get a real TOS:"
+ einfo " http://www.atari.st/"
+ echo
+ einfo "The first time you run hatari, you should configure it to find the"
+ einfo "TOS you prefer to use. Be sure to save your settings."
+ echo
+}