summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-23 08:50:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-23 08:50:50 +0000
commit5ed25794ce37d6e9b2a4780f1197778758f77017 (patch)
tree32e12eedfb8165d8cea6e020fe36274043ae78f7 /games-emulation
parentAdded media-libs/fontconfig. (diff)
downloadgentoo-2-5ed25794ce37d6e9b2a4780f1197778758f77017.tar.gz
gentoo-2-5ed25794ce37d6e9b2a4780f1197778758f77017.tar.bz2
gentoo-2-5ed25794ce37d6e9b2a4780f1197778758f77017.zip
prepgamesdirs; tidy
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/blight_input/blight_input-0.0.7.ebuild15
-rw-r--r--games-emulation/blight_input/blight_input-0.0.8-r1.ebuild16
-rw-r--r--games-emulation/blight_input/blight_input-0.0.8.ebuild14
3 files changed, 25 insertions, 20 deletions
diff --git a/games-emulation/blight_input/blight_input-0.0.7.ebuild b/games-emulation/blight_input/blight_input-0.0.7.ebuild
index 5ed9940fb2f0..be6fd89604b3 100644
--- a/games-emulation/blight_input/blight_input-0.0.7.ebuild
+++ b/games-emulation/blight_input/blight_input-0.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/blight_input/blight_input-0.0.7.ebuild,v 1.4 2004/07/14 14:32:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/blight_input/blight_input-0.0.7.ebuild,v 1.5 2004/09/23 08:50:50 mr_bones_ Exp $
inherit games
@@ -8,9 +8,9 @@ DESCRIPTION="An input plugin for the mupen64 N64 emulator"
SRC_URI="http://deltaanime.ath.cx/~blight/n64/blight_input_plugin/${P}.tgz"
HOMEPAGE="http://mupen64.emulation64.com/"
-KEYWORDS="x86 -ppc -sparc"
-IUSE=""
LICENSE="GPL-2"
+IUSE=""
+KEYWORDS="x86 -ppc -sparc"
SLOT="0"
DEPEND=">=media-libs/libsdl-1.2.4
@@ -25,8 +25,9 @@ src_unpack() {
}
src_install() {
- make install || die "make install failed"
- exeinto ${GAMES_LIBDIR}/mupen64/plugins
- doexe src/blight_input.so || die "doexe failed"
- dodoc AUTHORS ChangeLog README ToDo || die "dodoc failed"
+ make install || die "make install failed"
+ exeinto "${GAMES_LIBDIR}/mupen64/plugins"
+ doexe src/blight_input.so || die "doexe failed"
+ dodoc AUTHORS ChangeLog README ToDo
+ prepgamesdirs
}
diff --git a/games-emulation/blight_input/blight_input-0.0.8-r1.ebuild b/games-emulation/blight_input/blight_input-0.0.8-r1.ebuild
index 57929747318b..dd35d1b3c3d0 100644
--- a/games-emulation/blight_input/blight_input-0.0.8-r1.ebuild
+++ b/games-emulation/blight_input/blight_input-0.0.8-r1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/blight_input/blight_input-0.0.8-r1.ebuild,v 1.2 2004/06/24 22:24:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/blight_input/blight_input-0.0.8-r1.ebuild,v 1.3 2004/09/23 08:50:50 mr_bones_ Exp $
inherit games
-S="${WORKDIR}/blight_input-0.0.8-b"
DESCRIPTION="An input plugin for the mupen64 N64 emulator"
HOMEPAGE="http://mupen64.emulation64.com/"
SRC_URI="http://deltaanime.ath.cx/~blight/n64/blight_input_plugin/${P}-b.tar.gz"
@@ -18,17 +17,20 @@ DEPEND=">=media-libs/libsdl-1.2.4
media-libs/sdl-ttf
media-libs/freetype"
+S="${WORKDIR}/blight_input-0.0.8-b"
+
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# Death to all who distribute their stinking config.cache files!
rm -f config.cache
}
src_install() {
- make install || die "make install failed"
- exeinto ${GAMES_LIBDIR}/mupen64/plugins
- doexe src/blight_input.so || die "doexe failed"
- dodoc AUTHORS ChangeLog README ToDo || die "dodoc failed"
+ make install || die "make install failed"
+ exeinto "${GAMES_LIBDIR}/mupen64/plugins"
+ doexe src/blight_input.so || die "doexe failed"
+ dodoc AUTHORS ChangeLog README ToDo
+ prepgamesdirs
}
diff --git a/games-emulation/blight_input/blight_input-0.0.8.ebuild b/games-emulation/blight_input/blight_input-0.0.8.ebuild
index addbc6342afc..6e96a8a0ce49 100644
--- a/games-emulation/blight_input/blight_input-0.0.8.ebuild
+++ b/games-emulation/blight_input/blight_input-0.0.8.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/blight_input/blight_input-0.0.8.ebuild,v 1.4 2004/07/14 14:32:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/blight_input/blight_input-0.0.8.ebuild,v 1.5 2004/09/23 08:50:50 mr_bones_ Exp $
inherit games
-S=${WORKDIR}
DESCRIPTION="An input plugin for the mupen64 N64 emulator"
SRC_URI="http://deltaanime.ath.cx/~blight/n64/blight_input_plugin/${P}.tar.gz"
HOMEPAGE="http://mupen64.emulation64.com/"
@@ -17,17 +16,20 @@ SLOT="0"
DEPEND=">=media-libs/libsdl-1.2.4
media-libs/freetype"
+S="${WORKDIR}"
+
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# Death to all who distribute their stinking config.cache files!
rm -f config.cache
}
src_install() {
- make install || die "make install failed"
+ make install || die "make install failed"
exeinto ${GAMES_LIBDIR}/mupen64/plugins
- doexe src/blight_input.so || die "doexe failed"
- dodoc AUTHORS ChangeLog README ToDo || die "dodoc failed"
+ doexe src/blight_input.so || die "doexe failed"
+ dodoc AUTHORS ChangeLog README ToDo
+ prepgamesdirs
}