summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-20 06:47:32 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-20 06:47:32 +0000
commite9588d720d594526ab6646c9e6dff421552a89ae (patch)
treeb555643fd48f4da35b716462d191450e8c64abe4 /games-emulation
parentDont abort if tetex isnt installed #113023 by James Cave. (diff)
downloadgentoo-2-e9588d720d594526ab6646c9e6dff421552a89ae.tar.gz
gentoo-2-e9588d720d594526ab6646c9e6dff421552a89ae.tar.bz2
gentoo-2-e9588d720d594526ab6646c9e6dff421552a89ae.zip
add keyboard patch from xmess
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/xmame/ChangeLog6
-rw-r--r--games-emulation/xmame/files/xmame-0.101-keyboard.patch13
-rw-r--r--games-emulation/xmame/xmame-0.101.ebuild4
3 files changed, 21 insertions, 2 deletions
diff --git a/games-emulation/xmame/ChangeLog b/games-emulation/xmame/ChangeLog
index 3b0671664919..312ff94087c5 100644
--- a/games-emulation/xmame/ChangeLog
+++ b/games-emulation/xmame/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/xmame
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.53 2005/10/23 07:45:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.54 2005/11/20 06:47:32 vapier Exp $
+
+ 28 Oct 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/xmess-0.101-keyboard.patch, xmess-0.101.ebuild:
+ Add upstream patch to fix possible keyboard handling issues (bug #110671)
*xmame-0.101 (23 Oct 2005)
diff --git a/games-emulation/xmame/files/xmame-0.101-keyboard.patch b/games-emulation/xmame/files/xmame-0.101-keyboard.patch
new file mode 100644
index 000000000000..f9ebd3652624
--- /dev/null
+++ b/games-emulation/xmame/files/xmame-0.101-keyboard.patch
@@ -0,0 +1,13 @@
+diff -ru a/src/usrintrf.c b/src/usrintrf.c
+--- a/src/usrintrf.c 2005-10-22 13:37:29.000000000 -0700
++++ b/src/usrintrf.c 2005-10-28 00:11:20.296156336 -0700
+@@ -1219,7 +1219,8 @@
+ #ifdef MESS
+ if (osd_trying_to_quit())
+ return 1;
+- if (options.disable_normal_ui || !mess_ui_active())
++ if (options.disable_normal_ui ||
++ ((Machine->gamedrv->flags & GAME_COMPUTER) && !mess_ui_active()))
+ return 0;
+ #endif
+
diff --git a/games-emulation/xmame/xmame-0.101.ebuild b/games-emulation/xmame/xmame-0.101.ebuild
index 63b1945da40d..9852f6808739 100644
--- a/games-emulation/xmame/xmame-0.101.ebuild
+++ b/games-emulation/xmame/xmame-0.101.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.101.ebuild,v 1.1 2005/10/23 07:45:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.101.ebuild,v 1.2 2005/11/20 06:47:32 vapier Exp $
inherit flag-o-matic toolchain-funcs eutils games
@@ -56,6 +56,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-keyboard.patch #110671
+
case ${ARCH} in
x86) mycpu="i386";;
ia64) mycpu="ia64";;