summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-02-04 15:39:31 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-02-04 15:39:31 +0000
commitfd59f8770e48f889ad1b4a0c92a2591f93538b0f (patch)
tree80308d2d1bbdcbb4007604d52edafc5a0d00d065 /games-emulation
parentAdd ~amd64 keyword (diff)
downloadgentoo-2-fd59f8770e48f889ad1b4a0c92a2591f93538b0f.tar.gz
gentoo-2-fd59f8770e48f889ad1b4a0c92a2591f93538b0f.tar.bz2
gentoo-2-fd59f8770e48f889ad1b4a0c92a2591f93538b0f.zip
Fix --as-needed bug #247350
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r8 x86_64)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/gens/ChangeLog9
-rw-r--r--games-emulation/gens/files/gens-2.15.4-as-needed.patch11
-rw-r--r--games-emulation/gens/files/gens-2.15.5-as-needed.patch11
-rw-r--r--games-emulation/gens/gens-2.15.4.ebuild12
-rw-r--r--games-emulation/gens/gens-2.15.5.ebuild12
5 files changed, 41 insertions, 14 deletions
diff --git a/games-emulation/gens/ChangeLog b/games-emulation/gens/ChangeLog
index 9ea77a1f81ac..2d9606fc55df 100644
--- a/games-emulation/gens/ChangeLog
+++ b/games-emulation/gens/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/gens
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/ChangeLog,v 1.18 2008/10/14 16:22:27 mr_bones_ Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/ChangeLog,v 1.19 2009/02/04 15:39:31 tupone Exp $
+
+ 04 Feb 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/gens-2.15.4-as-needed.patch, +files/gens-2.15.5-as-needed.patch,
+ gens-2.15.4.ebuild, gens-2.15.5.ebuild:
+ Fix --as-needed bug #247350 by flameeyes@gentoo.org
*gens-2.15.5 (14 Oct 2008)
diff --git a/games-emulation/gens/files/gens-2.15.4-as-needed.patch b/games-emulation/gens/files/gens-2.15.4-as-needed.patch
new file mode 100644
index 000000000000..02aed32b802c
--- /dev/null
+++ b/games-emulation/gens/files/gens-2.15.4-as-needed.patch
@@ -0,0 +1,11 @@
+--- configure.old 2009-02-04 14:41:40.000000000 +0100
++++ configure 2009-02-04 14:48:52.000000000 +0100
+@@ -4929,7 +4929,7 @@
+ { echo "$as_me:$LINENO: result: $with_opengl" >&5
+ echo "${ECHO_T}$with_opengl" >&6; }
+ if test x$with_opengl = xyes; then
+- LDFLAGS="$LDFLAGS -lGL"
++ LIBS="$LIBS -lGL"
+
+ fi
+ fi
diff --git a/games-emulation/gens/files/gens-2.15.5-as-needed.patch b/games-emulation/gens/files/gens-2.15.5-as-needed.patch
new file mode 100644
index 000000000000..02aed32b802c
--- /dev/null
+++ b/games-emulation/gens/files/gens-2.15.5-as-needed.patch
@@ -0,0 +1,11 @@
+--- configure.old 2009-02-04 14:41:40.000000000 +0100
++++ configure 2009-02-04 14:48:52.000000000 +0100
+@@ -4929,7 +4929,7 @@
+ { echo "$as_me:$LINENO: result: $with_opengl" >&5
+ echo "${ECHO_T}$with_opengl" >&6; }
+ if test x$with_opengl = xyes; then
+- LDFLAGS="$LDFLAGS -lGL"
++ LIBS="$LIBS -lGL"
+
+ fi
+ fi
diff --git a/games-emulation/gens/gens-2.15.4.ebuild b/games-emulation/gens/gens-2.15.4.ebuild
index dc7b40f257ee..bd4c4cd914bd 100644
--- a/games-emulation/gens/gens-2.15.4.ebuild
+++ b/games-emulation/gens/gens-2.15.4.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/gens-2.15.4.ebuild,v 1.1 2008/09/10 22:00:55 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/gens-2.15.4.ebuild,v 1.2 2009/02/04 15:39:31 tupone Exp $
+EAPI=2
inherit eutils flag-o-matic games
DESCRIPTION="A Sega Genesis/CD/32X emulator"
@@ -19,10 +20,9 @@ RDEPEND="virtual/opengl
DEPEND="${RDEPEND}
>=dev-lang/nasm-0.98"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-romsdir.patch
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-romsdir.patch \
+ "${FILESDIR}"/${P}-as-needed.patch
append-ldflags -Wl,-z,noexecstack
}
diff --git a/games-emulation/gens/gens-2.15.5.ebuild b/games-emulation/gens/gens-2.15.5.ebuild
index 89f5f916a5d3..9674e668c3e6 100644
--- a/games-emulation/gens/gens-2.15.5.ebuild
+++ b/games-emulation/gens/gens-2.15.5.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/gens-2.15.5.ebuild,v 1.1 2008/10/14 16:22:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/gens-2.15.5.ebuild,v 1.2 2009/02/04 15:39:31 tupone Exp $
+EAPI=2
inherit eutils flag-o-matic games
DESCRIPTION="A Sega Genesis/CD/32X emulator"
@@ -19,10 +20,9 @@ RDEPEND="virtual/opengl
DEPEND="${RDEPEND}
>=dev-lang/nasm-0.98"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-romsdir.patch
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-romsdir.patch \
+ "${FILESDIR}"/${P}-as-needed.patch
append-ldflags -Wl,-z,noexecstack
}