summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-09-05 06:39:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-09-05 06:39:00 +0000
commit31bf7f3690c48dbbaefed02277dd8da5cd2f62db (patch)
tree1c99f3a1260ec11a837138390c4a4064409d9e41 /games-engines/frobtads/frobtads-0.12.ebuild
parentadd licenses for games-engines/frobtads (diff)
downloadgentoo-2-31bf7f3690c48dbbaefed02277dd8da5cd2f62db.tar.gz
gentoo-2-31bf7f3690c48dbbaefed02277dd8da5cd2f62db.tar.bz2
gentoo-2-31bf7f3690c48dbbaefed02277dd8da5cd2f62db.zip
initial commit - ebuild submitted by Nikos Chantziaras via bug #149764
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-engines/frobtads/frobtads-0.12.ebuild')
-rw-r--r--games-engines/frobtads/frobtads-0.12.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/games-engines/frobtads/frobtads-0.12.ebuild b/games-engines/frobtads/frobtads-0.12.ebuild
new file mode 100644
index 000000000000..66fa40a828f5
--- /dev/null
+++ b/games-engines/frobtads/frobtads-0.12.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/frobtads/frobtads-0.12.ebuild,v 1.1 2008/09/05 06:39:00 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Curses-based interpreter and development tools for TADS 2 and TADS 3 text adventures"
+HOMEPAGE="http://www.tads.org/frobtads.htm"
+SRC_URI="http://www.tads.org/frobtads/${P}.tar.gz
+ tads2compiler? ( http://www.tads.org/frobtads/${PN}-t2compiler-${PV}.tar.gz )
+ tads3compiler? ( http://www.tads.org/frobtads/${PN}-t3compiler-${PV}.tar.gz )"
+
+LICENSE="TADS2 TADS3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug tads2compiler tads3compiler"
+
+RESTRICT="!tads3compiler? ( test )"
+
+DEPEND="sys-libs/ncurses"
+
+src_unpack() {
+ unpack ${A}
+ if use tads2compiler; then
+ mv t2compiler/* "${S}"/t2compiler || die "mv t2compiler failed"
+ fi
+ if use tads3compiler; then
+ mv t3compiler/* "${S}"/t3compiler || die "mv t3compiler failed"
+ fi
+}
+
+src_compile() {
+ CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
+ egamesconf $(use_enable debug t3debug) || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
+src_test() {
+ if use debug; then
+ emake -j1 check || die "TADS 3 compiler test suite failed"
+ fi
+
+ emake -j1 sample || die "Failed to build test game"
+ ./frob -i plain -p samples/sample.t3 <<- END_FROB_TEST
+ save
+ testsave.sav
+ restore
+ testsave.sav
+ END_FROB_TEST
+ [[ $? -eq 0 ]] || die "Failed to run test game"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc doc/{AUTHORS,BUGS,ChangeLog,NEWS,README,SRC_GUIDELINES,THANKS}
+ prepgamesdirs
+}