summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-06-27 00:07:22 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-06-27 00:07:22 +0000
commit8c345c31b26410bb925ebed51402f8ae7ea9272f (patch)
tree3f2988ac72f9cafa719fd61229617ac6f66cfe45 /games-engines
parentadded missing patch (diff)
downloadgentoo-2-8c345c31b26410bb925ebed51402f8ae7ea9272f.tar.gz
gentoo-2-8c345c31b26410bb925ebed51402f8ae7ea9272f.tar.bz2
gentoo-2-8c345c31b26410bb925ebed51402f8ae7ea9272f.zip
version bump, remove old
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/renpy/ChangeLog9
-rw-r--r--games-engines/renpy/files/renpy-6.15.7-multiple-abi.patch (renamed from games-engines/renpy/files/renpy-6.15.5-multiple-abi.patch)235
-rw-r--r--games-engines/renpy/renpy-6.15.7.ebuild (renamed from games-engines/renpy/renpy-6.15.5.ebuild)2
3 files changed, 142 insertions, 104 deletions
diff --git a/games-engines/renpy/ChangeLog b/games-engines/renpy/ChangeLog
index b3b2dcae1093..724f75dd206c 100644
--- a/games-engines/renpy/ChangeLog
+++ b/games-engines/renpy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-engines/renpy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/renpy/ChangeLog,v 1.15 2013/06/05 12:27:29 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/renpy/ChangeLog,v 1.16 2013/06/27 00:07:21 hasufell Exp $
+
+*renpy-6.15.7 (27 Jun 2013)
+
+ 27 Jun 2013; Julian Ospald <hasufell@gentoo.org> -renpy-6.15.5.ebuild,
+ -files/renpy-6.15.5-multiple-abi.patch, +renpy-6.15.7.ebuild,
+ +files/renpy-6.15.7-multiple-abi.patch:
+ version bump, remove old
*renpy-6.15.5 (05 Jun 2013)
diff --git a/games-engines/renpy/files/renpy-6.15.5-multiple-abi.patch b/games-engines/renpy/files/renpy-6.15.7-multiple-abi.patch
index acd44aa3054a..c6b87ac868d7 100644
--- a/games-engines/renpy/files/renpy-6.15.5-multiple-abi.patch
+++ b/games-engines/renpy/files/renpy-6.15.7-multiple-abi.patch
@@ -1,95 +1,18 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Mon Feb 25 21:35:31 UTC 2013
-Subject: fix multiple abi support
+commit ea0351d8bf6404f5e8db2ff872885a19bf8a3f92
+Author: hasufell <hasufell@gentoo.org>
+Date: Thu Jun 27 02:01:17 2013 +0200
---- /dev/null
-+++ renpy-6.15.2-source/renpy/common.py
-@@ -0,0 +1,79 @@
-+# (the "Software"), to deal in the Software without restriction,
-+# including without limitation the rights to use, copy, modify, merge,
-+# publish, distribute, sublicense, and/or sell copies of the Software,
-+# and to permit persons to whom the Software is furnished to do so,
-+# subject to the following conditions:
-+#
-+# The above copyright notice and this permission notice shall be
-+# included in all copies or substantial portions of the Software.
-+#
-+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
-+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
-+# LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
-+# OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
-+# WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-+
-+import os
-+import sys
-+import warnings
-+from distutils.sysconfig import get_python_lib
-+
-+# Functions to be customized by distributors. ################################
-+
-+# Given the Ren'Py base directory (usually the directory containing
-+# this file), this is expected to return the path to the common directory.
-+def path_to_common(renpy_base):
-+ return renpy_base + "/renpy/common"
-+
-+# Given a directory holding a Ren'Py game, this is expected to return
-+# the path to a directory that will hold save files.
-+def path_to_saves(gamedir):
-+ import renpy #@UnresolvedImport
-+
-+ if not renpy.config.save_directory:
-+ return gamedir + "/saves"
-+
-+ # Search the path above Ren'Py for a directory named "Ren'Py Data".
-+ # If it exists, then use that for our save directory.
-+ path = renpy.config.renpy_base
-+
-+ while True:
-+ if os.path.isdir(path + "/Ren'Py Data"):
-+ return path + "/Ren'Py Data/" + renpy.config.save_directory
-+
-+ newpath = os.path.dirname(path)
-+ if path == newpath:
-+ break
-+ path = newpath
-+
-+ # Otherwise, put the saves in a platform-specific location.
-+ if renpy.android:
-+ return gamedir + "/saves"
-+
-+ elif renpy.macintosh:
-+ rv = "~/Library/RenPy/" + renpy.config.save_directory
-+ return os.path.expanduser(rv)
-+
-+ elif renpy.windows:
-+ if 'APPDATA' in os.environ:
-+ return os.environ['APPDATA'] + "/RenPy/" + renpy.config.save_directory
-+ else:
-+ rv = "~/RenPy/" + renpy.config.save_directory
-+ return os.path.expanduser(rv)
-+
-+ else:
-+ rv = "~/.renpy/" + renpy.config.save_directory
-+ return os.path.expanduser(rv)
-+
-+
-+# Returns the path to the Ren'Py base directory (containing common and
-+# the launcher, usually.)
-+def path_to_renpy_base():
-+ renpy_base = os.path.dirname(os.path.realpath(sys.argv[0]))
-+ renpy_base = get_python_lib() + "/renpy@SLOT@"
-+ renpy_base = os.environ.get('RENPY_BASE', renpy_base)
-+ renpy_base = os.path.abspath(renpy_base)
-+
-+ return renpy_base
---- renpy-6.15.2-source/renpy.py
-+++ renpy-6.15.2-source/renpy.py
-@@ -25,64 +25,9 @@
+ fix multiple abi support
+
+diff --git a/renpy.py b/renpy.py
+index 4ec5324..d873750 100644
+--- a/renpy.py
++++ b/renpy.py
+@@ -28,82 +28,9 @@
+ import os
import sys
import warnings
-
+-
-# Functions to be customized by distributors. ################################
-
-# Given the Ren'Py base directory (usually the directory containing
@@ -102,6 +25,26 @@ Subject: fix multiple abi support
-def path_to_saves(gamedir):
- import renpy #@UnresolvedImport
-
+- # Android.
+- if renpy.android:
+- paths = [
+- os.path.join(os.environ["ANDROID_OLD_PUBLIC"], "game/saves"),
+- os.path.join(os.environ["ANDROID_PRIVATE"], "saves"),
+- os.path.join(os.environ["ANDROID_PUBLIC"], "saves"),
+- ]
+-
+- for rv in paths:
+- if os.path.isdir(rv):
+- break
+-
+- print "Using savedir", rv
+-
+- # We return the last path as the default.
+-
+- return rv
+-
+-
+- # No save directory given.
- if not renpy.config.save_directory:
- return gamedir + "/saves"
-
@@ -119,10 +62,7 @@ Subject: fix multiple abi support
- path = newpath
-
- # Otherwise, put the saves in a platform-specific location.
-- if renpy.android:
-- return gamedir + "/saves"
--
-- elif renpy.macintosh:
+- if renpy.macintosh:
- rv = "~/Library/RenPy/" + renpy.config.save_directory
- return os.path.expanduser(rv)
-
@@ -154,12 +94,12 @@ Subject: fix multiple abi support
# The version of the Mac Launcher and py4renpy that we require.
macos_version = (6, 14, 0)
-@@ -97,21 +42,10 @@
+@@ -118,20 +45,9 @@ except:
print "Ren'Py requires at least python 2.6."
sys.exit(0)
-android = ("ANDROID_PRIVATE" in os.environ)
-
+-
-# Android requires us to add code to the main module, and to command some
-# renderers.
-if android:
@@ -168,7 +108,6 @@ Subject: fix multiple abi support
- __main__.path_to_common = path_to_common
- __main__.path_to_saves = path_to_saves
- os.environ["RENPY_RENDERER"] = "gl"
-- os.environ["RENPY_GL_ENVIRON"] = "limited"
-
def main():
@@ -177,7 +116,7 @@ Subject: fix multiple abi support
# Add paths.
if os.path.exists(renpy_base + "/module"):
-@@ -134,10 +68,6 @@
+@@ -154,10 +70,6 @@ def main():
print >>sys.stderr, "correctly, preserving the directory structure."
raise
@@ -188,9 +127,101 @@ Subject: fix multiple abi support
renpy.bootstrap.bootstrap(renpy_base)
if __name__ == "__main__":
---- renpy-6.15.2-source/renpy/main.py
-+++ renpy-6.15.2-source/renpy/main.py
-@@ -27,7 +27,7 @@
+diff --git a/renpy/common.py b/renpy/common.py
+new file mode 100644
+index 0000000..475b7e8
+--- /dev/null
++++ b/renpy/common.py
+@@ -0,0 +1,84 @@
++# This file is part of Ren'Py. The license below applies to Ren'Py only.
++# Games and other projects that use Ren'Py may use a different license.
++
++# Copyright 2004-2012 Tom Rothamel <pytom@bishoujo.us>
++#
++# Permission is hereby granted, free of charge, to any person
++# obtaining a copy of this software and associated documentation files
++# (the "Software"), to deal in the Software without restriction,
++# including without limitation the rights to use, copy, modify, merge,
++# publish, distribute, sublicense, and/or sell copies of the Software,
++# and to permit persons to whom the Software is furnished to do so,
++# subject to the following conditions:
++#
++# The above copyright notice and this permission notice shall be
++# included in all copies or substantial portions of the Software.
++#
++# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
++# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
++# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
++# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
++# LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
++# OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
++# WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
++
++import os
++import sys
++import warnings
++from distutils.sysconfig import get_python_lib
++
++# Functions to be customized by distributors. ################################
++
++# Given the Ren'Py base directory (usually the directory containing
++# this file), this is expected to return the path to the common directory.
++def path_to_common(renpy_base):
++ return renpy_base + "/renpy/common"
++
++# Given a directory holding a Ren'Py game, this is expected to return
++# the path to a directory that will hold save files.
++def path_to_saves(gamedir):
++ import renpy #@UnresolvedImport
++
++ # No save directory given.
++ if not renpy.config.save_directory:
++ return gamedir + "/saves"
++
++ # Search the path above Ren'Py for a directory named "Ren'Py Data".
++ # If it exists, then use that for our save directory.
++ path = renpy.config.renpy_base
++
++ while True:
++ if os.path.isdir(path + "/Ren'Py Data"):
++ return path + "/Ren'Py Data/" + renpy.config.save_directory
++
++ newpath = os.path.dirname(path)
++ if path == newpath:
++ break
++ path = newpath
++
++ # Otherwise, put the saves in a platform-specific location.
++ if renpy.macintosh:
++ rv = "~/Library/RenPy/" + renpy.config.save_directory
++ return os.path.expanduser(rv)
++
++ elif renpy.windows:
++ if 'APPDATA' in os.environ:
++ return os.environ['APPDATA'] + "/RenPy/" + renpy.config.save_directory
++ else:
++ rv = "~/RenPy/" + renpy.config.save_directory
++ return os.path.expanduser(rv)
++
++ else:
++ rv = "~/.renpy/" + renpy.config.save_directory
++ return os.path.expanduser(rv)
++
++
++# Returns the path to the Ren'Py base directory (containing common and
++# the launcher, usually.)
++def path_to_renpy_base():
++ renpy_base = os.path.dirname(os.path.realpath(sys.argv[0]))
++ renpy_base = get_python_lib() + "/renpy@SLOT@"
++ renpy_base = os.environ.get('RENPY_BASE', renpy_base)
++ renpy_base = os.path.abspath(renpy_base)
++
++ return renpy_base
+diff --git a/renpy/main.py b/renpy/main.py
+index 908e246..61027ec 100644
+--- a/renpy/main.py
++++ b/renpy/main.py
+@@ -27,7 +27,7 @@ import time
import zipfile
import subprocess
from cPickle import loads, dumps
@@ -199,7 +230,7 @@ Subject: fix multiple abi support
def save_persistent():
-@@ -147,7 +147,7 @@
+@@ -147,7 +147,7 @@ def main():
renpy.config.searchpath = [ renpy.config.gamedir ]
# Find the common directory.
@@ -208,7 +239,7 @@ Subject: fix multiple abi support
if os.path.isdir(commondir):
renpy.config.searchpath.append(commondir)
-@@ -206,7 +206,7 @@
+@@ -210,7 +210,7 @@ def main():
# Find the save directory.
if renpy.config.savedir is None:
diff --git a/games-engines/renpy/renpy-6.15.5.ebuild b/games-engines/renpy/renpy-6.15.7.ebuild
index 24c4d8fc733f..add17bab9c98 100644
--- a/games-engines/renpy/renpy-6.15.5.ebuild
+++ b/games-engines/renpy/renpy-6.15.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/renpy/renpy-6.15.5.ebuild,v 1.1 2013/06/05 12:27:29 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/renpy/renpy-6.15.7.ebuild,v 1.1 2013/06/27 00:07:22 hasufell Exp $
EAPI=5
PYTHON_COMPAT=( python2_6 python2_7 )