summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-07-23 16:07:26 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-07-23 16:07:26 +0000
commit2fea39213a313da41d25ada213c748d9eb0fe585 (patch)
tree91a0f009ae50e46b2becf85bc768745431015b46 /games-fps/blackshades/blackshades-20070723.ebuild
parentStable on ppc wrt bug 186080 (diff)
downloadgentoo-2-2fea39213a313da41d25ada213c748d9eb0fe585.tar.gz
gentoo-2-2fea39213a313da41d25ada213c748d9eb0fe585.tar.bz2
gentoo-2-2fea39213a313da41d25ada213c748d9eb0fe585.zip
New snapshot
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'games-fps/blackshades/blackshades-20070723.ebuild')
-rw-r--r--games-fps/blackshades/blackshades-20070723.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/games-fps/blackshades/blackshades-20070723.ebuild b/games-fps/blackshades/blackshades-20070723.ebuild
new file mode 100644
index 000000000000..3546f62a3914
--- /dev/null
+++ b/games-fps/blackshades/blackshades-20070723.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/blackshades/blackshades-20070723.ebuild,v 1.1 2007/07/23 16:07:26 nyhm Exp $
+
+inherit eutils games
+
+DESCRIPTION="you control a psychic bodyguard, and try to protect the VIP"
+HOMEPAGE="http://www.wolfire.com/blackshades.html
+ http://www.icculus.org/blackshades/"
+SRC_URI="http://filesingularity.timedoctor.org/Textures.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="blackshades"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/freealut
+ media-libs/libsdl"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -rf Data/Textures
+ rm -f ../Textures/{,Blood/}._*
+ mv -f ../Textures Data || die "mv failed"
+ epatch "${FILESDIR}"/${PN}-datadir.patch
+ sed -i \
+ -e "s/-O2 \(-Wall\) -g/${CXXFLAGS} \1/" \
+ -e "/^LINKER/s:$: ${LDFLAGS}:" \
+ Makefile \
+ || die "sed Makefile failed"
+ sed -i "s:@DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ Source/Main.cpp \
+ || die "sed Main.cpp failed"
+}
+
+src_install() {
+ newgamesbin objs/blackshades ${PN} || die "newgamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r Data || die "doins failed"
+ dodoc IF_THIS_IS_A_README_YOU_HAVE_WON Readme TODO uDevGame_Readme
+ make_desktop_entry ${PN} "Black Shades"
+ prepgamesdirs
+}