summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-10-07 14:39:00 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-10-07 14:39:00 +0000
commiteeedc8d6bb37fd2bcaaf665b169a9c25c46d9030 (patch)
treedb24ae00e0f3a0e429ee925f3b7c2a0049eac1f0 /games-fps/doom3-ducttape/doom3-ducttape-0006-r1.ebuild
parentEAPI=2 (diff)
downloadgentoo-2-eeedc8d6bb37fd2bcaaf665b169a9c25c46d9030.tar.gz
gentoo-2-eeedc8d6bb37fd2bcaaf665b169a9c25c46d9030.tar.bz2
gentoo-2-eeedc8d6bb37fd2bcaaf665b169a9c25c46d9030.zip
EAPI=2
(Portage version: 2.2_rc44/cvs/Linux x86_64)
Diffstat (limited to 'games-fps/doom3-ducttape/doom3-ducttape-0006-r1.ebuild')
-rw-r--r--games-fps/doom3-ducttape/doom3-ducttape-0006-r1.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/games-fps/doom3-ducttape/doom3-ducttape-0006-r1.ebuild b/games-fps/doom3-ducttape/doom3-ducttape-0006-r1.ebuild
index b47ed95fd923..d1dc417ce61e 100644
--- a/games-fps/doom3-ducttape/doom3-ducttape-0006-r1.ebuild
+++ b/games-fps/doom3-ducttape/doom3-ducttape-0006-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3-ducttape/doom3-ducttape-0006-r1.ebuild,v 1.3 2009/10/01 20:51:39 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3-ducttape/doom3-ducttape-0006-r1.ebuild,v 1.4 2009/10/07 14:39:00 nyhm Exp $
+
+EAPI=2
MOD_DESC="sticks flashlights to your machinegun and shotgun"
MOD_NAME="Duct Tape"
@@ -15,20 +17,20 @@ LICENSE="as-is"
KEYWORDS="amd64 x86"
IUSE="dedicated opengl"
-S=${WORKDIR}
-
src_unpack() {
- games-mods_src_unpack
- mkdir -p ${MOD_DIR}
- mv pak008.pk4 ${MOD_DIR} || die
+ mkdir ${MOD_DIR}
+ cd ${MOD_DIR}
+ unpack ${A}
+}
+
+src_prepare() {
+ rm -f ${MOD_DIR}/pak002.pk4 # for doom3-roe
}
pkg_postinst() {
games-mods_pkg_postinst
elog "To use old saved games with this mod, run:"
- echo
- elog "mkdir -p ~/.doom3/ducttape"
- elog "cp -r ~/.doom3/base/savegames ~/.doom3/ducttape"
- echo
+ elog " mkdir -p ~/.doom3/ducttape"
+ elog " cp -r ~/.doom3/base/savegames ~/.doom3/ducttape"
}