summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-05-31 23:53:06 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-05-31 23:53:06 +0000
commitece04fa5d4608df3ee16b332b3c2d98ed0167221 (patch)
tree702bd62a29c721099c7da0b2d367e6b354bd70b4 /games-fps/doomsday-resources/doomsday-resources-1.01.ebuild
parentStable on amd64 wrt security Bug #130889. (diff)
downloadgentoo-2-ece04fa5d4608df3ee16b332b3c2d98ed0167221.tar.gz
gentoo-2-ece04fa5d4608df3ee16b332b3c2d98ed0167221.tar.bz2
gentoo-2-ece04fa5d4608df3ee16b332b3c2d98ed0167221.zip
Initial import. Ebuild by Paul Bredbury <brebs@sent.com> and edited by me. Closing bug #117098.
(Portage version: 2.1_rc3-r2)
Diffstat (limited to 'games-fps/doomsday-resources/doomsday-resources-1.01.ebuild')
-rw-r--r--games-fps/doomsday-resources/doomsday-resources-1.01.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-fps/doomsday-resources/doomsday-resources-1.01.ebuild b/games-fps/doomsday-resources/doomsday-resources-1.01.ebuild
new file mode 100644
index 000000000000..0534156c97da
--- /dev/null
+++ b/games-fps/doomsday-resources/doomsday-resources-1.01.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doomsday-resources/doomsday-resources-1.01.ebuild,v 1.1 2006/05/31 23:53:06 wolf31o2 Exp $
+
+inherit eutils games
+
+DESCRIPTION="Improved models & textures for doomsday"
+HOMEPAGE="http://www.doomsdayhq.com/"
+SRC_URI="mirror://sourceforge/deng/jdoom-resource-pack-${PV}.zip
+ mirror://sourceforge/deng/jdoom-details.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="games-fps/doomsday"
+
+S=${WORKDIR}
+
+src_install() {
+ insinto /usr/share/games/deng/Data/jDoom/Auto/
+ doins data/jDoom/* *.pk3
+
+ # The definitions file cannot be auto-loaded
+ insinto /usr/share/games/deng/Defs/jDoom/
+ doins defs/jDoom/*
+
+ dodoc *.txt docs/*
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ # Must specify full path to .ded file
+ einfo "Add the following to the jdoom/doomsday command-line options:"
+ einfo " -def /usr/share/games/deng/Defs/jDoom/jDRP.ded"
+ echo
+}