summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-05-09 14:25:11 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-05-09 14:25:11 +0000
commitb3077773bcb7b35144a27c95ab79b02d48ce650b (patch)
treeef8bba0038e3128252ec9c8bfd1ea83816f6e18b /games-fps/rtcw
parentVersion bump with new patch. Marking stable on amd64 and x86. Removing olde... (diff)
downloadgentoo-2-b3077773bcb7b35144a27c95ab79b02d48ce650b.tar.gz
gentoo-2-b3077773bcb7b35144a27c95ab79b02d48ce650b.tar.bz2
gentoo-2-b3077773bcb7b35144a27c95ab79b02d48ce650b.zip
Version bump with new patch. Marking stable on amd64 and x86. Removing older versions. Closing bug #132377.
(Portage version: 2.1_pre10-r4)
Diffstat (limited to 'games-fps/rtcw')
-rw-r--r--games-fps/rtcw/ChangeLog9
-rw-r--r--games-fps/rtcw/files/digest-rtcw-1.41b6
-rw-r--r--games-fps/rtcw/rtcw-1.41b.ebuild106
3 files changed, 120 insertions, 1 deletions
diff --git a/games-fps/rtcw/ChangeLog b/games-fps/rtcw/ChangeLog
index 2c9d9147faee..f17a0ce4534a 100644
--- a/games-fps/rtcw/ChangeLog
+++ b/games-fps/rtcw/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-fps/rtcw
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/rtcw/ChangeLog,v 1.26 2006/03/31 21:18:40 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/rtcw/ChangeLog,v 1.27 2006/05/09 14:25:11 wolf31o2 Exp $
+
+*rtcw-1.41b (09 May 2006)
+
+ 09 May 2006; Chris Gianelloni <wolf31o2@gentoo.org> -rtcw-1.41-r2.ebuild,
+ +rtcw-1.41b.ebuild:
+ Version bump with new patch. Marking stable on amd64 and x86. Removing older
+ versions. Closing bug #132377.
31 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org> rtcw-1.41-r2.ebuild:
Changed nomirror to mirror and nostrip to strip.
diff --git a/games-fps/rtcw/files/digest-rtcw-1.41b b/games-fps/rtcw/files/digest-rtcw-1.41b
new file mode 100644
index 000000000000..47c493a408fa
--- /dev/null
+++ b/games-fps/rtcw/files/digest-rtcw-1.41b
@@ -0,0 +1,6 @@
+MD5 2aa37968aff19d665ed6c001773b2de3 wolf-linux-1.41b.x86.run 73940068
+RMD160 d26daffd2d53b40aa8e3ae579be3454e179b058b wolf-linux-1.41b.x86.run 73940068
+SHA256 2921425c1b429147c1bc6f0c6a8664bec502ae86a2d6bccfaa1162f75dce89f3 wolf-linux-1.41b.x86.run 73940068
+MD5 9e3d7a7432d80e9b45b192ce51554608 wolf-linux-goty-maps.x86.run 51930759
+RMD160 354d6b6d03e4962440a5bd76ffda224ad597b73e wolf-linux-goty-maps.x86.run 51930759
+SHA256 d80994fc3c89348ac08b616f0e03d6cfca3d2faae89491dd294501cac1cad952 wolf-linux-goty-maps.x86.run 51930759
diff --git a/games-fps/rtcw/rtcw-1.41b.ebuild b/games-fps/rtcw/rtcw-1.41b.ebuild
new file mode 100644
index 000000000000..e4d7c4650167
--- /dev/null
+++ b/games-fps/rtcw/rtcw-1.41b.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/rtcw/rtcw-1.41b.ebuild,v 1.1 2006/05/09 14:25:11 wolf31o2 Exp $
+
+inherit eutils games
+
+MAPS="wolf-linux-goty-maps.x86.run"
+DESCRIPTION="Return to Castle Wolfenstein - Long awaited sequel to Wolfenstein 3D"
+HOMEPAGE="http://games.activision.com/games/wolfenstein/"
+SRC_URI="mirror://3dgamers/returnwolfenstein/Missions/${MAPS}
+ mirror://idsoftware/wolf/linux/wolf-linux-${PV}.x86.run"
+# mirror://3dgamers/returnwolfenstein/wolf-linux-${PV}.x86.run
+
+LICENSE="RTCW"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="opengl dedicated"
+RESTRICT="strip mirror"
+
+RDEPEND="sys-libs/glibc
+ dedicated? (
+ app-misc/screen )
+ !dedicated? (
+ virtual/opengl
+ || (
+ (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXau
+ x11-libs/libXdmcp )
+ virtual/x11 ) )
+ opengl? (
+ virtual/opengl
+ || (
+ (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXau
+ x11-libs/libXdmcp )
+ virtual/x11 ) )
+ amd64? (
+ app-emulation/emul-linux-x86-xlibs )"
+
+S=${WORKDIR}
+
+GAMES_CHECK_LICENSE="yes"
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+src_unpack() {
+ unpack_makeself wolf-linux-goty-maps.x86.run
+ unpack_makeself wolf-linux-${PV}.x86.run
+}
+
+src_install() {
+ insinto "${dir}"
+ doins -r main Docs pb
+
+ exeinto "${dir}"
+ doexe bin/Linux/x86/*.x86 openurl.sh || die "copying exe"
+
+ games_make_wrapper rtcwmp ./wolf.x86 "${dir}" "${dir}"
+ games_make_wrapper rtcwsp ./wolfsp.x86 "${dir}" "${dir}"
+
+ if use dedicated; then
+ games_make_wrapper wolf-ded ./wolfded.x86 "${dir}" "${dir}"
+ exeinto /etc/init.d
+ newexe "${FILESDIR}"/wolf-ded.rc wolf-ded
+ dosed "s:GENTOO_DIR:${dir}:" /etc/init.d/wolf-ded
+ fi
+
+ insinto ${dir}
+ doins WolfMP.xpm WolfSP.xpm QUICKSTART CHANGES RTCW-README-1.4.txt
+ doicon WolfMP.xpm WolfSP.xpm
+
+ prepgamesdirs
+ make_desktop_entry rtcwmp "Return to Castle Wolfenstein (MP)" WolfMP.xpm
+ make_desktop_entry rtcwsp "Return to Castle Wolfenstein (SP)" WolfSP.xpm
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ ewarn "There are two possible security bugs in this package, both causing a"
+ ewarn "denial of service. One affects the game when running a server, the"
+ ewarn "other when running as a client."
+ ewarn "For more information, see bug #82149."
+ echo
+ einfo "You need to copy pak0.pk3, mp_pak0.pk3, mp_pak1.pk3, mp_pak2.pk3,"
+ einfo "sp_pak1.pk3 and sp_pak2.pk3 from a Window installation into ${dir}/main/"
+ echo
+ einfo "To play the game run:"
+ einfo " rtcwsp (single-player)"
+ einfo " rtcwmp (multi-player)"
+ echo
+ if use dedicated
+ then
+ einfo "To start a dedicated server run:"
+ einfo " /etc/init.d/wolf-ded start"
+ echo
+ einfo "To run the dedicated server at boot, type:"
+ einfo " rc-update add wolf-ded default"
+ echo
+ einfo "The dedicated server is started under the ${GAMES_USER_DED} user account"
+ echo
+ fi
+}