summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-06-13 21:14:13 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-06-13 21:14:13 +0000
commit2c8c4a72b31f47ce00a3ce37b069539499cee0b0 (patch)
treeb7c0057214a48a6c05c6804bf579cd50d3e0a146 /games-fps/tremulous
parentVersion bump, for not including .svn directories in the (mirrored) tarball ma... (diff)
downloadgentoo-2-2c8c4a72b31f47ce00a3ce37b069539499cee0b0.tar.gz
gentoo-2-2c8c4a72b31f47ce00a3ce37b069539499cee0b0.tar.bz2
gentoo-2-2c8c4a72b31f47ce00a3ce37b069539499cee0b0.zip
Patch for gcc-4.2
(Portage version: 2.1.2.9)
Diffstat (limited to 'games-fps/tremulous')
-rw-r--r--games-fps/tremulous/ChangeLog6
-rw-r--r--games-fps/tremulous/files/tremulous-1.1.0-gcc42.patch20
-rw-r--r--games-fps/tremulous/tremulous-1.1.0-r1.ebuild4
-rw-r--r--games-fps/tremulous/tremulous-1.1.0.ebuild4
4 files changed, 30 insertions, 4 deletions
diff --git a/games-fps/tremulous/ChangeLog b/games-fps/tremulous/ChangeLog
index 2164422e245c..5fc68866bbab 100644
--- a/games-fps/tremulous/ChangeLog
+++ b/games-fps/tremulous/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/tremulous
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/tremulous/ChangeLog,v 1.5 2007/05/18 22:46:46 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/tremulous/ChangeLog,v 1.6 2007/06/13 21:14:13 nyhm Exp $
+
+ 13 Jun 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/tremulous-1.1.0-gcc42.patch, tremulous-1.1.0-r1.ebuild:
+ Patch for gcc-4.2
*tremulous-1.1.0-r1 (18 May 2007)
diff --git a/games-fps/tremulous/files/tremulous-1.1.0-gcc42.patch b/games-fps/tremulous/files/tremulous-1.1.0-gcc42.patch
new file mode 100644
index 000000000000..f04398fa9c5d
--- /dev/null
+++ b/games-fps/tremulous/files/tremulous-1.1.0-gcc42.patch
@@ -0,0 +1,20 @@
+--- src/tools/asm/cmdlib.c
++++ src/tools/asm/cmdlib.c
+@@ -313,7 +313,7 @@
+ char *ExpandPath (const char *path)
+ {
+ static char full[1024];
+- if (!qdir)
++ if (!qdir[0])
+ Error ("ExpandPath called without qdir set");
+ if (path[0] == '/' || path[0] == '\\' || path[1] == ':') {
+ strcpy( full, path );
+@@ -326,7 +326,7 @@
+ char *ExpandGamePath (const char *path)
+ {
+ static char full[1024];
+- if (!qdir)
++ if (!qdir[0])
+ Error ("ExpandGamePath called without qdir set");
+ if (path[0] == '/' || path[0] == '\\' || path[1] == ':') {
+ strcpy( full, path );
diff --git a/games-fps/tremulous/tremulous-1.1.0-r1.ebuild b/games-fps/tremulous/tremulous-1.1.0-r1.ebuild
index e9c196fafa0f..158259043f80 100644
--- a/games-fps/tremulous/tremulous-1.1.0-r1.ebuild
+++ b/games-fps/tremulous/tremulous-1.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/tremulous/tremulous-1.1.0-r1.ebuild,v 1.1 2007/05/18 22:46:46 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/tremulous/tremulous-1.1.0-r1.ebuild,v 1.2 2007/06/13 21:14:13 nyhm Exp $
inherit eutils toolchain-funcs games
@@ -46,6 +46,8 @@ src_unpack() {
cd ${PN}
unpack ./${P}-src.tar.gz
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc42.patch
}
src_compile() {
diff --git a/games-fps/tremulous/tremulous-1.1.0.ebuild b/games-fps/tremulous/tremulous-1.1.0.ebuild
index 02dddd2a4114..7300f395fccd 100644
--- a/games-fps/tremulous/tremulous-1.1.0.ebuild
+++ b/games-fps/tremulous/tremulous-1.1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/tremulous/tremulous-1.1.0.ebuild,v 1.4 2006/12/05 18:03:48 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/tremulous/tremulous-1.1.0.ebuild,v 1.5 2007/06/13 21:14:13 nyhm Exp $
inherit eutils toolchain-funcs games