summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-10-05 17:46:44 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-10-05 17:46:44 +0000
commit26a22df60bb3d2877700518eeb2d57767d33d09c (patch)
tree2ad49e9fb30ba38fef44f455a3bae867264c9ca1 /games-fps
parentVersion bump for xorg-server-1.7. Remove old. (diff)
downloadgentoo-2-26a22df60bb3d2877700518eeb2d57767d33d09c.tar.gz
gentoo-2-26a22df60bb3d2877700518eeb2d57767d33d09c.tar.bz2
gentoo-2-26a22df60bb3d2877700518eeb2d57767d33d09c.zip
The code seems fragile. strip-flags to fix at least bug #285448 and protect against possible other flag-related bugs.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/warsow/ChangeLog6
-rw-r--r--games-fps/warsow/warsow-0.5.ebuild5
2 files changed, 8 insertions, 3 deletions
diff --git a/games-fps/warsow/ChangeLog b/games-fps/warsow/ChangeLog
index 0c3dbd6184b6..e731c0f46255 100644
--- a/games-fps/warsow/ChangeLog
+++ b/games-fps/warsow/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/warsow
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/warsow/ChangeLog,v 1.23 2009/09/02 19:29:22 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/warsow/ChangeLog,v 1.24 2009/10/05 17:46:44 mr_bones_ Exp $
+
+ 05 Oct 2009; Michael Sterrett <mr_bones_@gentoo.org> warsow-0.5.ebuild:
+ The code seems fragile. strip-flags to fix at least bug #285448 and
+ protect against possible other flag-related bugs.
*warsow-0.5 (02 Sep 2009)
diff --git a/games-fps/warsow/warsow-0.5.ebuild b/games-fps/warsow/warsow-0.5.ebuild
index 5bb6634fd7cc..3e3a7a6d91c5 100644
--- a/games-fps/warsow/warsow-0.5.ebuild
+++ b/games-fps/warsow/warsow-0.5.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/warsow/warsow-0.5.ebuild,v 1.1 2009/09/02 19:29:22 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/warsow/warsow-0.5.ebuild,v 1.2 2009/10/05 17:46:44 mr_bones_ Exp $
EAPI=2
-inherit eutils toolchain-funcs versionator games
+inherit flag-o-matic eutils toolchain-funcs versionator games
MY_P=${PN}_${PV}
DESCRIPTION="Multiplayer FPS based on the QFusion engine (evolved from Quake 2)"
@@ -50,6 +50,7 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-build.patch \
"${FILESDIR}"/${P}-openal.patch
+ strip-flags
}
src_compile() {