summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2008-03-04 04:30:25 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2008-03-04 04:30:25 +0000
commit4957e937d4c6fd2498475c5f9a1ca7dca76d3892 (patch)
tree568b80c70f3bd6032bbae08668f4b725242c4a31 /games-fps
parentKeyword split KDE for HPPA. (diff)
downloadgentoo-2-4957e937d4c6fd2498475c5f9a1ca7dca76d3892.tar.gz
gentoo-2-4957e937d4c6fd2498475c5f9a1ca7dca76d3892.tar.bz2
gentoo-2-4957e937d4c6fd2498475c5f9a1ca7dca76d3892.zip
Updated to check FILESDIR and DISTDIR for a PNG icon for bug #205362.
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake4-bin/ChangeLog8
-rw-r--r--games-fps/quake4-bin/quake4-bin-1.4.2.ebuild20
2 files changed, 20 insertions, 8 deletions
diff --git a/games-fps/quake4-bin/ChangeLog b/games-fps/quake4-bin/ChangeLog
index 379d6d161ff1..943d9bc2387b 100644
--- a/games-fps/quake4-bin/ChangeLog
+++ b/games-fps/quake4-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/quake4-bin
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake4-bin/ChangeLog,v 1.34 2007/08/20 17:23:52 wolf31o2 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake4-bin/ChangeLog,v 1.35 2008/03/04 04:30:25 wolf31o2 Exp $
+
+ 04 Mar 2008; Chris Gianelloni <wolf31o2@gentoo.org>
+ quake4-bin-1.4.2.ebuild:
+ Updated to check FILESDIR and DISTDIR for a PNG icon for bug #205362.
20 Aug 2007; Chris Gianelloni <wolf31o2@gentoo.org>
quake4-bin-1.4.2.ebuild:
diff --git a/games-fps/quake4-bin/quake4-bin-1.4.2.ebuild b/games-fps/quake4-bin/quake4-bin-1.4.2.ebuild
index 3698a4eaffee..d7616b696a3a 100644
--- a/games-fps/quake4-bin/quake4-bin-1.4.2.ebuild
+++ b/games-fps/quake4-bin/quake4-bin-1.4.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake4-bin/quake4-bin-1.4.2.ebuild,v 1.2 2007/08/20 17:23:52 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake4-bin/quake4-bin-1.4.2.ebuild,v 1.3 2008/03/04 04:30:25 wolf31o2 Exp $
inherit eutils games
@@ -109,10 +109,18 @@ src_install() {
doicon quake4.bmp || die "doicon"
games_make_wrapper quake4 "./quake4.x86" "${dir}" "${dir}"
games_make_wrapper quake4-smp ./quake4smp.x86 "${dir}" "${dir}"
-# doicon ${FILESDIR}/quake4.png || die "copying icon"
-# make_desktop_entry quake4 "Quake IV" quake4.png
-# make_desktop_entry quake4-smp "Quake IV (SMP)" quake4.png
- make_desktop_entry quake4 "Quake IV" /usr/share/pixmaps/quake4.bmp
+ icon_path="quake4"
+ if [ -e "${FILESDIR}"/quake4.png ]
+ then
+ doicon "${FILESDIR}"/quake4.png || die "copying icon"
+ elif [ -e "${DISTDIR}"/quake4.png ]
+ then
+ doicon "${DISTDIR}"/quake4.png || die "copying icon"
+ else
+ icon_path=/usr/share/pixmaps/quake4.bmp
+ fi
+ make_desktop_entry quake4 "Quake IV" ${icon_path}
+ make_desktop_entry quake4-smp "Quake IV (SMP)" ${icon_path}
fi
prepgamesdirs