summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-04-06 18:58:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-04-06 18:58:11 +0000
commit77eb018219d3f45fc5d3486418566e1e0807f44c (patch)
treeb6322852fef147473896c8a8964f84c26e87df3a /games-fps
parentFix building with newer bison-3 #509572 by jannis. (diff)
downloadgentoo-2-77eb018219d3f45fc5d3486418566e1e0807f44c.tar.gz
gentoo-2-77eb018219d3f45fc5d3486418566e1e0807f44c.tar.bz2
gentoo-2-77eb018219d3f45fc5d3486418566e1e0807f44c.zip
add ode use flag for alternate physics-engine support from dev-games/ode (bug #475468)
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/xonotic/ChangeLog7
-rw-r--r--games-fps/xonotic/metadata.xml3
-rw-r--r--games-fps/xonotic/xonotic-0.8.0.ebuild5
3 files changed, 12 insertions, 3 deletions
diff --git a/games-fps/xonotic/ChangeLog b/games-fps/xonotic/ChangeLog
index 4475d41bccf8..83f812fefc5c 100644
--- a/games-fps/xonotic/ChangeLog
+++ b/games-fps/xonotic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/xonotic
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/ChangeLog,v 1.17 2015/01/16 09:40:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/ChangeLog,v 1.18 2015/04/06 18:58:11 mr_bones_ Exp $
+
+ 06 Apr 2015; Michael Sterrett <mr_bones_@gentoo.org> metadata.xml,
+ xonotic-0.8.0.ebuild:
+ add ode use flag for alternate physics-engine support from dev-games/ode (bug
+ #475468)
*xonotic-0.8.0 (16 Jan 2015)
diff --git a/games-fps/xonotic/metadata.xml b/games-fps/xonotic/metadata.xml
index d3c2cc926f0b..1a4019ae7fcd 100644
--- a/games-fps/xonotic/metadata.xml
+++ b/games-fps/xonotic/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>games</herd>
+<use>
+ <flag name="ode">Enable support for physics engine from <pkg>dev-games/ode</pkg></flag>
+</use>
</pkgmetadata>
diff --git a/games-fps/xonotic/xonotic-0.8.0.ebuild b/games-fps/xonotic/xonotic-0.8.0.ebuild
index 2dd630a2c20f..1e4ce3bf0a07 100644
--- a/games-fps/xonotic/xonotic-0.8.0.ebuild
+++ b/games-fps/xonotic/xonotic-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/xonotic-0.8.0.ebuild,v 1.1 2015/01/16 09:40:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/xonotic-0.8.0.ebuild,v 1.2 2015/04/06 18:58:11 mr_bones_ Exp $
EAPI=5
inherit eutils check-reqs games
@@ -13,7 +13,7 @@ SRC_URI="http://dl.xonotic.org/${P}.zip"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="alsa debug dedicated doc sdl"
+IUSE="alsa debug dedicated doc ode sdl"
UIRDEPEND="
media-libs/libogg
@@ -30,6 +30,7 @@ UIRDEPEND="
virtual/opengl
media-libs/freetype:2
alsa? ( media-libs/alsa-lib )
+ ode? ( dev-games/ode[double-precision] )
sdl? ( media-libs/libsdl[X,sound,joystick,opengl,video,alsa?] )"
UIDEPEND="
x11-proto/xextproto