summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-09-26 11:28:44 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-09-26 11:28:44 +0000
commitc0cc1b70fe9d1bd22b5a4d6f7b20071b40ec2f2a (patch)
tree887735e5336967d61b6716808259038bb8f57a6b /games-fps
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-c0cc1b70fe9d1bd22b5a4d6f7b20071b40ec2f2a.tar.gz
gentoo-2-c0cc1b70fe9d1bd22b5a4d6f7b20071b40ec2f2a.tar.bz2
gentoo-2-c0cc1b70fe9d1bd22b5a4d6f7b20071b40ec2f2a.zip
Use system libraries instead of the bundled ones, bug #248895
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/postal2mp-demo/ChangeLog10
-rw-r--r--games-fps/postal2mp-demo/postal2mp-demo-1407-r1.ebuild58
2 files changed, 66 insertions, 2 deletions
diff --git a/games-fps/postal2mp-demo/ChangeLog b/games-fps/postal2mp-demo/ChangeLog
index 6a4e0470e7fd..c080e9a4576b 100644
--- a/games-fps/postal2mp-demo/ChangeLog
+++ b/games-fps/postal2mp-demo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/postal2mp-demo
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/postal2mp-demo/ChangeLog,v 1.12 2008/02/29 19:18:21 carlo Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/postal2mp-demo/ChangeLog,v 1.13 2009/09/26 11:28:44 nyhm Exp $
+
+*postal2mp-demo-1407-r1 (26 Sep 2009)
+
+ 26 Sep 2009; Tristan Heaven <nyhm@gentoo.org>
+ +postal2mp-demo-1407-r1.ebuild:
+ Use system libraries instead of the bundled ones, bug #248895
29 Feb 2008; Carsten Lohrke <carlo@gentoo.org> postal2mp-demo-1407.ebuild:
Remove icon extension from desktop entry to match Icon Theme Specification.
diff --git a/games-fps/postal2mp-demo/postal2mp-demo-1407-r1.ebuild b/games-fps/postal2mp-demo/postal2mp-demo-1407-r1.ebuild
new file mode 100644
index 000000000000..bc4d746aaf2a
--- /dev/null
+++ b/games-fps/postal2mp-demo/postal2mp-demo-1407-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/postal2mp-demo/postal2mp-demo-1407-r1.ebuild,v 1.1 2009/09/26 11:28:44 nyhm Exp $
+
+EAPI=2
+inherit eutils multilib games
+
+DESCRIPTION="You play the Postal Dude: Postal 2 is only as violent as you are"
+HOMEPAGE="http://www.linuxgamepublishing.com/info.php?id=postal2"
+SRC_URI="http://demofiles.linuxgamepublishing.com/postal2/postal2_demo.run"
+
+LICENSE="postal2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror strip"
+PROPERTIES="interactive"
+
+RDEPEND="virtual/opengl
+ sys-libs/glibc
+ amd64? ( app-emulation/emul-linux-x86-sdl )
+ x86? (
+ media-libs/libsdl[X,opengl]
+ media-libs/openal
+ )"
+DEPEND=""
+
+S=${WORKDIR}/data
+
+GAMES_CHECK_LICENSE="yes"
+
+src_unpack() {
+ unpack_makeself
+ mkdir data
+ cd data
+ unpack ./../postal2mpdemo.tar
+ unpack ./../linux-specific.tar
+}
+
+src_install() {
+ has_multilib_profile && ABI=x86
+
+ dir=${GAMES_PREFIX_OPT}/${PN}
+
+ insinto "${dir}"
+ doins -r * || die "doins failed"
+ fperms +x "${dir}"/System/{postal2,ucc}-bin || die "fperms failed"
+
+ dosym /usr/$(get_libdir)/libopenal.so "${dir}"/System/openal.so || die
+ dosym /usr/$(get_libdir)/libSDL-1.2.so.0 "${dir}"/System/libSDL-1.2.so.0 \
+ || die
+
+ games_make_wrapper ${PN} ./postal2-bin "${dir}"/System .
+ newicon ../postal2mpdemo.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Postal 2: Share the Pain (Demo)"
+
+ prepgamesdirs
+}