summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-11-12 01:53:15 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-11-12 01:53:15 +0000
commit43d695b24df630ef44bc9e67c6b8e74bfb4edab6 (patch)
tree0abdc11234eda490a7111e091611a1758b893970 /games-misc/OilWar
parentUse usex. (diff)
downloadgentoo-2-43d695b24df630ef44bc9e67c6b8e74bfb4edab6.tar.gz
gentoo-2-43d695b24df630ef44bc9e67c6b8e74bfb4edab6.tar.bz2
gentoo-2-43d695b24df630ef44bc9e67c6b8e74bfb4edab6.zip
EAPI=5; tidy
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-misc/OilWar')
-rw-r--r--games-misc/OilWar/ChangeLog7
-rw-r--r--games-misc/OilWar/OilWar-1.2.1-r1.ebuild45
2 files changed, 33 insertions, 19 deletions
diff --git a/games-misc/OilWar/ChangeLog b/games-misc/OilWar/ChangeLog
index 727b51e981e7..d974568b1361 100644
--- a/games-misc/OilWar/ChangeLog
+++ b/games-misc/OilWar/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-misc/OilWar
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/OilWar/ChangeLog,v 1.9 2008/10/07 17:21:27 mr_bones_ Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/OilWar/ChangeLog,v 1.10 2013/11/12 01:53:15 mr_bones_ Exp $
+
+ 12 Nov 2013; Michael Sterrett <mr_bones_@gentoo.org> OilWar-1.2.1-r1.ebuild:
+ EAPI=5; tidy
07 Oct 2008; Michael Sterrett <mr_bones_@gentoo.org>
OilWar-1.2.1-r1.ebuild:
diff --git a/games-misc/OilWar/OilWar-1.2.1-r1.ebuild b/games-misc/OilWar/OilWar-1.2.1-r1.ebuild
index 33a2ba4d46be..3fe770cd135f 100644
--- a/games-misc/OilWar/OilWar-1.2.1-r1.ebuild
+++ b/games-misc/OilWar/OilWar-1.2.1-r1.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/OilWar/OilWar-1.2.1-r1.ebuild,v 1.3 2008/10/07 17:21:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/OilWar/OilWar-1.2.1-r1.ebuild,v 1.4 2013/11/12 01:53:15 mr_bones_ Exp $
-inherit eutils games
+EAPI=5
+inherit eutils gnome2-utils games
DESCRIPTION="Evil army is attacking your country and tries to steal your oil"
-HOMEPAGE="http://www.2ndpoint.fi/projektit/oilwar.html"
-SRC_URI="http://www.2ndpoint.fi/projektit/filut/${P}.tar.gz
+HOMEPAGE="http://linux.softpedia.com/get/GAMES-ENTERTAINMENT/RTS/OilWar-15354.shtml"
+SRC_URI="mirror://gentoo/${P}.tar.gz
mirror://gentoo/${PN}.png"
LICENSE="GPL-2"
@@ -14,32 +15,42 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND="media-libs/libsdl
- media-libs/sdl-image
+DEPEND="media-libs/libsdl[video]
+ media-libs/sdl-image[png]
media-libs/sdl-mixer"
+RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${P}.tar.gz
- cd "${S}"
+src_prepare() {
sed -i \
-e '/^CXXCOMPILE/s:$(CPPFLAGS):$(SDL_CFLAGS):' \
-e '/^datafiledir/s:/games/:/:' \
-e '/install-data-am:/s:\\::' \
-e '/install-data-local$/d' \
- Makefile.in \
- || die "sed failed"
+ Makefile.in || die
}
-src_compile() {
- egamesconf --enable-sound || die
- emake || die
+src_configure() {
+ egamesconf --enable-sound
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
+ default
doicon "${DISTDIR}"/${PN}.png
make_desktop_entry oilwar ${PN}
fperms 664 "${GAMES_STATEDIR}/oilwar.scores"
prepgamesdirs
}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}