summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-07-19 21:31:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-07-19 21:31:49 +0000
commit285443eea66ced48ce560f2506da9903048929f0 (patch)
treefb25aa750cd0c6a6b16659324518a37a784bf9c1 /games-misc
parentlibvirt-1.1.0-r2 went out slightly too early and missed some patches, notibly... (diff)
downloadgentoo-2-285443eea66ced48ce560f2506da9903048929f0.tar.gz
gentoo-2-285443eea66ced48ce560f2506da9903048929f0.tar.bz2
gentoo-2-285443eea66ced48ce560f2506da9903048929f0.zip
version bump
(Portage version: 2.1.12.2/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/opengfx/ChangeLog8
-rw-r--r--games-misc/opengfx/files/opengfx-0.4.7-gcc48.patch16
-rw-r--r--games-misc/opengfx/opengfx-0.4.7.ebuild38
3 files changed, 61 insertions, 1 deletions
diff --git a/games-misc/opengfx/ChangeLog b/games-misc/opengfx/ChangeLog
index 21a5672b6d61..5a4e45bbe9aa 100644
--- a/games-misc/opengfx/ChangeLog
+++ b/games-misc/opengfx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-misc/opengfx
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/ChangeLog,v 1.30 2013/05/09 18:41:08 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/ChangeLog,v 1.31 2013/07/19 21:31:48 mr_bones_ Exp $
+
+*opengfx-0.4.7 (19 Jul 2013)
+
+ 19 Jul 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/opengfx-0.4.7-gcc48.patch, +opengfx-0.4.7.ebuild:
+ version bump
09 May 2013; Tupone Alfredo <tupone@gentoo.org> opengfx-0.4.6.1.ebuild,
+files/opengfx-0.4.6.1-gcc48.patch:
diff --git a/games-misc/opengfx/files/opengfx-0.4.7-gcc48.patch b/games-misc/opengfx/files/opengfx-0.4.7-gcc48.patch
new file mode 100644
index 000000000000..78b512e71cec
--- /dev/null
+++ b/games-misc/opengfx/files/opengfx-0.4.7-gcc48.patch
@@ -0,0 +1,16 @@
+--- scripts/Makefile.nml.old 2013-05-09 20:09:52.992038666 +0200
++++ scripts/Makefile.nml 2013-05-09 20:10:36.942970903 +0200
+@@ -14,11 +14,11 @@
+
+ %.src.dep: $(SRC_DIR)/%.pnml
+ $(_E) "[DEP] $@"
+- $(_V) $(CC) -C -M -MF $@ -E -MT $(patsubst %.src.dep,%.nml,$@) - < $<
++ $(_V) $(CC) -P -C -M -MF $@ -E -MT $(patsubst %.src.dep,%.nml,$@) - < $<
+
+ %.nml: $(SRC_DIR)/%.pnml $(TAG_FILENAME)
+ $(_E) "[CPP] $@"
+- $(_V) $(CC) -D REPO_REVISION=$(REPO_REVISION) $(CC_FLAGS) $< > $@
++ $(_V) $(CC) -P -D REPO_REVISION=$(REPO_REVISION) $(CC_FLAGS) $< > $@
+
+ %.gfx.dep: %.nml
+ $(_E) "[DEP] $@"
diff --git a/games-misc/opengfx/opengfx-0.4.7.ebuild b/games-misc/opengfx/opengfx-0.4.7.ebuild
new file mode 100644
index 000000000000..a79168fba6b6
--- /dev/null
+++ b/games-misc/opengfx/opengfx-0.4.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/opengfx-0.4.7.ebuild,v 1.1 2013/07/19 21:31:48 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="OpenGFX data files for OpenTTD"
+HOMEPAGE="http://bundles.openttdcoop.org/opengfx/"
+SRC_URI="http://bundles.openttdcoop.org/opengfx/releases/${PV}/${P}-source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+RESTRICT="test" # nml version affects the checksums that the test uses (bug #451444)
+
+DEPEND=">=games-util/nml-0.2.4"
+RDEPEND=""
+
+S=${WORKDIR}/${P}-source
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc48.patch
+}
+
+src_compile() {
+ # ensure that we will not use gimp to regenerate the pngs
+ # causes sandbox violations and not worth the effort anyway
+ GIMP='' emake bundle
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/openttd/data/"
+ doins *.grf opengfx.obg
+ dodoc docs/{changelog.txt,readme.txt}
+ prepgamesdirs
+}