summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-04-17 12:35:45 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-04-17 12:35:45 +0000
commit9f4fd78bcb96aebe4445ff1b5cd76d7ab5fbb966 (patch)
treedd3c30976b9eb0941b95a91c712bfef1d13d3539 /games-misc
parentInitial commit for new tool used to build OpenGFX files used by OpenTTD. (diff)
downloadgentoo-2-9f4fd78bcb96aebe4445ff1b5cd76d7ab5fbb966.tar.gz
gentoo-2-9f4fd78bcb96aebe4445ff1b5cd76d7ab5fbb966.tar.bz2
gentoo-2-9f4fd78bcb96aebe4445ff1b5cd76d7ab5fbb966.zip
Version bump to latest graphics pack usefull for new OpenTTD, remove arm and ppc64 keywords due to new dep. Keywordreq tbd.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/opengfx/ChangeLog10
-rw-r--r--games-misc/opengfx/opengfx-0.4.4.ebuild38
2 files changed, 46 insertions, 2 deletions
diff --git a/games-misc/opengfx/ChangeLog b/games-misc/opengfx/ChangeLog
index 0730e883aceb..3749e1d3b3ee 100644
--- a/games-misc/opengfx/ChangeLog
+++ b/games-misc/opengfx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-misc/opengfx
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/ChangeLog,v 1.14 2011/10/10 05:45:07 mr_bones_ Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/ChangeLog,v 1.15 2012/04/17 12:35:45 scarabeus Exp $
+
+*opengfx-0.4.4 (17 Apr 2012)
+
+ 17 Apr 2012; Tomáš Chvátal <scarabeus@gentoo.org> +opengfx-0.4.4.ebuild:
+ Version bump to latest graphics pack usefull for new OpenTTD, remove arm and
+ ppc64 keywords due to new dep. Keywordreq tbd.
10 Oct 2011; Michael Sterrett <mr_bones_@gentoo.org> opengfx-0.3.6.ebuild:
work around locale (bug #386597)
diff --git a/games-misc/opengfx/opengfx-0.4.4.ebuild b/games-misc/opengfx/opengfx-0.4.4.ebuild
new file mode 100644
index 000000000000..3882a5928bc4
--- /dev/null
+++ b/games-misc/opengfx/opengfx-0.4.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/opengfx-0.4.4.ebuild,v 1.1 2012/04/17 12:35:45 scarabeus Exp $
+
+EAPI=3
+inherit games
+
+DESCRIPTION="OpenGFX data files for OpenTTD"
+HOMEPAGE="http://bundles.openttdcoop.org/opengfx/"
+SRC_URI="http://bundles.openttdcoop.org/opengfx/releases/${PV}/${P}-source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${P}-source
+
+DEPEND="
+ >=games-util/grfcodec-5.1.1
+ >=games-util/nml-0.2.3
+"
+RDEPEND=""
+
+src_prepare() {
+ sed -i -e 's/\[a-z\]/[[:alpha:]]/' ./scripts/Makefile.in || die
+}
+
+src_compile() {
+ emake bundle || die
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/openttd/data/"
+ doins *.grf opengfx.obg || die
+ dodoc docs/{changelog.txt,readme.txt}
+ prepgamesdirs
+}