summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-07-14 00:21:32 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-07-14 00:21:32 +0000
commit4c333682f8561bff0892a620aa27566b195dc578 (patch)
treedd989861ff708eccf31349e77747c07ae0b165c6 /games-puzzle/larry/larry-1-r1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-4c333682f8561bff0892a620aa27566b195dc578.tar.gz
gentoo-2-4c333682f8561bff0892a620aa27566b195dc578.tar.bz2
gentoo-2-4c333682f8561bff0892a620aa27566b195dc578.zip
fix locale bug via revbump
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-puzzle/larry/larry-1-r1.ebuild')
-rw-r--r--games-puzzle/larry/larry-1-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/games-puzzle/larry/larry-1-r1.ebuild b/games-puzzle/larry/larry-1-r1.ebuild
new file mode 100644
index 000000000000..ce047baddc4f
--- /dev/null
+++ b/games-puzzle/larry/larry-1-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/larry/larry-1-r1.ebuild,v 1.1 2013/07/14 00:21:32 hasufell Exp $
+
+EAPI=5
+
+inherit eutils check-reqs gnome2-utils games
+
+DESCRIPTION="Leisure Suit Larry Reloaded"
+HOMEPAGE="https://www.replaygamesinc.com"
+SRC_URI="LarryReloadedLinux.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="splitdebug"
+
+QA_PREBUILT="${GAMES_PREFIX_OPT#/}/${PN}/Larry-Linux
+ ${GAMES_PREFIX_OPT#/}/${PN}/Larry-Linux_Data/Mono/x86/libmono.so"
+CHECKREQS_DISK_VAR="4500M"
+CHECKREQS_DISK_USR="4500M"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+ einfo
+}
+
+src_prepare() {
+ sed \
+ -e "s#@GAMES_DIR@#${GAMES_PREFIX_OPT}/${PN}#" \
+ "${FILESDIR}"/${PN}-wrapper > "${S}"/larry || die
+}
+
+src_install() {
+ newicon -s 128 Larry/Larry-Linux_Data/Resources/UnityPlayer.png ${PN}.png
+ make_desktop_entry ${PN}
+
+ dogamesbin larry
+ # move it, over 4gb
+ dodir "${GAMES_PREFIX_OPT}"/${PN}
+ mv Larry/* "${ED%/}/${GAMES_PREFIX_OPT}"/${PN}/ || die
+
+ fperms +x "${GAMES_PREFIX_OPT}"/${PN}/Larry-Linux
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}