summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-12-11 08:12:04 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-12-11 08:12:04 +0000
commit70fff799a927cee0eb51fc209aba2baaeaeed084 (patch)
treef755c3d85cffbc2bbaa98aef1603f26e3dabbe68 /games-puzzle/seatris/seatris-0.0.14.ebuild
parentNew version (Manifest recommit) (diff)
downloadgentoo-2-70fff799a927cee0eb51fc209aba2baaeaeed084.tar.gz
gentoo-2-70fff799a927cee0eb51fc209aba2baaeaeed084.tar.bz2
gentoo-2-70fff799a927cee0eb51fc209aba2baaeaeed084.zip
initial commit - in response to bug #54939
Diffstat (limited to 'games-puzzle/seatris/seatris-0.0.14.ebuild')
-rw-r--r--games-puzzle/seatris/seatris-0.0.14.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-puzzle/seatris/seatris-0.0.14.ebuild b/games-puzzle/seatris/seatris-0.0.14.ebuild
new file mode 100644
index 000000000000..13a703d49a92
--- /dev/null
+++ b/games-puzzle/seatris/seatris-0.0.14.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/seatris/seatris-0.0.14.ebuild,v 1.1 2004/12/11 08:12:04 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A color ncurses tetris clone"
+HOMEPAGE="http://www.earth.li/projectpurple/progs/seatris.html"
+SRC_URI="http://www.earth.li/projectpurple/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ sys-libs/ncurses"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:/var/lib/games:${GAMES_STATEDIR}:" \
+ scoring.h seatris.6 \
+ || die "sed failed"
+}
+
+src_install () {
+ dogamesbin seatris
+ doman seatris.6
+ dodoc ACKNOWLEDGEMENTS HISTORY README TODO example.seatrisrc
+ dodir "${GAMES_STATEDIR}"
+ touch "${D}${GAMES_STATEDIR}/seatris.score"
+ fperms 660 ${GAMES_STATEDIR}/seatris.score
+ prepgamesdirs
+}