summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-10-08 07:14:21 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-10-08 07:14:21 +0000
commitf199ddc23f9abbb5290695cf8acbe37cc86fcab6 (patch)
tree161af1f2f87c2a76831386253cb5c2f05b4b2063 /games-puzzle/tint
parentVersion bump for bug #168960 by Andrew Cremins. Note that maps will have to (diff)
downloadgentoo-2-f199ddc23f9abbb5290695cf8acbe37cc86fcab6.tar.gz
gentoo-2-f199ddc23f9abbb5290695cf8acbe37cc86fcab6.tar.bz2
gentoo-2-f199ddc23f9abbb5290695cf8acbe37cc86fcab6.zip
version bump
(Portage version: 2.1.3.9)
Diffstat (limited to 'games-puzzle/tint')
-rw-r--r--games-puzzle/tint/ChangeLog9
-rw-r--r--games-puzzle/tint/files/digest-tint-0.03b3
-rw-r--r--games-puzzle/tint/tint-0.03b.ebuild36
3 files changed, 46 insertions, 2 deletions
diff --git a/games-puzzle/tint/ChangeLog b/games-puzzle/tint/ChangeLog
index 323e52a2e69a..dcb41b858268 100644
--- a/games-puzzle/tint/ChangeLog
+++ b/games-puzzle/tint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-puzzle/tint
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tint/ChangeLog,v 1.9 2006/08/15 15:00:11 tcort Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tint/ChangeLog,v 1.10 2007/10/08 07:14:20 mr_bones_ Exp $
+
+*tint-0.03b (08 Oct 2007)
+
+ 08 Oct 2007; Michael Sterrett <mr_bones_@gentoo.org> +tint-0.03b.ebuild:
+ version bump
15 Aug 2006; Thomas Cort <tcort@gentoo.org> tint-0.03a.ebuild:
Stable on amd64 wrt Bug #143961
diff --git a/games-puzzle/tint/files/digest-tint-0.03b b/games-puzzle/tint/files/digest-tint-0.03b
new file mode 100644
index 000000000000..c2172a2210b0
--- /dev/null
+++ b/games-puzzle/tint/files/digest-tint-0.03b
@@ -0,0 +1,3 @@
+MD5 1eb517509dfc9957ebc760b961adb26e tint_0.03b.tar.gz 16909
+RMD160 23a763fc8dea63feb5f80a25ef6c75be47a97068 tint_0.03b.tar.gz 16909
+SHA256 f43fc82c5d16954a85ef532b0771599902cea86d8d9eea044e5b7454db91419c tint_0.03b.tar.gz 16909
diff --git a/games-puzzle/tint/tint-0.03b.ebuild b/games-puzzle/tint/tint-0.03b.ebuild
new file mode 100644
index 000000000000..2e0da1e296f7
--- /dev/null
+++ b/games-puzzle/tint/tint-0.03b.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tint/tint-0.03b.ebuild,v 1.1 2007/10/08 07:14:20 mr_bones_ Exp $
+
+inherit eutils games
+
+MY_P=${P/-/_}
+DESCRIPTION="Tint Is Not Tetris, a ncurses based clone of the original Tetris(tm) game"
+HOMEPAGE="http://oasis.frogfoot.net/code/tint/"
+SRC_URI="http://oasis.frogfoot.net/code/tint/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.4-r1"
+
+src_compile() {
+ emake \
+ STRIP=true \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ localstatedir="${GAMES_STATEDIR}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin tint || die "dogamesbin failed"
+ doman tint.6
+ dodoc CREDITS NOTES
+ insopts -m 0664
+ insinto "${GAMES_STATEDIR}"
+ doins tint.scores || die "doins failed"
+ prepgamesdirs
+}