summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-01-27 18:40:15 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-01-27 18:40:15 +0000
commiteaeaf42a347beae44d493a9d7b34741b8d3e8fc4 (patch)
tree1c2159b63f2527715c48f00ec3d0b4dc6efd2271 /games-puzzle
parentinitial ebuild (diff)
downloadgentoo-2-eaeaf42a347beae44d493a9d7b34741b8d3e8fc4.tar.gz
gentoo-2-eaeaf42a347beae44d493a9d7b34741b8d3e8fc4.tar.bz2
gentoo-2-eaeaf42a347beae44d493a9d7b34741b8d3e8fc4.zip
version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/xbomb/ChangeLog10
-rw-r--r--games-puzzle/xbomb/files/digest-xbomb-2.23
-rw-r--r--games-puzzle/xbomb/files/xbomb-2.2-DESTDIR.patch35
-rw-r--r--games-puzzle/xbomb/xbomb-2.2.ebuild41
4 files changed, 87 insertions, 2 deletions
diff --git a/games-puzzle/xbomb/ChangeLog b/games-puzzle/xbomb/ChangeLog
index bffb18f20c6b..cc72e471814a 100644
--- a/games-puzzle/xbomb/ChangeLog
+++ b/games-puzzle/xbomb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/xbomb
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xbomb/ChangeLog,v 1.11 2007/02/22 01:18:16 peper Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xbomb/ChangeLog,v 1.12 2008/01/27 18:40:14 mr_bones_ Exp $
+
+*xbomb-2.2 (27 Jan 2008)
+
+ 27 Jan 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/xbomb-2.2-DESTDIR.patch, +xbomb-2.2.ebuild:
+ version bump
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/games-puzzle/xbomb/files/digest-xbomb-2.2 b/games-puzzle/xbomb/files/digest-xbomb-2.2
new file mode 100644
index 000000000000..51e2387d5dc7
--- /dev/null
+++ b/games-puzzle/xbomb/files/digest-xbomb-2.2
@@ -0,0 +1,3 @@
+MD5 01a4e19e9585e52522c0c8acf1511274 xbomb-2.2.tgz 24872
+RMD160 51a212d8cbe62d765e75751ae7b3d341ce6a3ada xbomb-2.2.tgz 24872
+SHA256 e65282c80a88a831f2e264263ba76fff6826aaedc67317d4df037d7983b1683d xbomb-2.2.tgz 24872
diff --git a/games-puzzle/xbomb/files/xbomb-2.2-DESTDIR.patch b/games-puzzle/xbomb/files/xbomb-2.2-DESTDIR.patch
new file mode 100644
index 000000000000..945ac700be86
--- /dev/null
+++ b/games-puzzle/xbomb/files/xbomb-2.2-DESTDIR.patch
@@ -0,0 +1,35 @@
+diff -c xbomb-2.1/Makefile xbomb-2.1.new/Makefile
+*** xbomb-2.1/Makefile 1996-01-20 16:02:46.000000000 -0500
+--- xbomb-2.1.new/Makefile 2002-11-13 10:31:30.000000000 -0500
+***************
+*** 27,34 ****
+
+ OBJ=xbomb.o xwindow.o hiscore.o
+
+- INSTDIR=/usr/local
+-
+ ########
+
+ xbomb : $(OBJ)
+--- 27,32 ----
+***************
+*** 52,60 ****
+
+ install :
+ strip xbomb
+! install -d $(INSTDIR)/bin
+! install -d $(INSTDIR)/man/man6
+! install -d $(INSTDIR)/lib/app-defaults
+! install -m 755 xbomb $(INSTDIR)/bin
+! install -m 644 xbomb.6 $(INSTDIR)/man/man6
+! install -m 644 xbomb.ad $(INSTDIR)/lib/app-defaults/XBomb
+--- 50,58 ----
+
+ install :
+ strip xbomb
+! install -d $(DESTDIR)/usr/bin
+! install -d $(DESTDIR)/usr/share/man/man6
+! install -d $(DESTDIR)/etc/X11/app-defaults
+! install -m 755 xbomb $(DESTDIR)/usr/bin
+! install -m 644 xbomb.6 $(DESTDIR)/usr/share/man/man6
+! install -m 644 xbomb.ad $(DESTDIR)/etc/X11/app-defaults/XBomb
diff --git a/games-puzzle/xbomb/xbomb-2.2.ebuild b/games-puzzle/xbomb/xbomb-2.2.ebuild
new file mode 100644
index 000000000000..7dd95df8d44e
--- /dev/null
+++ b/games-puzzle/xbomb/xbomb-2.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xbomb/xbomb-2.2.ebuild,v 1.1 2008/01/27 18:40:14 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Minesweeper clone with hexagonal, rectangular and triangular grid"
+HOMEPAGE="http://www.gedanken.demon.co.uk/xbomb/"
+SRC_URI="http://www.gedanken.demon.co.uk/download-xbomb/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libXaw"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-DESTDIR.patch
+ sed -i \
+ -e '/strip/d' \
+ -e "/^CFLAGS/ { s:=.*:=${CFLAGS}: }" \
+ -e "s:/usr/bin:${GAMES_BINDIR}:" \
+ "${S}"/Makefile \
+ || die "sed Makefile failed"
+ sed -i \
+ -e "s:/var/tmp:${GAMES_STATEDIR}/${PN}:g" \
+ "${S}"/hiscore.c \
+ || die "sed hiscore.c failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README LSM
+ dodir "${GAMES_STATEDIR}"/${PN}
+ touch "${D}/${GAMES_STATEDIR}"/${PN}/${PN}{3,4,6}.hi || die "touch failed"
+ fperms 660 "${GAMES_STATEDIR}"/${PN}/${PN}{3,4,6}.hi || die "fperms failed"
+ prepgamesdirs
+}