summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-02-27 21:31:21 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-02-27 21:31:21 +0000
commit6af16ed0b3c4149bbceca035142c9a4b57b24a44 (patch)
treeed9199cb6d124a6855f016bc3a4c4d2fef7bc32f /games-roguelike/angband/angband-3.0.6.ebuild
parentUpdate HOMEPAGE (diff)
downloadgentoo-2-6af16ed0b3c4149bbceca035142c9a4b57b24a44.tar.gz
gentoo-2-6af16ed0b3c4149bbceca035142c9a4b57b24a44.tar.bz2
gentoo-2-6af16ed0b3c4149bbceca035142c9a4b57b24a44.zip
Version bump (3.0.6) bug #101574 thanks to Tristan Mills
(Portage version: 2.1_pre5)
Diffstat (limited to 'games-roguelike/angband/angband-3.0.6.ebuild')
-rw-r--r--games-roguelike/angband/angband-3.0.6.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-roguelike/angband/angband-3.0.6.ebuild b/games-roguelike/angband/angband-3.0.6.ebuild
new file mode 100644
index 000000000000..d30d99983536
--- /dev/null
+++ b/games-roguelike/angband/angband-3.0.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/angband/angband-3.0.6.ebuild,v 1.1 2006/02/27 21:31:21 tupone Exp $
+
+inherit flag-o-matic games
+
+DESCRIPTION="A roguelike dungeon exploration game based on the books of J.R.R.Tolkien"
+HOMEPAGE="http://thangorodrim.net/"
+SRC_URI="ftp://ftp.thangorodrim.net/pub/${PN}/Source/${P}.tar.gz"
+
+LICENSE="Moria"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sparc ~x86"
+IUSE="X gtk"
+
+DEPEND=">=sys-libs/ncurses-5
+ gtk? (
+ =x11-libs/gtk+-1.2*
+ )
+ X? ( || ( x11-libs/libXaw virtual/x11 ) )"
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --bindir="${GAMES_BINDIR}" \
+ --with-setgid="${GAMES_GROUP}" \
+ $(use_enable gtk) \
+ $(use_with X x) \
+ || die "egamesconf failed"
+ append-ldflags -Wl,-z,now
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog THANKS TODO changes.txt compile.txt readme.txt
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ chmod -R g+w "${ROOT}${GAMES_DATADIR}"/angband/lib/{apex,save,user}
+}