summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-01-20 05:47:59 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-01-20 05:47:59 +0000
commit65946bf6ee0054693a4f14d814abeb967aa57f41 (patch)
tree1054236b48f2593ecae8903931ebddb597908c2c /games-roguelike/tome/tome-2.2.7.ebuild
parentvalve sucks at linux (diff)
downloadgentoo-2-65946bf6ee0054693a4f14d814abeb967aa57f41.tar.gz
gentoo-2-65946bf6ee0054693a4f14d814abeb967aa57f41.tar.bz2
gentoo-2-65946bf6ee0054693a4f14d814abeb967aa57f41.zip
version bump; clean older versions
Diffstat (limited to 'games-roguelike/tome/tome-2.2.7.ebuild')
-rw-r--r--games-roguelike/tome/tome-2.2.7.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/games-roguelike/tome/tome-2.2.7.ebuild b/games-roguelike/tome/tome-2.2.7.ebuild
deleted file mode 100644
index 04710e6dd615..000000000000
--- a/games-roguelike/tome/tome-2.2.7.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/tome-2.2.7.ebuild,v 1.4 2004/07/01 05:21:55 mr_bones_ Exp $
-
-inherit eutils games
-
-MY_PV=${PV//./}
-DESCRIPTION="save the world from Morgoth and battle evil (or become evil ;])"
-HOMEPAGE="http://t-o-m-e.net/"
-SRC_URI="http://t-o-m-e.net/dl/src/tome-${MY_PV}-src.tar.bz2"
-
-LICENSE="Moria"
-SLOT="0"
-KEYWORDS="x86 ~ppc ~amd64"
-IUSE=""
-
-RDEPEND="virtual/libc
- dev-lang/lua
- >=sys-libs/ncurses-5
- virtual/x11"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
-
-S="${WORKDIR}/tome-${MY_PV}-src"
-
-src_unpack() {
- unpack ${A}
- cd "${S}/src"
- mv makefile.std makefile
- epatch "${FILESDIR}/${PV}-gentoo-paths.patch"
- sed -i \
- -e "s:GENTOO_DIR:${GAMES_STATEDIR}:" files.c init2.c \
- || die "sed failed"
- find "${S}" -name .cvsignore -exec rm -f \{\} \;
-}
-
-src_compile() {
- cd src
- make depend || die "make depend failed"
- emake -j1 \
- COPTS="${CFLAGS}" \
- BINDIR="${GAMES_BINDIR}" \
- LIBDIR="${GAMES_DATADIR}/${PN}" \
- || die "emake failed"
-}
-
-src_install() {
- cd src
- make \
- DESTDIR="${D}" \
- OWNER="${GAMES_USER}" \
- BINDIR="${GAMES_BINDIR}" \
- LIBDIR="${GAMES_DATADIR}/${PN}" install \
- || die "make install failed"
- cd "${S}"
- dodoc *.txt
-
- dodir "${GAMES_STATEDIR}"
- touch "${D}/${GAMES_STATEDIR}/${PN}-scores.raw"
- prepgamesdirs
- fperms g+w "${GAMES_STATEDIR}/${PN}-scores.raw"
- fperms g+w "${GAMES_DATADIR}/${PN}/data"
-}
-
-pkg_postinst() {
- games_pkg_postinst
- echo
- ewarn "ToME ${PV} is not save-game compatible with previous versions."
- echo
- einfo "If you have older save files and you wish to continue those games,"
- einfo "you'll need to remerge the version of ToME with which you started"
- einfo "those save-games."
-}