summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-03-11 21:51:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-03-11 21:51:46 +0000
commit9ece494328b5fa60f1537bf1e921f4bbb3e82331 (patch)
treedd11848d57cad4d893ccc6ad0a3e195cc2847b6f /games-roguelike/tomenet
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-9ece494328b5fa60f1537bf1e921f4bbb3e82331.tar.gz
gentoo-2-9ece494328b5fa60f1537bf1e921f4bbb3e82331.tar.bz2
gentoo-2-9ece494328b5fa60f1537bf1e921f4bbb3e82331.zip
version bump
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'games-roguelike/tomenet')
-rw-r--r--games-roguelike/tomenet/ChangeLog10
-rw-r--r--games-roguelike/tomenet/tomenet-100310.ebuild60
2 files changed, 68 insertions, 2 deletions
diff --git a/games-roguelike/tomenet/ChangeLog b/games-roguelike/tomenet/ChangeLog
index 769916846665..cb975cff5d25 100644
--- a/games-roguelike/tomenet/ChangeLog
+++ b/games-roguelike/tomenet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-roguelike/tomenet
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tomenet/ChangeLog,v 1.5 2009/11/03 05:20:15 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tomenet/ChangeLog,v 1.6 2010/03/11 21:51:46 mr_bones_ Exp $
+
+*tomenet-100310 (11 Mar 2010)
+
+ 11 Mar 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +tomenet-100310.ebuild:
+ version bump
*tomenet-091102 (03 Nov 2009)
diff --git a/games-roguelike/tomenet/tomenet-100310.ebuild b/games-roguelike/tomenet/tomenet-100310.ebuild
new file mode 100644
index 000000000000..cce853634c2e
--- /dev/null
+++ b/games-roguelike/tomenet/tomenet-100310.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tomenet/tomenet-100310.ebuild,v 1.1 2010/03/11 21:51:46 mr_bones_ Exp $
+
+EAPI=2
+inherit games
+
+DESCRIPTION="A MMORPG based on the works of J.R.R. Tolkien"
+HOMEPAGE="http://www.tomenet.net/"
+SRC_URI="http://angband.oook.cz/${PN}-nightly/${PN}-cvs-snapshot-${PV}.tar.bz2"
+
+LICENSE="Moria"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X Xaw3d"
+
+DEPEND="sys-libs/ncurses
+ X? ( x11-libs/libX11 )
+ Xaw3d? ( x11-libs/libXaw )"
+
+S=${WORKDIR}/${PN}/src
+
+src_prepare() {
+ sed -i \
+ -e '/^CC =/d' \
+ makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ local GENTOO_DEFINES="-DUSE_GCU "
+ local GENTOO_LIBS="-lncurses -lcrypt -lm"
+
+ if use Xaw3d; then
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_XAW"
+ elif use X; then
+ GENTOO_DEFINES="${GENTOO_DEFINES} -DUSE_X11"
+ fi
+ if use X; then
+ GENTOO_LIBS="${GENTOO_LIBS} -lX11"
+ fi
+ if use Xaw3d; then
+ GENTOO_LIBS="${GENTOO_LIBS} -lXaw"
+ fi
+ emake CFLAGS="${CFLAGS} ${GENTOO_DEFINES} -Iserver -Iserver/lua" \
+ LIBS="${GENTOO_LIBS}" tomenet \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+ dodoc ../{ChangeLog,TomeNET-Guide.txt,changes.txt}
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "To start playing right away:"
+ elog "$ tomenet totem.ielf.org"
+}