summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-02-21 11:20:13 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-02-21 11:20:13 +0000
commit12e8c53b8d673f69425b83329dbe8dc0b0429f76 (patch)
tree9b8e0a50e392338f27db8324a67c0cbe90e9206d /games-rpg
parentAdd upstream patch for compatibility with newer imagemagick versions, fixes #... (diff)
downloadgentoo-2-12e8c53b8d673f69425b83329dbe8dc0b0429f76.tar.gz
gentoo-2-12e8c53b8d673f69425b83329dbe8dc0b0429f76.tar.bz2
gentoo-2-12e8c53b8d673f69425b83329dbe8dc0b0429f76.zip
touchups
(Portage version: 2.1.7.16/cvs/Linux i686)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/egoboo/egoboo-2.7.4.ebuild15
-rw-r--r--games-rpg/egoboo/files/egoboo-2.7.4-enet.patch92
2 files changed, 81 insertions, 26 deletions
diff --git a/games-rpg/egoboo/egoboo-2.7.4.ebuild b/games-rpg/egoboo/egoboo-2.7.4.ebuild
index 1da0696784d7..fcf5573989f2 100644
--- a/games-rpg/egoboo/egoboo-2.7.4.ebuild
+++ b/games-rpg/egoboo/egoboo-2.7.4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/egoboo/egoboo-2.7.4.ebuild,v 1.3 2010/02/21 08:27:05 tupone Exp $
-EAPI=2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/egoboo/egoboo-2.7.4.ebuild,v 1.4 2010/02/21 11:20:12 mr_bones_ Exp $
-inherit eutils toolchain-funcs games
+EAPI=2
+inherit eutils games
DESCRIPTION="A 3d dungeon crawling adventure in the spirit of NetHack"
HOMEPAGE="http://egoboo.sourceforge.net/"
@@ -14,16 +14,15 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-RDEPEND="virtual/opengl
+DEPEND="virtual/opengl
virtual/glu
+ media-libs/libsdl[video]
media-libs/sdl-image
- media-libs/sdl-mixer
+ media-libs/sdl-mixer[vorbis]
media-libs/sdl-ttf
net-libs/enet"
-DEPEND="${RDEPEND}"
src_prepare() {
- edos2unix game/Makefile.unix
epatch "${FILESDIR}"/${P}-enet.patch
sed -i \
-e "s:\${EGOBOO_PREFIX}/share:${GAMES_DATADIR}:" \
@@ -32,7 +31,7 @@ src_prepare() {
}
src_compile() {
- emake -C game -f Makefile.unix CC="$(tc-getCC)" || die "emake failed"
+ emake -C game -f Makefile.unix || die "emake failed"
}
src_install() {
diff --git a/games-rpg/egoboo/files/egoboo-2.7.4-enet.patch b/games-rpg/egoboo/files/egoboo-2.7.4-enet.patch
index 82a9f8c5025f..ded70622d013 100644
--- a/games-rpg/egoboo/files/egoboo-2.7.4-enet.patch
+++ b/games-rpg/egoboo/files/egoboo-2.7.4-enet.patch
@@ -1,23 +1,79 @@
---- game/Makefile.unix.old 2010-02-20 22:53:56.000000000 +0100
-+++ game/Makefile.unix 2010-02-20 22:56:07.000000000 +0100
-@@ -22,16 +22,16 @@
-
- CC := gcc
+diff -ur egoboo-2.7.4.orig/game/Makefile.unix egoboo-2.7.4/game/Makefile.unix
+--- egoboo-2.7.4.orig/game/Makefile.unix 2009-07-03 05:36:02.000000000 -0400
++++ egoboo-2.7.4/game/Makefile.unix 2010-02-21 06:11:32.096511264 -0500
+@@ -1,5 +1,5 @@
+-# note if you change the prefix also update egoboo.sh
+-PREFIX := ${HOME}/.local
++# note if you change the prefix also update egoboo.sh
++PREFIX := ${HOME}/.local
+ EGO_SRC := camera.c char.c client.c clock.c configfile.c egoboo_endian.c \
+ egoboo_fileutil.c egoboo_math.c egoboo_setup.c egoboo_strutil.c \
+ enchant.c file_common.c file_linux.c font.c game.c graphic.c\
+@@ -9,36 +9,35 @@
+ egoboo_console.c script_functions.c mad.c mpd.c egoboo_typedef.c \
+ ogl_texture.c ogl_extensions.c ogl_include.c ogl_debug.c \
+ SDL_extensions.c SDL_GL_extensions.c mesh.c
+-
+-EGO_OBJ := ${EGO_SRC:.c=.o}
+-ENET_SRC := ../enet/host.c ../enet/list.c ../enet/memory.c \
+- ../enet/packet.c ../enet/peer.c ../enet/protocol.c \
+- ../enet/unix.c
+-ENET_OBJ := ${ENET_SRC:.c=.o}
+-
+-SDL_CONF := sdl-config
+-SDLCONF_I := $(shell ${SDL_CONF} --cflags)
+-SDLCONF_L := $(shell ${SDL_CONF} --libs)
+-
+-CC := gcc
++
++EGO_OBJ := ${EGO_SRC:.c=.o}
++ENET_SRC := ../enet/host.c ../enet/list.c ../enet/memory.c \
++ ../enet/packet.c ../enet/peer.c ../enet/protocol.c \
++ ../enet/unix.c
++ENET_OBJ := ${ENET_SRC:.c=.o}
++
++SDL_CONF := sdl-config
++SDLCONF_I := $(shell ${SDL_CONF} --cflags)
++SDLCONF_L := $(shell ${SDL_CONF} --libs)
++
OPT := -Os -Wall
--INC := -I. -I../enet/include -I.. ${SDLCONF_I}
--CFLAGS := ${OPT} ${INC}
--LDFLAGS := ${SDLCONF_L} -lSDL_ttf -lSDL_mixer -lGL -lGLU -lSDL_image
+-INC := -I. -I../enet/include -I.. ${SDLCONF_I}
+-CFLAGS := ${OPT} ${INC}
+-LDFLAGS := ${SDLCONF_L} -lSDL_ttf -lSDL_mixer -lGL -lGLU -lSDL_image
+-
+-EGO_BIN := egoboo
+-
+-all: ${EGO_BIN}
+-
+-
+-${EGO_BIN}: ${EGO_OBJ} ${ENET_OBJ}
+- ${CC} -o $@ $^ ${LDFLAGS}
+-
+-install: ${EGO_BIN}
+- mkdir -p ${PREFIX}/bin
+- mkdir -p ${PREFIX}/libexec
+- install -m 755 ${EGO_BIN} ${PREFIX}/libexec
+- install -p -m 755 ${EGO_BIN}.sh ${PREFIX}/bin/${EGO_BIN}
+-
+-clean:
+- rm -f ${ENET_OBJ} ${EGO_OBJ} ${EGO_BIN}
+INC := -I. -I.. ${SDLCONF_I} -DENET11
+CFLAGS := ${CFLAGS} ${INC}
+LDFLAGS := ${SDLCONF_L} -lenet -lSDL_ttf -lSDL_mixer -lGL -lGLU -lSDL_image
-
- EGO_BIN := egoboo
-
- all: ${EGO_BIN}
-
-
--${EGO_BIN}: ${EGO_OBJ} ${ENET_OBJ}
++
++EGO_BIN := egoboo
++
++all: ${EGO_BIN}
++
++
+${EGO_BIN}: ${EGO_OBJ}
- ${CC} -o $@ $^ ${LDFLAGS}
-
- install: ${EGO_BIN}
++ ${CC} -o $@ $^ ${LDFLAGS}
++
++install: ${EGO_BIN}
++ mkdir -p ${PREFIX}/bin
++ mkdir -p ${PREFIX}/libexec
++ install -m 755 ${EGO_BIN} ${PREFIX}/libexec
++ install -p -m 755 ${EGO_BIN}.sh ${PREFIX}/bin/${EGO_BIN}
++
++clean:
++ rm -f ${ENET_OBJ} ${EGO_OBJ} ${EGO_BIN}