summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Peterson <lavajoe@gentoo.org>2009-06-14 18:34:25 +0000
committerJoe Peterson <lavajoe@gentoo.org>2009-06-14 18:34:25 +0000
commitb59ecf60320a643efd768dbbad1d67624d6c7d40 (patch)
tree3c1e4f2821288ac50972b5a2afd6e50bc00a21da /games-simulation
parentAdd new 3.7.0 beta 32 (diff)
downloadgentoo-2-b59ecf60320a643efd768dbbad1d67624d6c7d40.tar.gz
gentoo-2-b59ecf60320a643efd768dbbad1d67624d6c7d40.tar.bz2
gentoo-2-b59ecf60320a643efd768dbbad1d67624d6c7d40.zip
Add new 1.23_rc4
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/secondlife-bin/ChangeLog9
-rw-r--r--games-simulation/secondlife-bin/files/secondlife-bin-1.23_rc4-amd64-audio-streaming-fix.patch26
-rw-r--r--games-simulation/secondlife-bin/secondlife-bin-1.23_rc4.ebuild119
3 files changed, 153 insertions, 1 deletions
diff --git a/games-simulation/secondlife-bin/ChangeLog b/games-simulation/secondlife-bin/ChangeLog
index 29f5ab92aaf8..202f8890e857 100644
--- a/games-simulation/secondlife-bin/ChangeLog
+++ b/games-simulation/secondlife-bin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-simulation/secondlife-bin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/secondlife-bin/ChangeLog,v 1.22 2009/05/26 16:34:22 lavajoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/secondlife-bin/ChangeLog,v 1.23 2009/06/14 18:34:25 lavajoe Exp $
+
+*secondlife-bin-1.23_rc4 (14 Jun 2009)
+
+ 14 Jun 2009; Joe Peterson <lavajoe@gentoo.org>
+ +secondlife-bin-1.23_rc4.ebuild,
+ +files/secondlife-bin-1.23_rc4-amd64-audio-streaming-fix.patch:
+ Add new 1.23_rc4
26 May 2009; Joe Peterson <lavajoe@gentoo.org>
secondlife-bin-1.22.11.ebuild, secondlife-bin-1.23_rc2.ebuild:
diff --git a/games-simulation/secondlife-bin/files/secondlife-bin-1.23_rc4-amd64-audio-streaming-fix.patch b/games-simulation/secondlife-bin/files/secondlife-bin-1.23_rc4-amd64-audio-streaming-fix.patch
new file mode 100644
index 000000000000..5d5f3486b21f
--- /dev/null
+++ b/games-simulation/secondlife-bin/files/secondlife-bin-1.23_rc4-amd64-audio-streaming-fix.patch
@@ -0,0 +1,26 @@
+--- secondlife.old 2009-06-09 08:53:20.000000000 -0600
++++ secondlife 2009-06-14 12:16:32.000000000 -0600
+@@ -5,7 +5,7 @@
+ ## testing phase; you should not usually need to touch them.
+
+ ## - Avoids using any OpenAL audio driver.
+-#export LL_BAD_OPENAL_DRIVER=x
++export LL_BAD_OPENAL_DRIVER=x
+ ## - Avoids using any FMOD audio driver.
+ #export LL_BAD_FMOD_DRIVER=x
+
+@@ -48,10 +48,10 @@
+ ## - GStreamer is automatically disabled - for now - on 64-bit systems due
+ ## to common fatal incompatibilities; remove/comment these lines if you want
+ ## to try anyway.
+-if [ "`uname -m`" = "x86_64" ]; then
+- export LL_DISABLE_GSTREAMER=x
+- echo '64-bit Linux detected: Disabling GStreamer (streaming video and music) by default; edit ./secondlife to re-enable.'
+-fi
++#if [ "`uname -m`" = "x86_64" ]; then
++# export LL_DISABLE_GSTREAMER=x
++# echo '64-bit Linux detected: Disabling GStreamer (streaming video and music) by default; edit ./secondlife to re-enable.'
++#fi
+
+ ## Everything below this line is just for advanced troubleshooters.
+ ##-------------------------------------------------------------------
diff --git a/games-simulation/secondlife-bin/secondlife-bin-1.23_rc4.ebuild b/games-simulation/secondlife-bin/secondlife-bin-1.23_rc4.ebuild
new file mode 100644
index 000000000000..cf0ba2443a67
--- /dev/null
+++ b/games-simulation/secondlife-bin/secondlife-bin-1.23_rc4.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/secondlife-bin/secondlife-bin-1.23_rc4.ebuild,v 1.1 2009/06/14 18:34:25 lavajoe Exp $
+
+inherit eutils multilib games versionator
+
+SECONDLIFE_REVISION=123523
+SECONDLIFE_MAJOR_VER=$(get_version_component_range 1-2)
+SECONDLIFE_MINOR_VER=$(get_version_component_range 3)
+SECONDLIFE_MINOR_VER=${SECONDLIFE_MINOR_VER/rc/}
+MY_P="SecondLife-i686-${SECONDLIFE_MAJOR_VER}.${SECONDLIFE_MINOR_VER}.${SECONDLIFE_REVISION}"
+
+DESCRIPTION="The Second Life (an online, 3D virtual world) viewer"
+HOMEPAGE="http://secondlife.com/"
+SRC_URI="http://automated-builds-secondlife-com.s3.amazonaws.com/viewer-rc-frozen/${SECONDLIFE_REVISION}/${MY_P}.tar.bz2"
+RESTRICT="mirror strip"
+
+LICENSE="GPL-2-with-Linden-Lab-FLOSS-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Note, used to RDEPEND on:
+# media-fonts/kochi-substitute
+RDEPEND="sys-libs/glibc
+ sys-apps/dbus
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ >=x11-libs/gtk+-2.0
+ x11-libs/libXinerama
+ dev-libs/libgcrypt
+ dev-libs/libgpg-error
+ dev-libs/openssl
+ dev-libs/apr
+ dev-libs/apr-util
+ dev-libs/boost
+ dev-libs/elfio
+ dev-libs/expat
+ media-libs/freetype
+ media-libs/libogg
+ media-libs/libsdl
+ media-libs/libvorbis
+ media-libs/gstreamer
+ media-plugins/gst-plugins-meta
+ media-libs/fmod
+ media-libs/jpeg
+ media-libs/openjpeg
+ net-libs/gnutls
+ net-misc/curl
+ net-dns/c-ares
+ sys-libs/zlib
+ virtual/libstdc++
+ virtual/glu
+ virtual/opengl
+ media-libs/openal
+ media-libs/freealut
+ amd64? (
+ app-emulation/emul-linux-x86-sdl
+ app-emulation/emul-linux-x86-gtklibs
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+SECONDLIFE_HOME="${GAMES_PREFIX_OPT}/secondlife"
+
+QA_TEXTRELS="${SECONDLIFE_HOME:1}/bin/libllkdu.so
+ ${SECONDLIFE_HOME:1}/lib/libkdu.so
+ ${SECONDLIFE_HOME:1}/lib/libfmod-3.75.so
+ ${SECONDLIFE_HOME:1}/lib/libvivoxsdk.so
+ ${SECONDLIFE_HOME:1}/app_settings/mozilla-runtime-linux-i686/libxul.so"
+QA_EXECSTACK="${SECONDLIFE_HOME:1}/bin/do-not-directly-run-secondlife-bin
+ ${SECONDLIFE_HOME:1}/bin/libllkdu.so
+ ${SECONDLIFE_HOME:1}/lib/libSDL-1.2.so.0
+ ${SECONDLIFE_HOME:1}/lib/libcrypto.so.0.9.7
+ ${SECONDLIFE_HOME:1}/lib/libkdu.so
+ ${SECONDLIFE_HOME:1}/lib/libfmod-3.75.so
+ ${SECONDLIFE_HOME:1}/app_settings/mozilla-runtime-linux-i686/libxul.so"
+
+pkg_setup() {
+ games_pkg_setup
+
+ # x86 binary package, ABI=x86
+ has_multilib_profile && ABI="x86"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # On 64-bit systems, we need to uncomment LL_BAD_OPENAL_DRIVER=x
+ # to fix streaming audio.
+ use amd64 && epatch "${FILESDIR}"/${P}-amd64-audio-streaming-fix.patch
+}
+
+src_install() {
+ exeinto "${SECONDLIFE_HOME}"
+ doexe launch_url.sh secondlife || die
+ rm -rf launch_url.sh secondlife
+
+ exeinto "${SECONDLIFE_HOME}"/bin
+ doexe bin/* || die
+ rm -rf bin
+
+ exeinto "${SECONDLIFE_HOME}"/lib
+ doexe lib/* || die
+ rm -rf lib
+
+ insinto "${SECONDLIFE_HOME}"
+ doins -r * || die "doins * failed"
+
+ #dosym /usr/share/fonts/kochi-substitute/kochi-mincho-subst.ttf "${SECONDLIFE_HOME}"/unicode.ttf
+
+ games_make_wrapper secondlife-bin "./secondlife --set VersionChannelName Gentoo" "${SECONDLIFE_HOME}" "${SECONDLIFE_HOME}"/lib
+ make_desktop_entry secondlife-bin "Second Life (binary distribution)" /opt/secondlife/secondlife_icon.png
+
+ prepgamesdirs
+}