summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-07-29 21:28:56 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-07-29 21:28:56 +0000
commit155477dc4a3866f68d5adc9f933f0e265639638a (patch)
tree648bbd9788aa12963b346700c7e42c9cfbb4cb59 /games-strategy/boswars
parentfix broken png images wrt #475764 (diff)
downloadgentoo-2-155477dc4a3866f68d5adc9f933f0e265639638a.tar.gz
gentoo-2-155477dc4a3866f68d5adc9f933f0e265639638a.tar.bz2
gentoo-2-155477dc4a3866f68d5adc9f933f0e265639638a.zip
fix broken png images wrt #475764
(Portage version: 2.2.0_alpha190/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-strategy/boswars')
-rw-r--r--games-strategy/boswars/ChangeLog7
-rw-r--r--games-strategy/boswars/boswars-2.7-r1.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/games-strategy/boswars/ChangeLog b/games-strategy/boswars/ChangeLog
index 6a8527e60192..c904f2f9ed3b 100644
--- a/games-strategy/boswars/ChangeLog
+++ b/games-strategy/boswars/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/boswars
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/ChangeLog,v 1.21 2013/06/24 16:11:50 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/ChangeLog,v 1.22 2013/07/29 21:28:56 hasufell Exp $
+
+*boswars-2.7-r1 (29 Jul 2013)
+
+ 29 Jul 2013; Julian Ospald <hasufell@gentoo.org> +boswars-2.7-r1.ebuild:
+ fix broken png images wrt #475764
*boswars-2.7 (24 Jun 2013)
diff --git a/games-strategy/boswars/boswars-2.7-r1.ebuild b/games-strategy/boswars/boswars-2.7-r1.ebuild
new file mode 100644
index 000000000000..6e411e9b65df
--- /dev/null
+++ b/games-strategy/boswars/boswars-2.7-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/boswars-2.7-r1.ebuild,v 1.1 2013/07/29 21:28:56 hasufell Exp $
+
+EAPI=5
+inherit eutils scons-utils games
+
+DESCRIPTION="Futuristic real-time strategy game"
+HOMEPAGE="http://www.boswars.org/"
+SRC_URI="http://www.boswars.org/dist/releases/${P}-src.tar.gz
+ http://dev.gentoo.org/~hasufell/distfiles/${P}-fixed-images-for-libpng-1.6.tar.xz
+ mirror://gentoo/bos.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/lua
+ media-libs/libsdl[audio,video]
+ media-libs/libpng:0
+ media-libs/libvorbis
+ media-libs/libtheora
+ media-libs/libogg
+ virtual/opengl
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}-src
+
+src_unpack() {
+ default
+ # bug 475764
+ cp -dRp ${P}-fixed-images-for-libpng-1.6/* ${P}-src/ \
+ || die "copying fixed images failed!"
+}
+
+src_prepare() {
+ rm -f doc/{README-SDL.txt,guichan-copyright.txt}
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-scons-blows.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ engine/include/stratagus.h \
+ || die
+ sed -i \
+ -e "/-O2/s:-O2.*math:${CXXFLAGS} -Wall:" \
+ SConstruct \
+ || die
+}
+
+src_compile() {
+ escons || die
+}
+
+src_install() {
+ newgamesbin build/${PN}-release ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r campaigns graphics intro languages maps patches scripts sounds units
+ newicon "${DISTDIR}"/bos.png ${PN}.png
+ make_desktop_entry ${PN} "Bos Wars"
+ # COPYRIGHT.txt is referenced by the html
+ dodoc CHANGELOG COPYRIGHT.txt README.txt
+ dohtml -r doc/*
+ prepgamesdirs
+}