summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-03-22 22:35:48 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-03-22 22:35:48 +0000
commit4b2a66884a580ef6504db8ca08c46fe24ebf4a4b (patch)
tree5e6449d9ef350a4d2f8c9a902949694be5cf9a49 /games-strategy/freeciv/freeciv-2.0.8.ebuild
parentRemove unused digest (diff)
downloadgentoo-2-4b2a66884a580ef6504db8ca08c46fe24ebf4a4b.tar.gz
gentoo-2-4b2a66884a580ef6504db8ca08c46fe24ebf4a4b.tar.bz2
gentoo-2-4b2a66884a580ef6504db8ca08c46fe24ebf4a4b.zip
Icon for menu, bug #125344
(Portage version: 2.1_pre6-r4)
Diffstat (limited to 'games-strategy/freeciv/freeciv-2.0.8.ebuild')
-rw-r--r--games-strategy/freeciv/freeciv-2.0.8.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/games-strategy/freeciv/freeciv-2.0.8.ebuild b/games-strategy/freeciv/freeciv-2.0.8.ebuild
index 1fb3a8adfb9e..caf7ea0396e1 100644
--- a/games-strategy/freeciv/freeciv-2.0.8.ebuild
+++ b/games-strategy/freeciv/freeciv-2.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/freeciv-2.0.8.ebuild,v 1.6 2006/03/12 15:53:07 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/freeciv-2.0.8.ebuild,v 1.7 2006/03/22 22:35:48 tupone Exp $
inherit games
@@ -94,6 +94,17 @@ src_unpack() {
configure \
|| die "sed failed"
+ # change .desktop icon to the freeciv icon rather than the gnome globe
+ sed -i \
+ -e 's:^\(Icon=\).*:\1freeciv.png:' \
+ bootstrap/freeciv.desktop.in \
+ || die "sed failed"
+
+ # change .desktop category so it is not gnome specific
+ sed -i \
+ -e 's:^\(Categories=GNOME;Application;Game;Strategy;\):Categories=Application;Game;StrategyGame;:' \
+ bootstrap/freeciv.desktop.in \
+ || die "sed failed"
# install the .desktop in /usr/share/applications
sed -i \
-e 's:^\(desktopfiledir = \).*:\1/usr/share/applications:' \
@@ -168,5 +179,7 @@ src_install() {
dodoc ChangeLog NEWS \
doc/{BUGS,CodingStyle,HACKING,HOWTOPLAY,PEOPLE,README*,TODO}
+ doicon "${FILESDIR}/${PN}.png"
+
prepgamesdirs
}