summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-09-27 08:17:05 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-09-27 08:17:05 +0000
commit23379d1b6a444ba32da7f2952389617b310b737e (patch)
tree5b9baacda631e42668f95b148dbf5d91c5f44112 /games-strategy/spaz/spaz-1.605.ebuild
parentgames-strategy/spaz can not run on amd64 non-multilib profiles, so masking it... (diff)
downloadgentoo-2-23379d1b6a444ba32da7f2952389617b310b737e.tar.gz
gentoo-2-23379d1b6a444ba32da7f2952389617b310b737e.tar.bz2
gentoo-2-23379d1b6a444ba32da7f2952389617b310b737e.zip
Initial commit
(Portage version: 2.2.0_alpha132/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy/spaz/spaz-1.605.ebuild')
-rw-r--r--games-strategy/spaz/spaz-1.605.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-strategy/spaz/spaz-1.605.ebuild b/games-strategy/spaz/spaz-1.605.ebuild
new file mode 100644
index 000000000000..0d0ca607a841
--- /dev/null
+++ b/games-strategy/spaz/spaz-1.605.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/spaz/spaz-1.605.ebuild,v 1.1 2012/09/27 08:17:05 pinkbyte Exp $
+
+EAPI=4
+
+inherit games
+
+DESCRIPTION="Space Pirates and Zombies"
+HOMEPAGE="http://spacepiratesandzombies.com"
+SRC_URI="${PN}-linux-humblebundle-09182012-bin"
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="alsa pulseaudio"
+RESTRICT="fetch strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND="amd64? ( app-emulation/emul-linux-x86-sdl )
+ x86? (
+ media-libs/openal[alsa?,pulseaudio?]
+ media-libs/libsdl
+ )
+ "
+
+S="${WORKDIR}"/data
+
+QA_PREBUILT="opt/spaz/SPAZ"
+
+src_unpack() {
+ unzip -q "${DISTDIR}/${PN}-linux-humblebundle-09182012-bin"
+}
+
+src_install() {
+ local dir="${GAMES_PREFIX_OPT}/${PN}"
+
+ insinto "${dir}"
+ exeinto "${dir}"
+ doexe SPAZ
+ doins -r common game mods
+ doins audio.so
+ newicon SPAZ.png spaz.png
+ dodoc README-linux.txt
+
+ games_make_wrapper ${PN} ./SPAZ "${dir}" "${dir}"
+ make_desktop_entry ${PN} "Space Pirates and Zombies" ${PN}
+
+ prepgamesdirs
+}