summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-03-11 19:01:29 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-03-11 19:01:29 +0000
commit07685137a22eb45bf721f3ced274b0d7fd67cfb5 (patch)
tree89d7f1b066d60700b5bea4fddbb56ae8eb44a8a9 /games-strategy/ufo-ai
parentVersion bumped. Thanks to NODA Kai <g340299@mail.ecc.u-tokyo.ac.jp> for contr... (diff)
downloadgentoo-2-07685137a22eb45bf721f3ced274b0d7fd67cfb5.tar.gz
gentoo-2-07685137a22eb45bf721f3ced274b0d7fd67cfb5.tar.bz2
gentoo-2-07685137a22eb45bf721f3ced274b0d7fd67cfb5.zip
Fixed errors using ${ARCH} and adding back absolute paths.
Diffstat (limited to 'games-strategy/ufo-ai')
-rw-r--r--games-strategy/ufo-ai/ChangeLog6
-rw-r--r--games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild23
2 files changed, 19 insertions, 10 deletions
diff --git a/games-strategy/ufo-ai/ChangeLog b/games-strategy/ufo-ai/ChangeLog
index 6bb33136469c..9b75bacc21d4 100644
--- a/games-strategy/ufo-ai/ChangeLog
+++ b/games-strategy/ufo-ai/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/ufo-ai
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ChangeLog,v 1.4 2004/03/11 13:40:59 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ChangeLog,v 1.5 2004/03/11 19:01:29 wolf31o2 Exp $
+
+ 11 Mar 2004; Chris Gianelloni <wolf31o2@gentoo.org>
+ ufo-ai-0.10.040218.ebuild:
+ Fixed errors using ${ARCH} and adding back absolute paths.
11 Mar 2004; Chris Gianelloni <wolf31o2@gentoo.org>
ufo-ai-0.10.040218.ebuild:
diff --git a/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild b/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild
index 9283ffe21fe1..5368305c9762 100644
--- a/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild
+++ b/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild,v 1.4 2004/03/11 13:40:59 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild,v 1.5 2004/03/11 19:01:29 wolf31o2 Exp $
inherit games
-S=${WORKDIR}
DESCRIPTION="UFO: Alien Invasion - X-COM inspired strategy game"
SRC_URI="http://n.ethz.ch/student/dbeyeler/download/ufoai_source_040218.zip
http://people.ee.ethz.ch/~baepeter/linux_ufoaidemo.zip"
@@ -23,28 +22,34 @@ DEPEND="virtual/glibc
media-libs/libogg"
src_unpack() {
- unpack ${A}
+ unpack ${A} || die "unpacking"
cd source/linux
epatch ${FILESDIR}/${PV}-Makefile.patch
}
src_compile() {
- cd source/linux
+ cd ${S}/source/linux
make build_release \
OPTCFLAGS="${CFLAGS}" \
|| die "make failed"
- cd ../..
}
src_install() {
dodir ${GAMES_DATADIR}/${PN}
- cp -rf ufo/* ${D}${GAMES_DATADIR}/${PN}
- cd source/linux/release${ARCH}-glibc
+ cp -rf ${S}/ufo/* ${D}${GAMES_DATADIR}/${PN} || die "copying data"
+ if [ ${ARCH} == x86 ]; then
+ ARCH=i386
+ fi
exeinto ${GAMES_DATADIR}/${PN}
- doexe ref_gl.so ref_glx.so ufo
+ doexe ${S}/source/linux/release${ARCH}-glibc/{ref_gl.so,ref_glx.so,ufo} \
+ || "doexe ufo"
exeinto ${GAMES_DATADIR}/${PN}/base
- doexe game${ARCH}.so
+ doexe ${S}/source/linux/release${ARCH}-glibc/game${ARCH}.so \
+ || die "doexe game${ARCH}.so"
games_make_wrapper ufo-ai ./ufo ${GAMES_DATADIR}/${PN}
prepgamesdirs
}
+pkg_postinst() {
+ games_pkg_postinst
+}