summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-03-11 01:25:07 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-03-11 01:25:07 +0000
commit1b6a5c66a2e703dae8d6213388644f74d65df5f5 (patch)
tree76e97235aa7378f55a8e70b3aa01e08c54aeffef /games-strategy/warmux
parentpython-novaclient-9999 now uses [${PYTHON_USEDEP}] (diff)
downloadgentoo-2-1b6a5c66a2e703dae8d6213388644f74d65df5f5.tar.gz
gentoo-2-1b6a5c66a2e703dae8d6213388644f74d65df5f5.tar.bz2
gentoo-2-1b6a5c66a2e703dae8d6213388644f74d65df5f5.zip
add patch so it works on xfs submitted by Andreas Wiese via bug #460422
(Portage version: 2.1.11.52/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-strategy/warmux')
-rw-r--r--games-strategy/warmux/ChangeLog8
-rw-r--r--games-strategy/warmux/files/warmux-11.04.1-stat.patch61
-rw-r--r--games-strategy/warmux/warmux-11.04.1.ebuild7
3 files changed, 71 insertions, 5 deletions
diff --git a/games-strategy/warmux/ChangeLog b/games-strategy/warmux/ChangeLog
index 680728f095b9..b301bba90b5e 100644
--- a/games-strategy/warmux/ChangeLog
+++ b/games-strategy/warmux/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/warmux
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/warmux/ChangeLog,v 1.14 2012/11/05 16:58:48 mr_bones_ Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warmux/ChangeLog,v 1.15 2013/03/11 01:25:07 mr_bones_ Exp $
+
+ 11 Mar 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/warmux-11.04.1-stat.patch, warmux-11.04.1.ebuild:
+ add patch so it works on xfs submitted by Andreas Wiese via bug #460422
05 Nov 2012; Michael Sterrett <mr_bones_@gentoo.org> warmux-11.04.1.ebuild:
update HOMEPAGE
diff --git a/games-strategy/warmux/files/warmux-11.04.1-stat.patch b/games-strategy/warmux/files/warmux-11.04.1-stat.patch
new file mode 100644
index 000000000000..487b3805ba6f
--- /dev/null
+++ b/games-strategy/warmux/files/warmux-11.04.1-stat.patch
@@ -0,0 +1,61 @@
+diff -ur warmux-11.04.orig/lib/warmux/tools/file_tools.cpp warmux-11.04/lib/warmux/tools/file_tools.cpp
+--- warmux-11.04.orig/lib/warmux/tools/file_tools.cpp 2011-04-28 21:03:13.000000000 +0200
++++ warmux-11.04/lib/warmux/tools/file_tools.cpp 2013-03-05 16:58:42.040443845 +0100
+@@ -33,6 +33,8 @@
+ # include <direct.h>
+ # undef DeleteFile // windows.h defines it I think
+ #else
++# include <sys/types.h>
++# include <sys/stat.h>
+ # include <stdlib.h> // getenv
+ # include <unistd.h> // not needed by mingw
+ #endif
+@@ -275,18 +277,14 @@
+ {
+ DIR *dir;
+ struct dirent *file;
+-#ifdef __SYMBIAN32__
+ std::string dname;
+-#endif
+ };
+
+ FolderSearch* OpenFolder(const std::string& dirname)
+ {
+ FolderSearch *f = new FolderSearch;
+ f->dir = opendir(dirname.c_str());
+-#ifdef __SYMBIAN32__
+ f->dname = dirname;
+-#endif
+
+ if (!f->dir) {
+ delete f;
+@@ -300,11 +298,11 @@
+ {
+ while ((f->file = readdir(f->dir)) != NULL) {
+
++ if (
+ #ifdef __SYMBIAN32__
+- if (f->file->d_namlen && DoesFolderExist(f->dname+"/"+std::string(f->file->d_name))) {
+-#else
+- if (f->file->d_type == DT_DIR) {
++ f->file->d_namlen &&
+ #endif
++ DoesFolderExist(f->dname+"/"+std::string(f->file->d_name))) {
+ // If we are also looking for files, report it isn't one
+ if (file)
+ file = false;
+@@ -316,11 +314,11 @@
+ continue;
+
+ // This is a file and we do search for file
++ if (
+ #ifdef __SYMBIAN32__
+- if (f->file->d_namlen && DoesFileExist(f->dname+"/"+std::string(f->file->d_name))) {
+-#else
+- if (f->file->d_type == DT_REG) {
++ f->file->d_namlen &&
+ #endif
++ DoesFileExist(f->dname+"/"+std::string(f->file->d_name))) {
+ file = true;
+ return f->file->d_name;
+ }
diff --git a/games-strategy/warmux/warmux-11.04.1.ebuild b/games-strategy/warmux/warmux-11.04.1.ebuild
index 5cb3abbf8b58..78db1f644dc5 100644
--- a/games-strategy/warmux/warmux-11.04.1.ebuild
+++ b/games-strategy/warmux/warmux-11.04.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/warmux/warmux-11.04.1.ebuild,v 1.7 2012/11/05 16:58:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warmux/warmux-11.04.1.ebuild,v 1.8 2013/03/11 01:25:07 mr_bones_ Exp $
EAPI=2
inherit autotools eutils games
@@ -37,7 +37,8 @@ src_prepare() {
"${FILESDIR}"/${P}-gentoo.patch \
"${FILESDIR}"/${P}-zlib.patch \
"${FILESDIR}"/${P}-action.patch \
- "${FILESDIR}"/${P}-gcc47.patch
+ "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-stat.patch
eautoreconf
}