summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-02-22 22:32:40 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-02-22 22:32:40 +0000
commit95f3bcd46795f23723afb1f16cfd0a08e3ef899f (patch)
tree77d624de154bad1246ba44e0970a0af22a6e3453 /games-strategy/wesnoth
parentUpdating lvm2 to version 2.00.33 (diff)
downloadgentoo-2-95f3bcd46795f23723afb1f16cfd0a08e3ef899f.tar.gz
gentoo-2-95f3bcd46795f23723afb1f16cfd0a08e3ef899f.tar.bz2
gentoo-2-95f3bcd46795f23723afb1f16cfd0a08e3ef899f.zip
version bump
(Portage version: 2.0.51-r15)
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/ChangeLog7
-rw-r--r--games-strategy/wesnoth/Manifest2
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.8.112
-rw-r--r--games-strategy/wesnoth/wesnoth-0.8.11.ebuild66
4 files changed, 76 insertions, 1 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 21f3c17f7eb5..a26b56910f1a 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.45 2005/02/12 19:37:59 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.46 2005/02/22 22:32:40 mr_bones_ Exp $
+
+*wesnoth-0.8.11 (22 Feb 2005)
+
+ 22 Feb 2005; Michael Sterrett <mr_bones_@gentoo.org> +wesnoth-0.8.11.ebuild:
+ version bump
*wesnoth-0.8.7 (12 Feb 2005)
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index 3e15ce0d0f2e..5824081b81e2 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,4 +1,6 @@
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 857eea5e5ef16e9067c04311468cf091 ChangeLog 6301
MD5 93581e11441f3cd875599dfbea67f87a wesnoth-0.8.10.ebuild 1766
+MD5 93581e11441f3cd875599dfbea67f87a wesnoth-0.8.11.ebuild 1766
MD5 b7e6563ad1ede86d02ff1afcaa76e84e files/digest-wesnoth-0.8.10 141
+MD5 3c7adc12b44a2b4b9d788c8f422ba401 files/digest-wesnoth-0.8.11 141
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.8.11 b/games-strategy/wesnoth/files/digest-wesnoth-0.8.11
new file mode 100644
index 000000000000..528e4373deb6
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.8.11
@@ -0,0 +1,2 @@
+MD5 929c65818cc2fb47227929f253fb1f8c wesnoth-0.8.11.tar.gz 33034379
+MD5 fc6691a607fc99b8771fe462e7547ac0 wesnoth-lite-0.8.11.tar.gz 17239199
diff --git a/games-strategy/wesnoth/wesnoth-0.8.11.ebuild b/games-strategy/wesnoth/wesnoth-0.8.11.ebuild
new file mode 100644
index 000000000000..dbffb7436007
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.8.11.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.8.11.ebuild,v 1.1 2005/02/22 22:32:40 mr_bones_ Exp $
+
+inherit eutils flag-o-matic gcc games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="!lite? ( mirror://sourceforge/wesnoth/${P}.tar.gz )
+ lite? ( mirror://sourceforge/wesnoth/${PN}-lite-${PV}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="editor gnome kde lite nls server tools"
+
+DEPEND=">=media-libs/libsdl-1.2.7
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/freetype-2
+ media-libs/sdl-net
+ sys-libs/zlib
+ virtual/x11"
+
+src_unpack() {
+ if use lite ; then
+ unpack ${PN}-lite-${PV}.tar.gz
+ S=${WORKDIR}/${PN}-lite-${PV}
+ else
+ unpack ${P}.tar.gz
+ fi
+ cd "${S}"
+ sed -i \
+ -e 's/--expandvars//' configure \
+ || die "sed failed"
+}
+
+src_compile() {
+ if use lite ; then
+ S=${WORKDIR}/${PN}-lite-${PV}
+ fi
+ cd "${S}"
+ filter-flags -ftracer -fomit-frame-pointer
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable server) \
+ $(use_enable server campaign-server) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable nls) \
+ $(use_with gnome) \
+ $(use_with kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ if use lite ; then
+ S=${WORKDIR}/${PN}-lite-${PV}
+ fi
+ cd "${S}"
+ make DESTDIR="${D}" install || die "make install failed"
+ mv "${D}${GAMES_DATADIR}/"{icons,applnk,applications} "${D}/usr/share/"
+ dodoc MANUAL changelog
+ prepgamesdirs
+}