summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-08-26 23:13:07 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-08-26 23:13:07 +0000
commit3219857c4e10db8c21d0b4bd8a17231d37339e6a (patch)
tree76f5b9e7efe5cd0351ce0492e66f4a423ab454aa /games-strategy
parentversion bump (bug #481036) (diff)
downloadgentoo-2-3219857c4e10db8c21d0b4bd8a17231d37339e6a.tar.gz
gentoo-2-3219857c4e10db8c21d0b4bd8a17231d37339e6a.tar.bz2
gentoo-2-3219857c4e10db8c21d0b4bd8a17231d37339e6a.zip
old
(Portage version: 2.1.12.2/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog5
-rw-r--r--games-strategy/wesnoth/wesnoth-1.10.5.ebuild117
2 files changed, 4 insertions, 118 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index ac4749ec3dd9..391f93f6effe 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.228 2013/08/19 18:54:25 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.229 2013/08/26 23:13:07 mr_bones_ Exp $
+
+ 26 Aug 2013; Michael Sterrett <mr_bones_@gentoo.org> -wesnoth-1.10.5.ebuild:
+ old
*wesnoth-1.10.7 (19 Aug 2013)
diff --git a/games-strategy/wesnoth/wesnoth-1.10.5.ebuild b/games-strategy/wesnoth/wesnoth-1.10.5.ebuild
deleted file mode 100644
index 951d32080da3..000000000000
--- a/games-strategy/wesnoth/wesnoth-1.10.5.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.10.5.ebuild,v 1.4 2013/01/13 11:40:17 ago Exp $
-
-EAPI=2
-inherit cmake-utils eutils multilib toolchain-funcs flag-o-matic games
-
-DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
-HOMEPAGE="http://www.wesnoth.org/"
-SRC_URI="mirror://sourceforge/wesnoth/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ~ppc64 x86 ~x86-fbsd"
-IUSE="dbus dedicated doc nls server"
-
-RDEPEND=">=media-libs/libsdl-1.2.7[joystick,video,X]
- media-libs/sdl-net
- >=media-libs/sdl-ttf-2.0.8
- >=media-libs/sdl-mixer-1.2[vorbis]
- >=media-libs/sdl-image-1.2[jpeg,png]
- !dedicated? (
- dbus? ( sys-apps/dbus )
- )
- >=dev-libs/boost-1.36
- sys-libs/zlib
- x11-libs/pango
- dev-lang/lua
- media-libs/fontconfig
- virtual/libintl"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- sys-devel/gettext"
-
-src_prepare() {
- if use dedicated || use server ; then
- sed \
- -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
- -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
- -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
- -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
- > "${T}"/wesnothd \
- || die "sed failed"
- fi
- if ! use doc ; then
- sed -i \
- -e '/manual/d' \
- doc/CMakeLists.txt \
- || die "sed failed"
- fi
- # how do I hate boost? Let me count the ways...
- local boost_ver=$(best_version ">=dev-libs/boost-1.36")
-
- boost_ver=${boost_ver/*boost-/}
- boost_ver=${boost_ver%.*}
- boost_ver=${boost_ver/./_}
-
- einfo "Using boost version ${boost_ver}"
- append-cxxflags \
- -I/usr/include/boost-${boost_ver}
- append-ldflags \
- -L/usr/$(get_libdir)/boost-${boost_ver}
- export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
- export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
-}
-
-src_configure() {
- filter-flags -ftracer -fomit-frame-pointer
- if [[ $(gcc-major-version) -eq 3 ]] ; then
- filter-flags -fstack-protector
- append-flags -fno-stack-protector
- fi
- if use dedicated || use server ; then
- mycmakeargs=(
- "-DENABLE_CAMPAIGN_SERVER=TRUE"
- "-DENABLE_SERVER=TRUE"
- "-DSERVER_UID=${GAMES_USER_DED}"
- "-DSERVER_GID=${GAMES_GROUP}"
- "-DFIFO_DIR=${GAMES_STATEDIR}/run/wesnothd"
- )
- else
- mycmakeargs=(
- "-DENABLE_CAMPAIGN_SERVER=FALSE"
- "-DENABLE_SERVER=FALSE"
- )
- fi
- mycmakeargs+=(
- $(cmake-utils_use_enable !dedicated GAME)
- $(cmake-utils_use_enable !dedicated ENABLE_DESKTOP_ENTRY)
- $(cmake-utils_use_enable nls NLS)
- $(cmake-utils_use_enable dbus NOTIFICATIONS)
- "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
- "-DENABLE_FRIBIDI=FALSE"
- "-DENABLE_STRICT_COMPILATION=FALSE"
- "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
- "-DDATAROOTDIR=${GAMES_DATADIR}"
- "-DBINDIR=${GAMES_BINDIR}"
- "-DICONDIR=/usr/share/pixmaps"
- "-DDESKTOPDIR=/usr/share/applications"
- "-DMANDIR=/usr/share/man"
- "-DDOCDIR=/usr/share/doc/${PF}"
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_install() {
- DOCS="README changelog players_changelog" cmake-utils_src_install
- if use dedicated || use server; then
- keepdir "${GAMES_STATEDIR}/run/wesnothd"
- doinitd "${T}"/wesnothd || die "doinitd failed"
- fi
- prepgamesdirs
-}