summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-10-04 19:46:07 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-10-04 19:46:07 +0000
commit8a360b0aebd6df792ff5742704cfa2501c6dd6ae (patch)
tree04258af144bf4d7cb8a9c95f09db988ae10cafe9 /games-strategy
parentremove for bug #237175 and CVE-2008-3964 (diff)
downloadgentoo-2-8a360b0aebd6df792ff5742704cfa2501c6dd6ae.tar.gz
gentoo-2-8a360b0aebd6df792ff5742704cfa2501c6dd6ae.tar.bz2
gentoo-2-8a360b0aebd6df792ff5742704cfa2501c6dd6ae.zip
Version bump to 2.2.1 Bug #206145 by Jaak Ristioja
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/ufo-ai/ChangeLog8
-rw-r--r--games-strategy/ufo-ai/files/ufo-ai-2.2.1-gentoo.patch44
-rw-r--r--games-strategy/ufo-ai/metadata.xml3
-rw-r--r--games-strategy/ufo-ai/ufo-ai-2.2.1.ebuild101
4 files changed, 155 insertions, 1 deletions
diff --git a/games-strategy/ufo-ai/ChangeLog b/games-strategy/ufo-ai/ChangeLog
index a21fff72f248..9c57a4ea3d31 100644
--- a/games-strategy/ufo-ai/ChangeLog
+++ b/games-strategy/ufo-ai/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/ufo-ai
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ChangeLog,v 1.19 2008/08/24 14:56:35 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ChangeLog,v 1.20 2008/10/04 19:46:06 tupone Exp $
+
+*ufo-ai-2.2.1 (04 Oct 2008)
+
+ 04 Oct 2008; <tupone@gentoo.org> +files/ufo-ai-2.2.1-gentoo.patch,
+ +ufo-ai-2.2.1.ebuild:
+ Version bump to 2.2.1 Bug #206145 by Jaak Ristioja
24 Aug 2008; Tupone Alfredo <tupone@gentoo.org>
+files/ufo-ai-2.1.1-dprintf.patch, ufo-ai-2.1.1-r1.ebuild:
diff --git a/games-strategy/ufo-ai/files/ufo-ai-2.2.1-gentoo.patch b/games-strategy/ufo-ai/files/ufo-ai-2.2.1-gentoo.patch
new file mode 100644
index 000000000000..5fed2ad8a4e5
--- /dev/null
+++ b/games-strategy/ufo-ai/files/ufo-ai-2.2.1-gentoo.patch
@@ -0,0 +1,44 @@
+--- src/common/files.c.old 2008-10-04 18:09:14.000000000 +0200
++++ src/common/files.c 2008-10-04 18:10:45.000000000 +0200
+@@ -889,7 +889,7 @@
+
+ /* basedir <path> */
+ /* allows the game to run from outside the data tree */
+- fs_basedir = Cvar_Get("fs_basedir", ".", CVAR_NOSET, "Allows the game to run from outside the data tree");
++ fs_basedir = Cvar_Get("fs_basedir", "@GENTOO_DATADIR@", CVAR_NOSET, "Allows the game to run from outside the data tree");
+
+ /* start up with base by default */
+ FS_AddGameDirectory(va("%s/" BASEDIRNAME, fs_basedir->string));
+--- src/tools/gtkradiant/games/ufoai.game.old 2008-10-04 18:22:56.000000000 +0200
++++ src/tools/gtkradiant/games/ufoai.game 2008-10-04 18:23:28.000000000 +0200
+@@ -3,7 +3,7 @@
+ type="q2"
+ name="UFO:Alien Invasion"
+ enginepath_win32="c:/ufoai/"
+- enginepath_linux="/usr/local/games/ufoai/"
++ enginepath_linux="@GENTOO_DATADIR@"
+ enginepath_macos="/Applications/UFOAI/"
+ engine_win32="ufo.exe"
+ engine_linux="ufo"
+--- src/client/cl_main.c.old 2008-10-04 18:24:57.000000000 +0200
++++ src/client/cl_main.c 2008-10-04 18:26:05.000000000 +0200
+@@ -2506,7 +2506,7 @@
+ if (*fs_i18ndir->string)
+ Q_strncpyz(languagePath, fs_i18ndir->string, sizeof(languagePath));
+ else
+- Com_sprintf(languagePath, sizeof(languagePath), "%s/"BASEDIRNAME"/i18n/", FS_GetCwd());
++ Com_sprintf(languagePath, sizeof(languagePath), "%s/"BASEDIRNAME"/i18n/", "@GENTOO_DATADIR@");
+ Com_DPrintf(DEBUG_CLIENT, "...using mo files from %s\n", languagePath);
+ bindtextdomain(TEXT_DOMAIN, languagePath);
+ bind_textdomain_codeset(TEXT_DOMAIN, "UTF-8");
+--- src/client/cl_language.c.old 2008-10-04 18:27:17.000000000 +0200
++++ src/client/cl_language.c 2008-10-04 19:03:04.000000000 +0200
+@@ -133,7 +133,7 @@
+ if (*fs_i18ndir->string)
+ Q_strncpyz(languagePath, fs_i18ndir->string, sizeof(languagePath));
+ else
+- Com_sprintf(languagePath, sizeof(languagePath), "%s/"BASEDIRNAME"/i18n/", FS_GetCwd());
++ Com_sprintf(languagePath, sizeof(languagePath), "%s/"BASEDIRNAME"/i18n/", "@GENTOO_DATADIR@");
+ Com_DPrintf(DEBUG_CLIENT, "CL_LanguageTest()... using mo files from '%s'\n", languagePath);
+ Q_strcat(languagePath, localeID, sizeof(languagePath));
+ Q_strcat(languagePath, "/LC_MESSAGES/ufoai.mo", sizeof(languagePath));
diff --git a/games-strategy/ufo-ai/metadata.xml b/games-strategy/ufo-ai/metadata.xml
index d3c2cc926f0b..8c35ca6b8d21 100644
--- a/games-strategy/ufo-ai/metadata.xml
+++ b/games-strategy/ufo-ai/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>games</herd>
+<use>
+ <flag name='editor'>Build map editor</flag>
+</use>
</pkgmetadata>
diff --git a/games-strategy/ufo-ai/ufo-ai-2.2.1.ebuild b/games-strategy/ufo-ai/ufo-ai-2.2.1.ebuild
new file mode 100644
index 000000000000..3d8e2ae9fdcb
--- /dev/null
+++ b/games-strategy/ufo-ai/ufo-ai-2.2.1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ufo-ai-2.2.1.ebuild,v 1.1 2008/10/04 19:46:06 tupone Exp $
+
+inherit eutils autotools games
+
+MY_P="${P/o-a/oa}"
+
+DESCRIPTION="UFO: Alien Invasion - X-COM inspired strategy game"
+HOMEPAGE="http://ufoai.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ufoai/${MY_P}-source.tar.bz2
+ mirror://sourceforge/ufoai/${MY_P}-data.tar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dedicated doc editor mmx"
+
+# Dependencies and more instructions can be found here:
+# http://ufoai.ninex.info/wiki/index.php/Compile_for_Linux
+RDEPEND="!dedicated? (
+ virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ media-libs/sdl-ttf
+ media-libs/sdl-mixer
+ media-libs/jpeg
+ media-libs/libpng
+ media-libs/libogg
+ media-libs/libvorbis
+ x11-proto/xf86vidmodeproto
+ )
+ editor? ( media-libs/jpeg )
+ net-misc/curl
+ sys-devel/gettext"
+
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )"
+
+S=${WORKDIR}/${MY_P}-source
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # move data from packages to source dir
+ mv "${WORKDIR}/base" "${S}"
+
+ # Set basedir & fixes bug in finding text files - it should use fs_basedir
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ src/common/files.c \
+ src/tools/gtkradiant/games/ufoai.game \
+ src/client/cl_main.c \
+ src/client/cl_language.c \
+ || die "sed failed"
+}
+
+src_compile() {
+ egamesconf \
+ $(use_enable mmx) \
+ --enable-release \
+ $(use_enable editor ufo2map) \
+ --enable-dedicated \
+ $(use_enable !dedicated client) \
+ --with-shaders
+
+ emake lang || die "emake langs failed"
+
+ if use doc ; then
+ emake pdf-manual || die "emake pdf-manual failed (USE=doc)"
+ fi
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ # server
+ dogamesbin ufoded || die "Failed installing server"
+ newicon src/ports/linux/installer/data/ufo.xpm ${PN}.xpm \
+ || die "Failed installing icon"
+ make_desktop_entry ${PN}-ded "UFO: Alien Invasion Server" ${PN}.xpm
+ if ! use dedicated ; then
+ # client
+ newgamesbin ufo ${PN} || die "Failed installing client"
+ make_desktop_entry ${PN} "UFO: Alien Invasion" ${PN}.xpm
+ fi
+
+ if use editor ; then
+ dogamesbin ufo2map || die "Failed installing editor"
+ fi
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r base || die "doins -r failed"
+ if use doc ; then
+ dodoc src/docs/tex/ufo-manual_EN.pdf || die "Failed installing manual"
+ fi
+
+ prepgamesdirs
+}