summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-03-27 22:11:44 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-03-27 22:11:44 +0000
commitb695e11a45a310565163830abd32136ad6882ec9 (patch)
tree37f7bd0201c6c0b896f060c54521ddb5ad712669 /games-strategy
parentfixing versions on git master 9999 (diff)
downloadgentoo-2-b695e11a45a310565163830abd32136ad6882ec9.tar.gz
gentoo-2-b695e11a45a310565163830abd32136ad6882ec9.tar.bz2
gentoo-2-b695e11a45a310565163830abd32136ad6882ec9.zip
version bump
(Portage version: 2.2.9-r1/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/liquidwar6/ChangeLog7
-rw-r--r--games-strategy/liquidwar6/liquidwar6-0.4.3681.ebuild111
2 files changed, 117 insertions, 1 deletions
diff --git a/games-strategy/liquidwar6/ChangeLog b/games-strategy/liquidwar6/ChangeLog
index 4409e9e9c6d1..057e0655212d 100644
--- a/games-strategy/liquidwar6/ChangeLog
+++ b/games-strategy/liquidwar6/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/liquidwar6
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/liquidwar6/ChangeLog,v 1.3 2014/01/08 16:53:56 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/liquidwar6/ChangeLog,v 1.4 2014/03/27 22:11:44 hasufell Exp $
+
+*liquidwar6-0.4.3681 (27 Mar 2014)
+
+ 27 Mar 2014; Julian Ospald <hasufell@gentoo.org> +liquidwar6-0.4.3681.ebuild:
+ version bump
*liquidwar6-0.2.3551 (08 Jan 2014)
diff --git a/games-strategy/liquidwar6/liquidwar6-0.4.3681.ebuild b/games-strategy/liquidwar6/liquidwar6-0.4.3681.ebuild
new file mode 100644
index 000000000000..3a7cebeac80e
--- /dev/null
+++ b/games-strategy/liquidwar6/liquidwar6-0.4.3681.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/liquidwar6/liquidwar6-0.4.3681.ebuild,v 1.1 2014/03/27 22:11:44 hasufell Exp $
+
+EAPI=5
+
+inherit autotools eutils toolchain-funcs games
+
+MY_PV=${PV/_beta/beta}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Unique multiplayer wargame between liquids"
+HOMEPAGE="http://www.gnu.org/software/liquidwar6/"
+SRC_URI="http://www.ufoot.org/download/liquidwar/v6/${MY_PV}/${MY_P}.tar.gz
+ maps? ( http://www.ufoot.org/download/liquidwar/v6/${MY_PV}/${PN}-extra-maps-${MY_PV}.tar.gz )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gles2 gtk libcaca +maps nls +ogg openmp readline test"
+
+# yes, cunit is rdep
+RDEPEND="dev-db/sqlite:3
+ dev-libs/expat
+ dev-scheme/guile
+ dev-util/cunit
+ media-libs/freetype:2
+ media-libs/libpng:0
+ media-libs/libsdl[X,opengl,video]
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-ttf
+ net-misc/curl
+ sys-devel/libtool:2
+ sys-libs/zlib
+ virtual/glu
+ virtual/jpeg
+ virtual/opengl
+ libcaca? ( media-libs/libcaca )
+ gles2? ( media-libs/mesa[gles2] )
+ gtk? ( x11-libs/gtk+:2 )
+ nls? ( virtual/libintl
+ virtual/libiconv )
+ ogg? (
+ media-libs/libsdl[X,audio,opengl,video]
+ media-libs/sdl-mixer[vorbis]
+ )
+ readline? ( sys-libs/ncurses
+ sys-libs/readline )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_P}
+S_MAPS=${WORKDIR}/${PN}-extra-maps-${MY_PV}
+
+pkg_setup() {
+ if use openmp; then
+ if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp ; then
+ ewarn "OpenMP is not available in your current selected gcc"
+ die "need openmp capable gcc"
+ fi
+ fi
+ games_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.2.3551-{ldconfig,paths}.patch
+
+ sed -i \
+ -e 's/-Werror//' \
+ configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ # configure fails with cunit disabled
+ egamesconf \
+ $(use_enable nls) \
+ --enable-cunit \
+ $(use_enable gtk) \
+ --enable-mod-gl1 \
+ $(use_enable gles2 mod-gles2) \
+ $(use_enable libcaca mod-caca) \
+ $(use_enable openmp) \
+ $(use_enable ogg mod-ogg) \
+ $(use_enable !ogg silent) \
+ $(use_enable readline console) \
+ --disable-static \
+ --datarootdir=/usr/share \
+ --mandir=/usr/share/man \
+ --docdir=/usr/share/doc/${PF} \
+ --htmldir=/usr/share/doc/${PF}/html
+
+ if use maps; then
+ cd "${S_MAPS}" || die
+ egamesconf
+ fi
+}
+
+src_compile() {
+ default
+ use doc && emake html
+ use maps && emake -C "${S_MAPS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use maps && emake -C "${S_MAPS}" DESTDIR="${D}" install
+ prune_libtool_files --all
+ prepgamesdirs
+}