summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 18:53:23 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 18:53:23 +0000
commitf832b6aa8af70160dd49b2f91631e66e941b9dbe (patch)
treee28495f9d6e402f2d221775fbef168a3e40e3457 /games-util/atlas/atlas-0.2.2.ebuild
parentAdd local dv USE flag for mjpegtools. (diff)
downloadgentoo-2-f832b6aa8af70160dd49b2f91631e66e941b9dbe.tar.gz
gentoo-2-f832b6aa8af70160dd49b2f91631e66e941b9dbe.tar.bz2
gentoo-2-f832b6aa8af70160dd49b2f91631e66e941b9dbe.zip
welcome to games-util
Diffstat (limited to 'games-util/atlas/atlas-0.2.2.ebuild')
-rw-r--r--games-util/atlas/atlas-0.2.2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/games-util/atlas/atlas-0.2.2.ebuild b/games-util/atlas/atlas-0.2.2.ebuild
new file mode 100644
index 000000000000..565dd2f5146a
--- /dev/null
+++ b/games-util/atlas/atlas-0.2.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/atlas-0.2.2.ebuild,v 1.1 2003/09/10 18:53:23 vapier Exp $
+
+inherit games
+
+MY_P="Atlas-${PV}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Chart Program to use with Flightgear Flight Simulator"
+HOMEPAGE="http://atlas.sourceforge.net/"
+SRC_URI="mirror://sourceforge/atlas/${MY_P}.tar.gz"
+
+INSDESTTREE="/usr/games/lib/FlightGear"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+
+DEPEND=">=flightgear-0.8.0
+ >=libpng-1.2.5
+ >=media-libs/plib-1.4
+ virtual/glut"
+
+src_compile() {
+ egamesconf --with-fgbase=/usr/games/lib/FlightGear || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ doins ${S}/src/AtlasPalette || die
+ egamesinstall || die
+ keepdir /usr/games/lib/FlightGear/Atlas
+ keepdir /usr/games/lib/FlightGear/Atlas/lowres
+ dodoc AUTHORS README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ einfo "You now can make the maps with the following commands:"
+ einfo "/usr/games/bin/Map --atlas=/usr/games/lib/FlightGear/Atlas"
+ einfo "/usr/games/bin/Map --atlas=/usr/games/lib/FlightGear/Atlas/lowres --size=64"
+ echo
+ einfo "To run Atlas concurrently with FlightGear use the following:"
+ einfo "Atlas --path=[path of map images] --udp=[port number]"
+ einfo "and start fgfs with the following switch (or in .fgfsrc):"
+ einfo "--nmea=socket,out,0.5,[host that you run Atlas on],[port number],udp"
+ echo
+}
+
+pkg_postrm() {
+ einfo "You must manually remove the maps if you don't want them around."
+ einfo "They are found in the following directory:"
+ echo
+ einfo "/usr/games/lib/FlightGear/Atlas"
+ echo
+}