summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-07-21 15:03:58 +0000
committerAlex Alexander <wired@gentoo.org>2011-07-21 15:03:58 +0000
commitefe252b4a2f8094848c3dd9184ca0eda24808c6e (patch)
tree46ec184467b178aa038dc4f584a7d8939a5bd5be /games-util/gtkevemon
parentRemoved automatic configuration of features (diff)
downloadgentoo-2-efe252b4a2f8094848c3dd9184ca0eda24808c6e.tar.gz
gentoo-2-efe252b4a2f8094848c3dd9184ca0eda24808c6e.tar.bz2
gentoo-2-efe252b4a2f8094848c3dd9184ca0eda24808c6e.zip
first commit. based on the sunrise ebuilds by Andre Schulz.
(Portage version: 2.2.0_alpha46/cvs/Linux x86_64)
Diffstat (limited to 'games-util/gtkevemon')
-rw-r--r--games-util/gtkevemon/ChangeLog12
-rw-r--r--games-util/gtkevemon/files/gtkevemon-1.8-learning.patch.gzbin0 -> 5879 bytes
-rw-r--r--games-util/gtkevemon/files/gtkevemon-1.8-portrait.patch17
-rw-r--r--games-util/gtkevemon/gtkevemon-1.8-r1.ebuild49
-rw-r--r--games-util/gtkevemon/gtkevemon-9999.ebuild44
-rw-r--r--games-util/gtkevemon/metadata.xml15
6 files changed, 137 insertions, 0 deletions
diff --git a/games-util/gtkevemon/ChangeLog b/games-util/gtkevemon/ChangeLog
new file mode 100644
index 000000000000..954eb9fd0c81
--- /dev/null
+++ b/games-util/gtkevemon/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for games-util/gtkevemon
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/gtkevemon/ChangeLog,v 1.1 2011/07/21 15:03:58 wired Exp $
+
+*gtkevemon-9999 (21 Jul 2011)
+*gtkevemon-1.8-r1 (21 Jul 2011)
+
+ 21 Jul 2011; Alex Alexander <wired@gentoo.org> +gtkevemon-1.8-r1.ebuild,
+ +files/gtkevemon-1.8-learning.patch.gz, +files/gtkevemon-1.8-portrait.patch,
+ +gtkevemon-9999.ebuild, +metadata.xml:
+ first commit. based on the sunrise ebuilds by Andre Schulz.
+
diff --git a/games-util/gtkevemon/files/gtkevemon-1.8-learning.patch.gz b/games-util/gtkevemon/files/gtkevemon-1.8-learning.patch.gz
new file mode 100644
index 000000000000..d0706bb7c0e0
--- /dev/null
+++ b/games-util/gtkevemon/files/gtkevemon-1.8-learning.patch.gz
Binary files differ
diff --git a/games-util/gtkevemon/files/gtkevemon-1.8-portrait.patch b/games-util/gtkevemon/files/gtkevemon-1.8-portrait.patch
new file mode 100644
index 000000000000..8c2f4716ccca
--- /dev/null
+++ b/games-util/gtkevemon/files/gtkevemon-1.8-portrait.patch
@@ -0,0 +1,17 @@
+http://trac.battleclinic.com:8000/gtkevemon/changeset/121/trunk/gtkevemon/src/gtkportrait.cc
+
+Index: trunk/gtkevemon/src/gtkportrait.cc
+===================================================================
+--- trunk/gtkevemon/src/gtkportrait.cc (revision 109)
++++ trunk/gtkevemon/src/gtkportrait.cc (revision 121)
+@@ -107,6 +107,8 @@
+
+ AsyncHttp* http = AsyncHttp::create();;
+- http->set_host("img.eve.is");
+- http->set_path("/serv.asp?s=256&c=" + this->char_id);
++ //http->set_host("img.eve.is");
++ //http->set_path("/serv.asp?s=256&c=" + this->char_id);
++ http->set_host("image.eveonline.com");
++ http->set_path("/Character/" + this->char_id + "_256.jpg");
+ Config::setup_http(http);
+
diff --git a/games-util/gtkevemon/gtkevemon-1.8-r1.ebuild b/games-util/gtkevemon/gtkevemon-1.8-r1.ebuild
new file mode 100644
index 000000000000..3774e0479362
--- /dev/null
+++ b/games-util/gtkevemon/gtkevemon-1.8-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/gtkevemon/gtkevemon-1.8-r1.ebuild,v 1.1 2011/07/21 15:03:58 wired Exp $
+
+EAPI=4
+
+inherit eutils
+
+IUSE=""
+if [[ ${PV} == *9999* ]]; then
+ inherit subversion
+ ESVN_REPO_URI="svn://svn.battleclinic.com/GTKEVEMon/trunk/${PN}"
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="http://gtkevemon.battleclinic.com/releases/${P}-source.tar.gz"
+fi
+
+DESCRIPTION="A standalone skill monitoring application for EVE Online"
+HOMEPAGE="http://gtkevemon.battleclinic.com"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ dev-cpp/gtkmm:2.4
+ dev-libs/libxml2
+"
+DEPEND="${DEPEND}
+ dev-util/pkgconfig
+"
+
+src_prepare() {
+ sed -e 's:Categories=Game;$:Categories=Game;RolePlaying;GTK;:' \
+ -i icon/${PN}.desktop || die "sed failed"
+
+ # upstream fix for new character portrait URL
+ epatch "${FILESDIR}/${P}-portrait.patch"
+ # upstream fix for remap calculation after learning skills removal
+ epatch "${FILESDIR}/${P}-learning.patch.gz"
+}
+
+src_install() {
+ dobin src/${PN}
+ doicon icon/${PN}.xpm
+ domenu icon/${PN}.desktop
+ dodoc CHANGES README TODO
+}
diff --git a/games-util/gtkevemon/gtkevemon-9999.ebuild b/games-util/gtkevemon/gtkevemon-9999.ebuild
new file mode 100644
index 000000000000..cee2bba71f51
--- /dev/null
+++ b/games-util/gtkevemon/gtkevemon-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/gtkevemon/gtkevemon-9999.ebuild,v 1.1 2011/07/21 15:03:58 wired Exp $
+
+EAPI=4
+
+inherit eutils
+
+IUSE=""
+if [[ ${PV} == *9999* ]]; then
+ inherit subversion
+ ESVN_REPO_URI="svn://svn.battleclinic.com/GTKEVEMon/trunk/${PN}"
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="http://gtkevemon.battleclinic.com/releases/${P}-source.tar.gz"
+fi
+
+DESCRIPTION="A standalone skill monitoring application for EVE Online"
+HOMEPAGE="http://gtkevemon.battleclinic.com"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ dev-cpp/gtkmm:2.4
+ dev-libs/libxml2
+"
+DEPEND="${DEPEND}
+ dev-util/pkgconfig
+"
+
+src_prepare() {
+ sed -e 's:Categories=Game;$:Categories=Game;RolePlaying;GTK;:' \
+ -i icon/${PN}.desktop || die "sed failed"
+}
+
+src_install() {
+ dobin src/${PN}
+ doicon icon/${PN}.png
+ domenu icon/${PN}.desktop
+ dodoc CHANGES README TODO
+}
diff --git a/games-util/gtkevemon/metadata.xml b/games-util/gtkevemon/metadata.xml
new file mode 100644
index 000000000000..6e6fd3fb987b
--- /dev/null
+++ b/games-util/gtkevemon/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>wired@gentoo.org</email>
+ <name>Alex Alexander</name>
+ </maintainer>
+ <longdescription lang="en">
+ GtkEveMon is a standalone skill monitoring application for EVE Online.
+ It allows monitoring characters' skills and skill training process without
+ starting EVE Online. It is intended as a lightweight, cross-platform
+ alternative to EveMon, a popular skill monitoring application for Windows.
+ </longdescription>
+</pkgmetadata>