summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-12-07 00:04:32 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-12-07 00:04:32 +0000
commit796321d989b82ac3afe2034eb5dbb457177efb44 (patch)
tree248ffb24f4e63652f2f17928da91e795bcb9fa58 /games-util/mattricks/mattricks-0.7.ebuild
parentstable x86, bug 197806 (diff)
downloadgentoo-2-796321d989b82ac3afe2034eb5dbb457177efb44.tar.gz
gentoo-2-796321d989b82ac3afe2034eb5dbb457177efb44.tar.bz2
gentoo-2-796321d989b82ac3afe2034eb5dbb457177efb44.zip
Use wxversion to force wxpython-2.6 when multiple slots are available. Bug
201317. (Portage version: 2.1.4_rc7)
Diffstat (limited to 'games-util/mattricks/mattricks-0.7.ebuild')
-rw-r--r--games-util/mattricks/mattricks-0.7.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/games-util/mattricks/mattricks-0.7.ebuild b/games-util/mattricks/mattricks-0.7.ebuild
index c97c5ad9c674..4356bc5a1cf6 100644
--- a/games-util/mattricks/mattricks-0.7.ebuild
+++ b/games-util/mattricks/mattricks-0.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/mattricks/mattricks-0.7.ebuild,v 1.4 2007/02/24 19:24:13 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/mattricks/mattricks-0.7.ebuild,v 1.5 2007/12/07 00:04:32 dirtyepic Exp $
-inherit distutils
+inherit distutils eutils
MY_P=${P/m/M}
DESCRIPTION="Hattrick Manager"
@@ -18,3 +18,8 @@ DEPEND="<dev-python/wxpython-2.8
dev-python/pyxml"
S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ distutils_src_unpack
+ epatch "${FILESDIR}"/${P}-wxversion.patch
+}