summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-07-26 20:38:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-07-26 20:38:00 +0000
commitc11575f70e2778df0d42b429a055cfbc672eeb0a (patch)
tree77c15cf7178e2aa396a8f4b4629148cdb0d768de /games-util/showeq
parentAdding no-herd tag as requested by Thilo Bangert <bangert@gentoo.org> in bug ... (diff)
downloadgentoo-2-c11575f70e2778df0d42b429a055cfbc672eeb0a.tar.gz
gentoo-2-c11575f70e2778df0d42b429a055cfbc672eeb0a.tar.bz2
gentoo-2-c11575f70e2778df0d42b429a055cfbc672eeb0a.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-util/showeq')
-rw-r--r--games-util/showeq/ChangeLog8
-rw-r--r--games-util/showeq/showeq-5.13.5.0.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/games-util/showeq/ChangeLog b/games-util/showeq/ChangeLog
index 3126c968387f..bf4819b96b19 100644
--- a/games-util/showeq/ChangeLog
+++ b/games-util/showeq/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-util/showeq
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/showeq/ChangeLog,v 1.26 2009/01/12 19:50:46 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/showeq/ChangeLog,v 1.27 2009/07/26 20:38:00 mr_bones_ Exp $
+
+*showeq-5.13.5.0 (26 Jul 2009)
+
+ 26 Jul 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +showeq-5.13.5.0.ebuild:
+ version bump
12 Jan 2009; Tupone Alfredo <tupone@gentoo.org>
files/showeq-5.0.0.18-gcc4.patch, +files/showeq-5.12.4.2-gcc43.patch,
diff --git a/games-util/showeq/showeq-5.13.5.0.ebuild b/games-util/showeq/showeq-5.13.5.0.ebuild
new file mode 100644
index 000000000000..40c0714c8439
--- /dev/null
+++ b/games-util/showeq/showeq-5.13.5.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/showeq/showeq-5.13.5.0.ebuild,v 1.1 2009/07/26 20:38:00 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils qt3 games
+
+DESCRIPTION="An Everquest monitoring program"
+HOMEPAGE="http://www.showeq.net/"
+SRC_URI="mirror://sourceforge/seq/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/libpcap
+ x11-libs/qt:3"
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-debug \
+ --disable-optimization
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doman showeq.1
+ dodoc AUTHORS BUGS ChangeLog FAQ NEWS README ROADMAP TODO doc/*.{doc,txt}
+ dohtml doc/map.html
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "For complete functionality, download and extract the following"
+ elog "files into ${GAMES_DATADIR}/${PN}"
+ elog
+ elog "http://patch.everquest.com:7000/patch/everquest/main/eqstr_us.txt.gz"
+ elog "http://patch.everquest.com:7000/patch/everquest/main/spells_us.txt.gz"
+ elog
+ elog "or simply run the following commands..."
+ elog " cd ${GAMES_DATADIR}/${PN}"
+ elog " for i in eqstr_us.txt spells_us.txt; do"
+ elog " wget --user-agent=SOEPatcher/curl \\"
+ elog " http://patch.everquest.com:7000/patch/everquest/main/\${i}.gz"
+ elog " gunzip \${i}.gz"
+ elog " done"
+ echo
+}