summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-08-09 17:29:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-08-09 17:29:42 +0000
commit5b0c6aed26d9036440b906bd7119956ce727c830 (patch)
tree1cc77f682e978ba3ce80e55add70581c02af4c7b /games-util
parent[app-emulation/xen] Sync 9999 and 4.1.1 (diff)
downloadgentoo-2-5b0c6aed26d9036440b906bd7119956ce727c830.tar.gz
gentoo-2-5b0c6aed26d9036440b906bd7119956ce727c830.tar.bz2
gentoo-2-5b0c6aed26d9036440b906bd7119956ce727c830.zip
Import upstream patch for libpng15 compability wrt #378493 by Diego Elio Pettenò
(Portage version: 2.2.0_alpha50/cvs/Linux x86_64)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/atlas/ChangeLog7
-rw-r--r--games-util/atlas/atlas-0.3.1_p20101101.ebuild5
-rw-r--r--games-util/atlas/files/atlas-0.3.1_p20101101-libpng15.patch13
3 files changed, 22 insertions, 3 deletions
diff --git a/games-util/atlas/ChangeLog b/games-util/atlas/ChangeLog
index b62734f6d770..3f726e0fc894 100644
--- a/games-util/atlas/ChangeLog
+++ b/games-util/atlas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-util/atlas
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/ChangeLog,v 1.25 2011/02/26 16:55:11 signals Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/ChangeLog,v 1.26 2011/08/09 17:29:42 ssuominen Exp $
+
+ 09 Aug 2011; Samuli Suominen <ssuominen@gentoo.org>
+ atlas-0.3.1_p20101101.ebuild, +files/atlas-0.3.1_p20101101-libpng15.patch:
+ Import upstream patch for libpng15 compability wrt #378493 by Diego Elio
+ Pettenò
26 Feb 2011; Kevin McCarthy <signals@gentoo.org>
atlas-0.3.1_p20100302.ebuild:
diff --git a/games-util/atlas/atlas-0.3.1_p20101101.ebuild b/games-util/atlas/atlas-0.3.1_p20101101.ebuild
index 59e2889bcf01..d8a3c4d9288e 100644
--- a/games-util/atlas/atlas-0.3.1_p20101101.ebuild
+++ b/games-util/atlas/atlas-0.3.1_p20101101.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/atlas-0.3.1_p20101101.ebuild,v 1.2 2011/02/26 13:35:50 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/atlas-0.3.1_p20101101.ebuild,v 1.3 2011/08/09 17:29:42 ssuominen Exp $
EAPI=2
-inherit autotools games
+inherit autotools eutils games
DESCRIPTION="Chart Program to use with Flightgear Flight Simulator"
HOMEPAGE="http://atlas.sourceforge.net/"
@@ -31,6 +31,7 @@ DEPEND=">=games-simulation/flightgear-2
x11-libs/libXmu"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng15.patch
eautoreconf
}
diff --git a/games-util/atlas/files/atlas-0.3.1_p20101101-libpng15.patch b/games-util/atlas/files/atlas-0.3.1_p20101101-libpng15.patch
new file mode 100644
index 000000000000..0ed98aeb479d
--- /dev/null
+++ b/games-util/atlas/files/atlas-0.3.1_p20101101-libpng15.patch
@@ -0,0 +1,13 @@
+http://atlas.cvs.sourceforge.net/viewvc/atlas/Atlas/src/Image.cxx?r1=1.7&r2=1.8
+
+--- src/Image.cxx
++++ src/Image.cxx
+@@ -319,7 +319,7 @@
+ return;
+ }
+
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ png_destroy_write_struct(&png_ptr, &info_ptr);
+ fclose(fp);
+ return;