summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-22 21:18:37 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-22 21:18:37 +0000
commit29badb9072d04f233e3c7e31ad3c898618a5d316 (patch)
treead0f4aa682502bc22c901026a818e9cfe7b498ea /gnome-base/gnome-common/gnome-common-1.2.4-r3.ebuild
parentgnome applets for gnome2 (diff)
downloadgentoo-2-29badb9072d04f233e3c7e31ad3c898618a5d316.tar.gz
gentoo-2-29badb9072d04f233e3c7e31ad3c898618a5d316.tar.bz2
gentoo-2-29badb9072d04f233e3c7e31ad3c898618a5d316.zip
common things for gnome2
Diffstat (limited to 'gnome-base/gnome-common/gnome-common-1.2.4-r3.ebuild')
-rw-r--r--gnome-base/gnome-common/gnome-common-1.2.4-r3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnome-base/gnome-common/gnome-common-1.2.4-r3.ebuild b/gnome-base/gnome-common/gnome-common-1.2.4-r3.ebuild
new file mode 100644
index 000000000000..03ce1eb099e4
--- /dev/null
+++ b/gnome-base/gnome-common/gnome-common-1.2.4-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-common/gnome-common-1.2.4-r3.ebuild,v 1.1 2002/05/22 21:18:37 spider Exp $
+
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Some Common files for Gnome2 applications"
+SRC_URI="ftp://ftp.gnome.org/pub/gnome/pre-gnome2/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+LICENSE="GPL-2"
+SLOT="1"
+
+
+RDEPEND=">=dev-libs/glib-2.0.0"
+DEPEND="${RDEPEND} >=dev-util/pkgconfig-0.12.0"
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --enable-debug=yes || die "configure failure"
+ emake || die "compile failure"
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die "install failure"
+
+ dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS
+}