summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-03-07 08:36:30 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-03-07 08:36:30 +0000
commitfa1a12fb17c00e45aafb1c5d944e1e1452eb4ad9 (patch)
treed8a0c65eb6075fb4ab63e774639bc3e3fe92a888 /gnome-base/gnome-menus
parentClean up old revision. (diff)
downloadgentoo-2-fa1a12fb17c00e45aafb1c5d944e1e1452eb4ad9.tar.gz
gentoo-2-fa1a12fb17c00e45aafb1c5d944e1e1452eb4ad9.tar.bz2
gentoo-2-fa1a12fb17c00e45aafb1c5d944e1e1452eb4ad9.zip
Clean up old revisions.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'gnome-base/gnome-menus')
-rw-r--r--gnome-base/gnome-menus/ChangeLog7
-rw-r--r--gnome-base/gnome-menus/files/gnome-menus-3.6.1-applications-merged.patch102
-rw-r--r--gnome-base/gnome-menus/gnome-menus-3.4.2-r1.ebuild131
-rw-r--r--gnome-base/gnome-menus/gnome-menus-3.6.1-r2.ebuild115
4 files changed, 6 insertions, 349 deletions
diff --git a/gnome-base/gnome-menus/ChangeLog b/gnome-base/gnome-menus/ChangeLog
index c8cb95cd1235..5510b2bb873c 100644
--- a/gnome-base/gnome-menus/ChangeLog
+++ b/gnome-base/gnome-menus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/gnome-menus
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-menus/ChangeLog,v 1.182 2013/01/22 08:38:59 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-menus/ChangeLog,v 1.183 2013/03/07 08:36:30 eva Exp $
+
+ 07 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org>
+ -gnome-menus-3.4.2-r1.ebuild, -gnome-menus-3.6.1-r2.ebuild,
+ -files/gnome-menus-3.6.1-applications-merged.patch:
+ Clean up old revisions.
*gnome-menus-3.6.2 (22 Jan 2013)
diff --git a/gnome-base/gnome-menus/files/gnome-menus-3.6.1-applications-merged.patch b/gnome-base/gnome-menus/files/gnome-menus-3.6.1-applications-merged.patch
deleted file mode 100644
index ada08df02491..000000000000
--- a/gnome-base/gnome-menus/files/gnome-menus-3.6.1-applications-merged.patch
+++ /dev/null
@@ -1,102 +0,0 @@
-From e047041a49ad9e857b97c534203a98aac80de8d8 Mon Sep 17 00:00:00 2001
-From: Alexandre Rostovtsev <tetromino@gentoo.org>
-Date: Sat, 24 Nov 2012 15:24:50 -0500
-Subject: [PATCH] libmenu: always call menu_layout_load() with
- non_prefixed_name parameter
-
-We must ensure that when loading "${XDG_MENU_PREFIX}applications.menu",
-the root layout node's name is set to "applications", not
-"${XDG_MENU_PREFIX}applications", because the menu spec states that the
-default merge directory for "${XDG_MENU_PREFIX}applications.menu" is
-"applications-merged", not "${XDG_MENU_PREFIX}applications-merged".
-
-https://bugzilla.gnome.org/show_bug.cgi?id=688972
----
- libmenu/gmenu-tree.c | 31 +++++++++++++++++++++++++++++--
- 1 file changed, 29 insertions(+), 2 deletions(-)
-
-diff --git a/libmenu/gmenu-tree.c b/libmenu/gmenu-tree.c
-index 3e59c2c..dd6c670 100644
---- a/libmenu/gmenu-tree.c
-+++ b/libmenu/gmenu-tree.c
-@@ -60,6 +60,7 @@ struct _GMenuTree
- GObject parent_instance;
-
- char *basename;
-+ char *non_prefixed_basename;
- char *path;
- char *canonical_path;
-
-@@ -524,6 +525,24 @@ gmenu_tree_constructor (GType type,
- }
-
- static void
-+gmenu_tree_update_non_prefixed_basename (GMenuTree *tree,
-+ const gchar *filename)
-+{
-+ gchar *s, *basename;
-+
-+ g_free (tree->non_prefixed_basename);
-+ tree->non_prefixed_basename = NULL;
-+ if (filename == NULL)
-+ return;
-+ s = g_strdup_printf ("%sapplications.menu", g_getenv ("XDG_MENU_PREFIX"));
-+ basename = g_path_get_basename (filename);
-+ if (!g_strcmp0 (basename, "applications.menu") || !g_strcmp0 (basename, s))
-+ tree->non_prefixed_basename = g_strdup ("applications.menu");
-+ g_free (s);
-+ g_free (basename);
-+}
-+
-+static void
- gmenu_tree_set_property (GObject *object,
- guint prop_id,
- const GValue *value,
-@@ -534,10 +553,14 @@ gmenu_tree_set_property (GObject *object,
- switch (prop_id)
- {
- case PROP_MENU_BASENAME:
-+ if (g_strcmp0 (self->basename, g_value_get_string (value)))
-+ gmenu_tree_update_non_prefixed_basename (self, g_value_get_string (value));
- self->basename = g_value_dup_string (value);
- break;
-
- case PROP_MENU_PATH:
-+ if (g_strcmp0 (self->path, g_value_get_string (value)))
-+ gmenu_tree_update_non_prefixed_basename (self, g_value_get_string (value));
- self->path = g_value_dup_string (value);
- break;
-
-@@ -587,6 +610,9 @@ gmenu_tree_finalize (GObject *object)
- g_free (tree->basename);
- tree->basename = NULL;
-
-+ g_free (tree->non_prefixed_basename);
-+ tree->non_prefixed_basename = NULL;
-+
- if (tree->path != NULL)
- g_free (tree->path);
- tree->path = NULL;
-@@ -1896,7 +1922,7 @@ load_merge_file (GMenuTree *tree,
-
- menu_verbose ("Merging file \"%s\"\n", canonical);
-
-- to_merge = menu_layout_load (canonical, NULL, NULL);
-+ to_merge = menu_layout_load (canonical, tree->non_prefixed_basename, NULL);
- if (to_merge == NULL)
- {
- menu_verbose ("No menu for file \"%s\" found when merging\n",
-@@ -3053,8 +3079,9 @@ gmenu_tree_load_layout (GMenuTree *tree,
- tree->canonical_path);
-
- error = NULL;
-+
- tree->layout = menu_layout_load (tree->canonical_path,
-- tree->path ? NULL : tree->basename,
-+ tree->non_prefixed_basename,
- error);
- if (!tree->layout)
- return FALSE;
---
-1.8.0
-
diff --git a/gnome-base/gnome-menus/gnome-menus-3.4.2-r1.ebuild b/gnome-base/gnome-menus/gnome-menus-3.4.2-r1.ebuild
deleted file mode 100644
index f54dd4391ddd..000000000000
--- a/gnome-base/gnome-menus/gnome-menus-3.4.2-r1.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-menus/gnome-menus-3.4.2-r1.ebuild,v 1.2 2012/12/19 09:55:31 tetromino Exp $
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit eutils gnome2 python
-
-DESCRIPTION="The GNOME menu system, implementing the F.D.O cross-desktop spec"
-HOMEPAGE="http://www.gnome.org"
-
-LICENSE="GPL-2+ LGPL-2+"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-
-# +python for gmenu-simple-editor
-IUSE="debug +introspection +python test"
-
-COMMON_DEPEND=">=dev-libs/glib-2.29.15:2
- introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
- python? (
- >=dev-libs/gobject-introspection-0.9.5
- dev-python/pygobject:3
- x11-libs/gdk-pixbuf:2[introspection]
- x11-libs/gtk+:3[introspection] )"
-# Older versions of slot 0 install the menu editor and the desktop directories
-RDEPEND="${COMMON_DEPEND}
- !<gnome-base/gnome-menus-3.0.1-r1:0"
-DEPEND="${COMMON_DEPEND}
- sys-devel/gettext
- virtual/pkgconfig
- >=dev-util/intltool-0.40
- test? ( dev-libs/gjs )"
-
-pkg_setup() {
- use python && python_pkg_setup
- DOCS="AUTHORS ChangeLog HACKING NEWS README"
-
- # Do NOT compile with --disable-debug/--enable-debug=no
- # It disables api usage checks
- if ! use debug ; then
- G2CONF="${G2CONF} --enable-debug=minimum"
- fi
-
- if use python || use introspection; then
- use introspection || ewarn "Enabling introspection due to USE=python"
- G2CONF="${G2CONF} --enable-introspection"
- else
- G2CONF="${G2CONF} --disable-introspection"
- fi
-
- G2CONF="${G2CONF} --disable-static"
-}
-
-src_prepare() {
- gnome2_src_prepare
-
- # Don't show KDE standalone settings desktop files in GNOME others menu
- epatch "${FILESDIR}/${PN}-3.0.0-ignore_kde_standalone.patch"
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=688972
- epatch "${FILESDIR}/${PN}-3.6.1-applications-merged.patch"
-
- if use python; then
- python_clean_py-compile_files
- python_copy_sources
- else
- sed -e 's/\(SUBDIRS.*\) simple-editor/\1/' \
- -i Makefile.* || die "sed failed"
- fi
-}
-
-src_configure() {
- if use python; then
- python_execute_function -s gnome2_src_configure
- else
- gnome2_src_configure
- fi
-}
-
-src_compile() {
- if use python; then
- python_execute_function -s gnome2_src_compile
- else
- gnome2_src_compile
- fi
-}
-
-src_test() {
- if use python; then
- python_execute_function -s -d
- else
- default
- fi
-}
-
-src_install() {
- if use python; then
- python_execute_function -s gnome2_src_install
- python_clean_installation_image
- else
- gnome2_src_install
- fi
-
- # Prefix menu, bug #256614
- mv "${ED}"/etc/xdg/menus/applications.menu \
- "${ED}"/etc/xdg/menus/gnome-applications.menu || die "menu move failed"
-
- exeinto /etc/X11/xinit/xinitrc.d/
- newexe "${FILESDIR}/10-xdg-menu-gnome-r1" 10-xdg-menu-gnome
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- if use python; then
- python_mod_optimize GMenuSimpleEditor
- fi
-}
-
-pkg_postrm() {
- gnome2_pkg_postrm
- if use python; then
- python_mod_cleanup GMenuSimpleEditor
- fi
-}
diff --git a/gnome-base/gnome-menus/gnome-menus-3.6.1-r2.ebuild b/gnome-base/gnome-menus/gnome-menus-3.6.1-r2.ebuild
deleted file mode 100644
index b0aad30cd152..000000000000
--- a/gnome-base/gnome-menus/gnome-menus-3.6.1-r2.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-menus/gnome-menus-3.6.1-r2.ebuild,v 1.1 2012/12/19 09:55:31 tetromino Exp $
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit eutils gnome2 python-r1
-
-DESCRIPTION="The GNOME menu system, implementing the F.D.O cross-desktop spec"
-HOMEPAGE="http://www.gnome.org"
-
-LICENSE="GPL-2+ LGPL-2+"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-
-# +python for gmenu-simple-editor
-IUSE="debug +introspection +python test"
-REQUIRED_USE="python? ( introspection )"
-
-COMMON_DEPEND=">=dev-libs/glib-2.29.15:2
- introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
- python? (
- ${PYTHON_DEPS}
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- x11-libs/gdk-pixbuf:2[introspection]
- x11-libs/gtk+:3[introspection] )"
-# Older versions of slot 0 install the menu editor and the desktop directories
-RDEPEND="${COMMON_DEPEND}
- !<gnome-base/gnome-menus-3.0.1-r1:0"
-DEPEND="${COMMON_DEPEND}
- >=dev-util/intltool-0.40
- sys-devel/gettext
- virtual/pkgconfig
- test? ( dev-libs/gjs )"
-
-src_prepare() {
- gnome2_src_prepare
-
- # Don't show KDE standalone settings desktop files in GNOME others menu
- epatch "${FILESDIR}/${PN}-3.0.0-ignore_kde_standalone.patch"
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=688972
- epatch "${FILESDIR}/${PN}-3.6.1-applications-merged.patch"
-
- if use python; then
- python_copy_sources
- else
- sed -e 's/\(SUBDIRS.*\) simple-editor/\1/' \
- -i Makefile.* || die "sed failed"
- fi
-}
-
-src_configure() {
- DOCS="AUTHORS ChangeLog HACKING NEWS README"
-
- # Do NOT compile with --disable-debug/--enable-debug=no
- # It disables api usage checks
- G2CONF="${G2CONF}
- $(usex debug --enable-debug=yes --enable-debug=minimum)
- $(use_enable introspection)
- --disable-static"
-
- if use python; then
- python_foreach_impl run_in_build_dir gnome2_src_configure
- else
- gnome2_src_configure
- fi
-}
-
-src_compile() {
- if use python; then
- python_foreach_impl run_in_build_dir gnome2_src_compile
- else
- gnome2_src_compile
- fi
-}
-
-src_test() {
- if use python; then
- python_foreach_impl run_in_build_dir default
- else
- default
- fi
-}
-
-src_install() {
- if use python; then
- installing() {
- gnome2_src_install
- # Massage shebang to make python_doscript happy
- sed -e 's:#!'"${PYTHON}:#!/usr/bin/python:" \
- -i simple-editor/gmenu-simple-editor || die
- python_doscript simple-editor/gmenu-simple-editor
- }
- python_foreach_impl run_in_build_dir installing
- else
- gnome2_src_install
- fi
-
- # Prefix menu, bug #256614
- mv "${ED}"/etc/xdg/menus/applications.menu \
- "${ED}"/etc/xdg/menus/gnome-applications.menu || die "menu move failed"
-
- exeinto /etc/X11/xinit/xinitrc.d/
- newexe "${FILESDIR}/10-xdg-menu-gnome-r1" 10-xdg-menu-gnome
-}
-
-run_in_build_dir() {
- pushd "${BUILD_DIR}" > /dev/null || die
- "$@"
- popd > /dev/null
-}