summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Houser <chouser@gentoo.org>2001-11-07 05:21:57 +0000
committerChris Houser <chouser@gentoo.org>2001-11-07 05:21:57 +0000
commit74e6398cf5d7bd18de1efc66bad53ee2c4d28b06 (patch)
tree46c01d582f6d0b3ab95449492be4f12322de4ffa /gnome-base/gnome-print
parenttypo fix. verwilist, pleas be more careful! (diff)
downloadgentoo-2-74e6398cf5d7bd18de1efc66bad53ee2c4d28b06.tar.gz
gentoo-2-74e6398cf5d7bd18de1efc66bad53ee2c4d28b06.tar.bz2
gentoo-2-74e6398cf5d7bd18de1efc66bad53ee2c4d28b06.zip
cleaned up font installation
0.31 was not installing new fontmaps at all if old ones existed, and new fontmaps were incorrect in such a way that guppi crashed, taking it's host application (gnucash, gnumeric) with it. 0.31-r1 should fix these problems
Diffstat (limited to 'gnome-base/gnome-print')
-rw-r--r--gnome-base/gnome-print/files/digest-gnome-print-0.31-r11
-rw-r--r--gnome-base/gnome-print/gnome-print-0.31-r1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/gnome-base/gnome-print/files/digest-gnome-print-0.31-r1 b/gnome-base/gnome-print/files/digest-gnome-print-0.31-r1
new file mode 100644
index 000000000000..5028d500905e
--- /dev/null
+++ b/gnome-base/gnome-print/files/digest-gnome-print-0.31-r1
@@ -0,0 +1 @@
+MD5 345886fa17f598b7487b67bf876f3cef gnome-print-0.31.tar.gz 925696
diff --git a/gnome-base/gnome-print/gnome-print-0.31-r1.ebuild b/gnome-base/gnome-print/gnome-print-0.31-r1.ebuild
new file mode 100644
index 000000000000..130a7b2614aa
--- /dev/null
+++ b/gnome-base/gnome-print/gnome-print-0.31-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-print/gnome-print-0.31-r1.ebuild,v 1.1 2001/11/07 05:21:57 chouser Exp $
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="gnome-print"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+RDEPEND=">=media-libs/gdk-pixbuf-0.11.0-r1
+ >=gnome-base/libglade-0.17-r1"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ sys-devel/perl
+ >=app-text/ghostscript-6.50-r2"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${S}
+ # add missing DESTDIR to font installation
+ sed 's:all \($(datadir).*\)\($(sysconfdir)\):all $(DESTDIR)\1$(DESTDIR)\2:'\
+ installer/Makefile.in > installer/Makefile.in.new
+ mv installer/Makefile.in.new installer/Makefile.in
+ # add --clean to gnome-font-install options so that currently-installed
+ # fontmaps will be ignored and new complete ones will be built
+ sed "s:'--dynamic',:& '--clean',:" \
+ run-gnome-font-install > run-gnome-font-install.new
+ mv run-gnome-font-install.new run-gnome-font-install
+}
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ $myconf || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dosed /etc/gnome/fonts/*
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+}