summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-03 17:15:27 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-03 17:15:27 +0000
commitb77db769a97f7e49f1e249e85e9feeb5a909b8ba (patch)
tree87a8d3ccacc5b64f66b8d99fd719f860a50c620e /gnome-base/orbit
parentInitial commit, wrt bug #263658. Ebuild by Mikle Kolyada, who will maintain t... (diff)
downloadgentoo-2-b77db769a97f7e49f1e249e85e9feeb5a909b8ba.tar.gz
gentoo-2-b77db769a97f7e49f1e249e85e9feeb5a909b8ba.tar.bz2
gentoo-2-b77db769a97f7e49f1e249e85e9feeb5a909b8ba.zip
gnome-base/orbit: Fix usage of srcdir with tests for atuomake-1.13 compatibility, #454956
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'gnome-base/orbit')
-rw-r--r--gnome-base/orbit/ChangeLog8
-rw-r--r--gnome-base/orbit/files/orbit-2.14.19-automake-1.13.patch22
-rw-r--r--gnome-base/orbit/orbit-2.14.19-r3.ebuild86
3 files changed, 115 insertions, 1 deletions
diff --git a/gnome-base/orbit/ChangeLog b/gnome-base/orbit/ChangeLog
index 9f25c02e46e3..d0543796a098 100644
--- a/gnome-base/orbit/ChangeLog
+++ b/gnome-base/orbit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/orbit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.197 2013/04/09 16:43:30 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.198 2013/05/03 17:15:27 jlec Exp $
+
+*orbit-2.14.19-r3 (03 May 2013)
+
+ 03 May 2013; Justin Lecher <jlec@gentoo.org> +orbit-2.14.19-r3.ebuild,
+ +files/orbit-2.14.19-automake-1.13.patch:
+ Fix usage of srcdir with tests for atuomake-1.13 compatibility, #454956
09 Apr 2013; Agostino Sarubbo <ago@gentoo.org> orbit-2.14.19-r2.ebuild:
Stable for sh, wrt bug #458984
diff --git a/gnome-base/orbit/files/orbit-2.14.19-automake-1.13.patch b/gnome-base/orbit/files/orbit-2.14.19-automake-1.13.patch
new file mode 100644
index 000000000000..fcfeefba08cb
--- /dev/null
+++ b/gnome-base/orbit/files/orbit-2.14.19-automake-1.13.patch
@@ -0,0 +1,22 @@
+ test/everything/Makefile.am | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/test/everything/Makefile.am b/test/everything/Makefile.am
+index 32beb36..1eef7ac 100644
+--- a/test/everything/Makefile.am
++++ b/test/everything/Makefile.am
+@@ -73,12 +73,12 @@ server_DEPENDENCIES=${EVERYTHING_BUILT} $(included_src)
+
+ IDL_FLAGS= --showcpperrors --add-imodule
+ IDL_FILES= everything.idl
+-include $(top_srcdir)/Makefile.shared
++include ../../Makefile.shared
+
+ BUILT_SOURCES = ${EVERYTHING_BUILT} everything-imodule.c
+ CLEANFILES = ${BUILT_SOURCES} iorfile
+
+-TESTS = $(srcdir)/test.sh
++TESTS = test.sh
+
+ EXTRA_DIST = $(IDL_FILES) test.sh $(included_src)
+
diff --git a/gnome-base/orbit/orbit-2.14.19-r3.ebuild b/gnome-base/orbit/orbit-2.14.19-r3.ebuild
new file mode 100644
index 000000000000..f2a77d2f88cf
--- /dev/null
+++ b/gnome-base/orbit/orbit-2.14.19-r3.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.19-r3.ebuild,v 1.1 2013/05/03 17:15:27 jlec Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME_ORG_MODULE="ORBit2"
+GNOME_TARBALL_SUFFIX="bz2"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 toolchain-funcs autotools
+
+DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
+HOMEPAGE="http://projects.gnome.org/ORBit2/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="pic static-libs test"
+REQUIRED_USE="test? ( debug )"
+
+RDEPEND=">=dev-libs/glib-2.8:2
+ >=dev-libs/libIDL-0.8.2
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Fix wrong process kill, bug #268142
+ sed "s:killall lt-timeout-server:killall timeout-server:" \
+ -i test/timeout.sh || die "sed 1 failed"
+
+ # Do not mess with CFLAGS
+ sed 's/-ggdb -O0//' -i configure.in configure || die "sed 2 failed"
+
+ if ! use test; then
+ sed -i -e 's/test //' Makefile.am || die
+ fi
+
+ # Drop failing test, bug #331709
+ sed -i -e 's/test-mem //' test/Makefile.am || die
+
+ # Fix link_protocol_is_local() for ipv4 on machines with ipv6
+ # https://bugzilla.gnome.org/show_bug.cgi?id=693636
+ epatch "${FILESDIR}/${PN}-2.14.19-link_protocol_is_local.patch"
+
+ # Build libname-server-2.a with -fPIC on hardened, bug #312161
+ epatch "${FILESDIR}/${PN}-2.14.19-fPIC.patch"
+
+ epatch "${FILESDIR}"/${P}-automake-1.13.patch
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+
+ # We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
+ # files to be not found by autotools when compiling ORBit. See bug #58540
+ # for more information. Please don't remove -- 8/18/06
+ unset IDL_DIR
+
+ # We need to use the hosts IDL compiler if cross-compiling, bug #262741
+ if tc-is-cross-compiler; then
+ # check that host version is present and executable
+ [ -x /usr/bin/orbit-idl-2 ] || die "Please emerge ~${CATEGORY}/${P} on the host system first"
+ G2CONF="${G2CONF} --with-idl-compiler=/usr/bin/orbit-idl-2"
+ fi
+ gnome2_src_configure \
+ $(use_enable pic libname-server-pic) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ # Parallel build fails from time to time, bug #273031
+ MAKEOPTS="${MAKEOPTS} -j1"
+ gnome2_src_compile
+}
+
+src_test() {
+ # can fail in parallel, see bug #235994
+ emake -j1 check
+}