summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-06-07 12:40:49 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-06-07 12:40:49 +0000
commit013a93f4734ac510c37ed3cf7904a2f18d8ff7db (patch)
tree4e62abc23d1b9ecc51a84310cef17619b31e2cb7 /gnome-base
parentadd chktex as a dep since its ebuld now works (diff)
downloadgentoo-2-013a93f4734ac510c37ed3cf7904a2f18d8ff7db.tar.gz
gentoo-2-013a93f4734ac510c37ed3cf7904a2f18d8ff7db.tar.bz2
gentoo-2-013a93f4734ac510c37ed3cf7904a2f18d8ff7db.zip
new version, eclassed
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/libgnomeprint/ChangeLog7
-rw-r--r--gnome-base/libgnomeprint/files/digest-libgnomeprint-1.115.01
-rw-r--r--gnome-base/libgnomeprint/libgnomeprint-1.115.0.ebuild42
3 files changed, 49 insertions, 1 deletions
diff --git a/gnome-base/libgnomeprint/ChangeLog b/gnome-base/libgnomeprint/ChangeLog
index 3b9cfd7ef144..a6d03eac158e 100644
--- a/gnome-base/libgnomeprint/ChangeLog
+++ b/gnome-base/libgnomeprint/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for gnome-extra/libgnomeprint
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/ChangeLog,v 1.1 2002/06/02 18:04:52 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/ChangeLog,v 1.2 2002/06/07 12:40:49 spider Exp $
+
+*libgnomeprint-1.115.0 (7 jun 2002)
+ 07 Jun 2002; Spider <spider@gentoo.org> libgnomeprint-1.115.0.ebuild:
+ gnome2 eclass, new version
+
*libgnomeprint-1.114.0 (27 May 2002)
27 May 2002; Spider <spider@gentoo.org> libgnomeprint-1.114.0.ebuild:
new version
diff --git a/gnome-base/libgnomeprint/files/digest-libgnomeprint-1.115.0 b/gnome-base/libgnomeprint/files/digest-libgnomeprint-1.115.0
new file mode 100644
index 000000000000..e47df9c759a5
--- /dev/null
+++ b/gnome-base/libgnomeprint/files/digest-libgnomeprint-1.115.0
@@ -0,0 +1 @@
+MD5 e44cf8558c5d82a49c495a894f48539a libgnomeprint-1.115.0.tar.bz2 470579
diff --git a/gnome-base/libgnomeprint/libgnomeprint-1.115.0.ebuild b/gnome-base/libgnomeprint/libgnomeprint-1.115.0.ebuild
new file mode 100644
index 000000000000..83d58e7566a2
--- /dev/null
+++ b/gnome-base/libgnomeprint/libgnomeprint-1.115.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/libgnomeprint-1.115.0.ebuild,v 1.1 2002/06/07 12:40:49 spider Exp $
+
+inherit gnome2
+# Author: Spider <spider@gentoo.org>
+# Maintainer: Spider <spider@gentoo.org>
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Printer handling for Gnome"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+
+
+RDEPEND=">=gnome-base/libbonobo-2.0.0
+ >=media-libs/libart_lgpl-2.3.8
+ >=x11-libs/pango-1.0.0
+ >=dev-libs/libxml2-2.4.22
+ >=dev-libs/glib-2.0.0
+ >=media-libs/freetype-2.0.9"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-0.9-r2 )
+ >=dev-util/pkgconfig-0.12.0"
+
+DOCS="AUTHORS COPYING* ChangeLog* INSTALL NEWS README"
+
+pkg_postinst() {
+ echo ">>> Updating Fonts"
+ libgnomeprint-2.0-font-install \
+ --debug \
+ --smart \
+ --static \
+ --aliases=/usr/share/gnome/libgnomeprint-2.0/fonts/adobe-urw.font \
+ --target=/usr/share/gnome/libgnomeprint-2.0/fonts/gnome-print.fontmap
+
+}
+
+