summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2008-09-13 13:36:28 +0000
committerRémi Cardona <remi@gentoo.org>2008-09-13 13:36:28 +0000
commite4262245abe2a3ebbbfc5d506c4658249bc00b4d (patch)
tree61ce63c3bf2f1efbd8e33d48135e1e230c426310 /gnome-base
parentVersion bump <http://my.opera.com/desktopteam/blog/2008/09/12/a-new-weekly-an... (diff)
downloadgentoo-2-e4262245abe2a3ebbbfc5d506c4658249bc00b4d.tar.gz
gentoo-2-e4262245abe2a3ebbbfc5d506c4658249bc00b4d.tar.bz2
gentoo-2-e4262245abe2a3ebbbfc5d506c4658249bc00b4d.zip
gnome-base/libbonobo: attach bonobo to dbus session bus (fixes bug #236864), move flex to DEPEND
(Portage version: 2.2_rc8/cvs/Linux 2.6.25-gentoo-r3 i686)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/libbonobo/ChangeLog9
-rw-r--r--gnome-base/libbonobo/files/libbonobo-2.22.0-quit-with-dbus-session.patch52
-rw-r--r--gnome-base/libbonobo/libbonobo-2.22.0-r1.ebuild50
3 files changed, 110 insertions, 1 deletions
diff --git a/gnome-base/libbonobo/ChangeLog b/gnome-base/libbonobo/ChangeLog
index d7dd6babbfd1..09e9c1b909bf 100644
--- a/gnome-base/libbonobo/ChangeLog
+++ b/gnome-base/libbonobo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-base/libbonobo
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libbonobo/ChangeLog,v 1.162 2008/08/12 13:31:54 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libbonobo/ChangeLog,v 1.163 2008/09/13 13:36:27 remi Exp $
+
+*libbonobo-2.22.0-r1 (13 Sep 2008)
+
+ 13 Sep 2008; Rémi Cardona <remi@gentoo.org>
+ +files/libbonobo-2.22.0-quit-with-dbus-session.patch,
+ +libbonobo-2.22.0-r1.ebuild:
+ attach bonobo to dbus session bus (fixes bug #236864), move flex to DEPEND
12 Aug 2008; Raúl Porcel <armin76@gentoo.org> libbonobo-2.22.0.ebuild:
alpha/ia64/sparc stable wrt #229709
diff --git a/gnome-base/libbonobo/files/libbonobo-2.22.0-quit-with-dbus-session.patch b/gnome-base/libbonobo/files/libbonobo-2.22.0-quit-with-dbus-session.patch
new file mode 100644
index 000000000000..43a8f185aee4
--- /dev/null
+++ b/gnome-base/libbonobo/files/libbonobo-2.22.0-quit-with-dbus-session.patch
@@ -0,0 +1,52 @@
+diff -up libbonobo-2.22.0/activation-server/activation-server-main.c.get-on-d-bus libbonobo-2.22.0/activation-server/activation-server-main.c
+--- libbonobo-2.22.0/activation-server/activation-server-main.c.get-on-d-bus 2008-04-29 14:18:57.000000000 -0400
++++ libbonobo-2.22.0/activation-server/activation-server-main.c 2008-04-29 14:19:00.000000000 -0400
+@@ -54,6 +54,8 @@
+
+ #include <glib/gstdio.h>
+
++#include <dbus/dbus-glib-lowlevel.h>
++
+ static gboolean server_threaded = FALSE;
+ static glong server_guard_depth = 0;
+ static GStaticRecMutex server_guard = G_STATIC_REC_MUTEX_INIT;
+@@ -398,6 +400,8 @@ main (int argc, char *argv[])
+ const gchar *debug_output_env;
+ #endif
+ GError *error = NULL;
++ DBusConnection *connection;
++ DBusError bus_error;
+
+ #ifdef HAVE_SETSID
+ /*
+@@ -535,6 +539,18 @@ main (int argc, char *argv[])
+
+ od_finished_internal_registration ();
+
++ dbus_error_init (&bus_error);
++ connection = dbus_bus_get (DBUS_BUS_SESSION, &bus_error);
++
++ if (dbus_error_is_set (&bus_error)) {
++ g_warning ("could not associate with desktop session: %s",
++ bus_error.message);
++ connection = NULL;
++ } else {
++ dbus_connection_setup_with_g_main (connection,
++ g_main_loop_get_context (main_loop));
++ }
++
+ if (getenv ("BONOBO_ACTIVATION_DEBUG") == NULL)
+ chdir ("/");
+
+diff -up libbonobo-2.22.0/configure.in.get-on-d-bus libbonobo-2.22.0/configure.in
+--- libbonobo-2.22.0/configure.in.get-on-d-bus 2008-04-29 14:18:47.000000000 -0400
++++ libbonobo-2.22.0/configure.in 2008-04-29 14:19:06.000000000 -0400
+@@ -121,6 +121,8 @@ PKG_CHECK_MODULES(SERVER, \
+ gmodule-2.0 >= 2.0.1 \
+ ORBit-2.0 >= 2.4.0 \
+ ORBit-CosNaming-2.0 >= 2.4.0 \
++ dbus-1 >= 1.0.0 \
++ dbus-glib-1 >= 0.74 \
+ libxml-2.0 >= 2.4.20)
+ AC_SUBST(SERVER_LIBS)
+ AC_SUBST(SERVER_CFLAGS)
diff --git a/gnome-base/libbonobo/libbonobo-2.22.0-r1.ebuild b/gnome-base/libbonobo/libbonobo-2.22.0-r1.ebuild
new file mode 100644
index 000000000000..1097e856214a
--- /dev/null
+++ b/gnome-base/libbonobo/libbonobo-2.22.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libbonobo/libbonobo-2.22.0-r1.ebuild,v 1.1 2008/09/13 13:36:27 remi Exp $
+
+inherit gnome2 eutils autotools
+
+DESCRIPTION="GNOME CORBA framework"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc"
+
+RDEPEND=">=dev-libs/glib-2.8
+ >=gnome-base/orbit-2.14.0
+ >=dev-libs/libxml2-2.4.20
+ >=sys-apps/dbus-1.0.0
+ >=dev-libs/dbus-glib-0.74
+ >=dev-libs/popt-1.5
+ !gnome-base/bonobo-activation"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ x11-apps/xrdb
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable debug bonobo-activation-debug)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ sed -i -e '/DISABLE_DEPRECATED/d' \
+ "${S}/activation-server/Makefile.am" "${S}/activation-server/Makefile.in" \
+ "${S}/bonobo/Makefile.am" "${S}/bonobo/Makefile.in" \
+ "${S}/bonobo-activation/Makefile.am" "${S}/bonobo-activation/Makefile.in"
+
+ sed -i -e 's:-DG_DISABLE_DEPRECATED ::g' \
+ "${S}/tests/test-activation/Makefile.am" "${S}/tests/test-activation/Makefile.in"
+
+ # attach bonobo to the dbus session bus, fixes bug #236864
+ epatch "${FILESDIR}/${PN}-2.22.0-quit-with-dbus-session.patch"
+
+ eautoreconf
+}