summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-05 13:31:15 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-05 13:31:15 +0000
commitfaea198f166c24745e78d336843b97e80df00b5b (patch)
treee66e470a2362775a62fd2c7dcf80d1d82b05e5dd /gnome-extra/gnome-color-manager
parentProperly fix bug 350850 in making akonadi optional (diff)
downloadgentoo-2-faea198f166c24745e78d336843b97e80df00b5b.tar.gz
gentoo-2-faea198f166c24745e78d336843b97e80df00b5b.tar.bz2
gentoo-2-faea198f166c24745e78d336843b97e80df00b5b.zip
Fix building with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/gnome-color-manager')
-rw-r--r--gnome-extra/gnome-color-manager/ChangeLog7
-rw-r--r--gnome-extra/gnome-color-manager/files/gnome-color-manager-2.32.0-libnotify-0.7.patch27
-rw-r--r--gnome-extra/gnome-color-manager/gnome-color-manager-2.32.0.ebuild15
3 files changed, 44 insertions, 5 deletions
diff --git a/gnome-extra/gnome-color-manager/ChangeLog b/gnome-extra/gnome-color-manager/ChangeLog
index 002832d4299d..afc6cdae0fa9 100644
--- a/gnome-extra/gnome-color-manager/ChangeLog
+++ b/gnome-extra/gnome-color-manager/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/gnome-color-manager
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-color-manager/ChangeLog,v 1.2 2011/01/03 21:55:11 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-color-manager/ChangeLog,v 1.3 2011/02/05 13:31:15 ssuominen Exp $
+
+ 05 Feb 2011; Samuli Suominen <ssuominen@gentoo.org>
+ gnome-color-manager-2.32.0.ebuild,
+ +files/gnome-color-manager-2.32.0-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
03 Jan 2011; Gilles Dartiguelongue <eva@gentoo.org>
gnome-color-manager-2.32.0.ebuild:
diff --git a/gnome-extra/gnome-color-manager/files/gnome-color-manager-2.32.0-libnotify-0.7.patch b/gnome-extra/gnome-color-manager/files/gnome-color-manager-2.32.0-libnotify-0.7.patch
new file mode 100644
index 000000000000..7b3fe5b4273d
--- /dev/null
+++ b/gnome-extra/gnome-color-manager/files/gnome-color-manager-2.32.0-libnotify-0.7.patch
@@ -0,0 +1,27 @@
+--- src/gcm-session.c
++++ src/gcm-session.c
+@@ -28,6 +28,10 @@
+ #include <gconf/gconf-client.h>
+ #include <libnotify/notify.h>
+
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++
+ #include "egg-debug.h"
+ #include "gcm-dbus.h"
+ #include "gcm-client.h"
+@@ -145,7 +149,12 @@
+ NotifyNotification *notification;
+
+ /* show a bubble */
+- notification = notify_notification_new (title, message, GCM_STOCK_ICON, NULL);
++ notification = notify_notification_new (title, message, GCM_STOCK_ICON
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ , NULL);
++#endif
+ notify_notification_set_timeout (notification, GCM_SESSION_NOTIFY_TIMEOUT);
+ notify_notification_set_urgency (notification, NOTIFY_URGENCY_LOW);
+
diff --git a/gnome-extra/gnome-color-manager/gnome-color-manager-2.32.0.ebuild b/gnome-extra/gnome-color-manager/gnome-color-manager-2.32.0.ebuild
index 99ba610c8d0a..a6b387bb4c07 100644
--- a/gnome-extra/gnome-color-manager/gnome-color-manager-2.32.0.ebuild
+++ b/gnome-extra/gnome-color-manager/gnome-color-manager-2.32.0.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-color-manager/gnome-color-manager-2.32.0.ebuild,v 1.2 2011/01/03 21:55:11 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-color-manager/gnome-color-manager-2.32.0.ebuild,v 1.3 2011/02/05 13:31:15 ssuominen Exp $
EAPI="3"
GCONF_DEBUG="no"
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="Color profile manager for the GNOME desktop"
HOMEPAGE="http://projects.gnome.org/gnome-color-manager/"
@@ -42,5 +42,12 @@ DEPEND="${RDEPEND}
# FIXME: run test-suite with files on live file-system
RESTRICT="test"
-# Always enable tests since they are check_PROGRAMS anyway
-G2CONF="${G2CONF} --enable-tests --disable-packagekit"
+pkg_setup() {
+ # Always enable tests since they are check_PROGRAMS anyway
+ G2CONF="${G2CONF} --enable-tests --disable-packagekit"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+ gnome2_src_prepare
+}