summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-09-17 22:01:55 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-09-17 22:01:55 +0000
commit31fd1c8e7f7a48118f2dda76f2aad5a8f5769ae8 (patch)
treea941fd917f4bf381ed9b7114e48cb05807b0957c /gnome-extra/gnome-lirc-properties/gnome-lirc-properties-0.2.8.ebuild
parentmask gnome-lirc-properties (diff)
downloadgentoo-2-31fd1c8e7f7a48118f2dda76f2aad5a8f5769ae8.tar.gz
gentoo-2-31fd1c8e7f7a48118f2dda76f2aad5a8f5769ae8.tar.bz2
gentoo-2-31fd1c8e7f7a48118f2dda76f2aad5a8f5769ae8.zip
new package for controlling LIRC remotes
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'gnome-extra/gnome-lirc-properties/gnome-lirc-properties-0.2.8.ebuild')
-rw-r--r--gnome-extra/gnome-lirc-properties/gnome-lirc-properties-0.2.8.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnome-extra/gnome-lirc-properties/gnome-lirc-properties-0.2.8.ebuild b/gnome-extra/gnome-lirc-properties/gnome-lirc-properties-0.2.8.ebuild
new file mode 100644
index 000000000000..993b15e2e258
--- /dev/null
+++ b/gnome-extra/gnome-lirc-properties/gnome-lirc-properties-0.2.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-lirc-properties/gnome-lirc-properties-0.2.8.ebuild,v 1.1 2008/09/17 22:01:55 cardoe Exp $
+
+DESCRIPTION="GTK+ based utilty to configure LIRC remotes"
+HOMEPAGE="https://code.fluendo.com/remotecontrol/trac/
+ http://live.gnome.org/gnome-lirc-properties"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="policykit"
+
+RDEPEND=">=app-misc/lirc-0.8.4
+ >=dev-lang/python-2.4
+ >=sys-auth/policykit-0.7
+ >=gnome-extra/policykit-gnome-0.7"
+DEPEND=">=dev-util/intltool-0.35.0
+ app-text/gnome-doc-utils"
+
+# uses AC_PATH_PROG([lircd]), which is in /usr/sbin which is only in the path
+# for root
+RESTRICT="userpriv"
+
+src_compile() {
+ econf --with-lirc-confdir=/etc $(use_enable policykit policy-kit) || \
+ die "econf failed"
+
+ emake || die "emake failed"
+}