summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-04-21 18:25:56 +0000
committerPeter Volkov <pva@gentoo.org>2010-04-21 18:25:56 +0000
commited1898f03f6a33fba569e68dbd2ccc0d7eb1e92b (patch)
treea7822c7ca1f7929617cc40c498a124c6eec09a19 /gnome-extra/gpointing-device-settings/gpointing-device-settings-1.5.1.ebuild
parentamd64 stable wrt #316335 (diff)
downloadgentoo-2-ed1898f03f6a33fba569e68dbd2ccc0d7eb1e92b.tar.gz
gentoo-2-ed1898f03f6a33fba569e68dbd2ccc0d7eb1e92b.tar.bz2
gentoo-2-ed1898f03f6a33fba569e68dbd2ccc0d7eb1e92b.zip
Version bump, fixed HOMEPAGE, #316519, thank Samuli Suominen and Johannes Rauh for report.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/gpointing-device-settings/gpointing-device-settings-1.5.1.ebuild')
-rw-r--r--gnome-extra/gpointing-device-settings/gpointing-device-settings-1.5.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnome-extra/gpointing-device-settings/gpointing-device-settings-1.5.1.ebuild b/gnome-extra/gpointing-device-settings/gpointing-device-settings-1.5.1.ebuild
new file mode 100644
index 000000000000..2678f8ec95af
--- /dev/null
+++ b/gnome-extra/gpointing-device-settings/gpointing-device-settings-1.5.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gpointing-device-settings/gpointing-device-settings-1.5.1.ebuild,v 1.1 2010/04/21 18:25:56 pva Exp $
+
+GCONF_DEBUG="no"
+inherit eutils gnome2
+
+DESCRIPTION="A GTK+ based configuration utility for the synaptics driver"
+HOMEPAGE="http://live.gnome.org/GPointingDeviceSettings"
+SRC_URI="mirror://sourceforge.jp/gsynaptics/45812/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# recent enough x11-base/xorg-server required
+RDEPEND=">=dev-libs/glib-2.10
+ >=x11-libs/gtk+-2.14.0
+ >=gnome-base/gconf-2.24
+ >=gnome-base/gnome-settings-daemon-2.28
+ >=x11-libs/libXi-1.2
+ >=x11-libs/libX11-1.2.0
+ !<=x11-base/xorg-server-1.6.0
+ !gnome-extra/gsynaptics"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.19
+ >=dev-util/intltool-0.35.5"
+
+DOCS="MAINTAINERS NEWS TODO"
+
+src_install() {
+ gnome2_src_install
+
+ doicon data/touchpad.png
+ make_desktop_entry gpointing-device-settings \
+ gpointing-device-settings \
+ touchpad \
+ 'GNOME;GTK;Settings;HardwareSettings'
+}